upgrade to 0.998a
PR: 41173 Submitted by: Ports Fury
This commit is contained in:
parent
d75ba83d1e
commit
44e64ae118
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=63784
@ -7,7 +7,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= gretl
|
||||
PORTVERSION= 0.994
|
||||
PORTVERSION= 0.998a
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
@ -30,7 +30,7 @@ USE_LIBTOOL= yes
|
||||
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
CONFIGURE_ARGS= --with-gmake
|
||||
CONFIGURE_ARGS= --with-gmake --without-gmp
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
MAN1= gretl.1 gretl-config.1
|
||||
|
@ -1 +1 @@
|
||||
MD5 (gretl-0.994.tar.gz) = a4f69d758c52b9f60c74c85e50f0cdd9
|
||||
MD5 (gretl-0.998a.tar.gz) = 97a5e3803ed0ee58188c46e0f0a777b8
|
||||
|
@ -1,8 +1,8 @@
|
||||
--- gui/Makefile.in.orig Mon Apr 22 01:43:31 2002
|
||||
+++ gui/Makefile.in Thu May 2 01:49:12 2002
|
||||
@@ -41,21 +41,20 @@
|
||||
LIBS = `gnome-config --libs gnomeui print` `gtkextra-config --libs` ../lib/libgretl.la
|
||||
GUI_CFLAGS = `gnome-config --cflags gnomeui print` `gtkextra-config --cflags`
|
||||
--- gui/Makefile.in.orig Thu Jul 11 00:20:39 2002
|
||||
+++ gui/Makefile.in Sat Jul 27 09:04:18 2002
|
||||
@@ -44,8 +44,8 @@
|
||||
LIBS = $(GNOME_LIBS) $(GTK_EXTRA_LIBS) ../lib/libgretl.la
|
||||
GUI_CFLAGS = $(GNOME_CFLAGS) $(GTK_EXTRA_CFLAGS)
|
||||
desktopdir = $(gnome_prefix)/share/gnome/apps/Applications
|
||||
- mimedir = $(gnome_prefix)/share/mime-info
|
||||
- gpixmaps = $(gnome_prefix)/share/pixmaps
|
||||
@ -11,23 +11,25 @@
|
||||
ghelpdir = $(gnome_prefix)/share/gnome/help/gretl
|
||||
query_install_gnome = install-gnome
|
||||
else
|
||||
- LIBS = `gtk-config --libs` `gtkextra-config --libs` ../lib/libgretl.la
|
||||
- GUI_CFLAGS = `gtk-config --cflags` `gtkextra-config --cflags`
|
||||
+ LIBS = `$(GTK_CONFIG) --libs` `gtkextra-config --libs` ../lib/libgretl.la
|
||||
+ GUI_CFLAGS = `$(GTK_CONFIG) --cflags` `gtkextra-config --cflags`
|
||||
@@ -54,7 +54,7 @@
|
||||
endif
|
||||
ifeq ($(USE_NLS),yes)
|
||||
datadir = @datadir@
|
||||
- localedir = $(datadir)/locale
|
||||
+ localedir = $(prefix)/share/locale
|
||||
DEFS = -DLOCALEDIR=\"$(localedir)\"
|
||||
endif
|
||||
|
||||
override CFLAGS += $(PIXBUF_CFLAGS)
|
||||
override LIBS += $(PIXBUF_LIBS)
|
||||
@@ -63,7 +63,7 @@
|
||||
|
||||
# Directories
|
||||
-bindir = $(prefix)/bin
|
||||
bindir = $(prefix)/bin
|
||||
-gretldir = $(prefix)/share/gretl
|
||||
+gretldir = $(libdir)/gretl
|
||||
tooldir = $(topsrc)/tools
|
||||
libsrc = $(topsrc)/lib/src
|
||||
clisrc = $(topsrc)/cli
|
||||
@@ -90,7 +89,7 @@
|
||||
@@ -94,7 +94,7 @@
|
||||
$(LIBTOOL) $(INSTALL_PROGRAM) -s $(PROG) $(bindir)/$(PROG)
|
||||
|
||||
install-data: installdirs
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- lib/Makefile.in.orig Mon Apr 22 01:43:31 2002
|
||||
+++ lib/Makefile.in Wed May 1 23:59:51 2002
|
||||
--- lib/Makefile.in.orig Thu Jul 11 00:20:39 2002
|
||||
+++ lib/Makefile.in Sat Jul 27 08:40:14 2002
|
||||
@@ -11,8 +11,8 @@
|
||||
XML_CFLAGS = @XML_CFLAGS@
|
||||
XML_LIBS = @XML_LIBS@
|
||||
@ -11,7 +11,7 @@
|
||||
endif
|
||||
ifeq ($(INSTALL_DATA),)
|
||||
INSTALL_DATA = $(INSTALL) -m 644
|
||||
@@ -27,7 +27,7 @@
|
||||
@@ -28,7 +28,7 @@
|
||||
|
||||
# General compile options and libs:
|
||||
LIBGRETL = libgretl.la
|
||||
@ -20,7 +20,7 @@
|
||||
|
||||
#### End of system configuration section. ####
|
||||
|
||||
@@ -61,14 +61,14 @@
|
||||
@@ -65,15 +65,15 @@
|
||||
.PHONY:
|
||||
|
||||
install: $(LIBGRETL) install-data
|
||||
@ -33,8 +33,9 @@
|
||||
|
||||
install-data: installdirs
|
||||
$(INSTALL_DATA) $(srcdir)/*.h $(includedir)
|
||||
$(INSTALL_DATA) ../gretl.m4 $(aclocaldir)
|
||||
- $(INSTALL_PROGRAM) ../gretl-config $(bindir)
|
||||
+ $(INSTALL_SCRIPT) ../gretl-config $(bindir)
|
||||
|
||||
installdirs:
|
||||
$(topsrc)/tools/mkinstalldirs $(libdir) $(includedir)
|
||||
$(topsrc)/tools/mkinstalldirs $(libdir) $(includedir) $(aclocaldir)
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- plugin/Makefile.in.orig Thu Mar 28 07:05:24 2002
|
||||
+++ plugin/Makefile.in Thu May 2 01:46:10 2002
|
||||
--- plugin/Makefile.in.orig Thu Jul 11 00:20:39 2002
|
||||
+++ plugin/Makefile.in Sat Jul 27 08:43:08 2002
|
||||
@@ -2,6 +2,7 @@
|
||||
|
||||
prefix = @prefix@
|
||||
@ -8,7 +8,7 @@
|
||||
CC = @CC@
|
||||
CFLAGS = @CFLAGS@
|
||||
MAKE = @MAKE@
|
||||
@@ -21,7 +22,7 @@
|
||||
@@ -25,7 +26,7 @@
|
||||
endif
|
||||
|
||||
# Installation directory
|
||||
@ -16,19 +16,17 @@
|
||||
+gretldir = $(libdir)/gretl
|
||||
|
||||
LIBTOOL = $(topsrc)/libtool
|
||||
COMPILE = $(LIBTOOL) --mode=compile $(CC) -c -fPIC -DPIC $(CFLAGS)
|
||||
@@ -29,8 +30,8 @@
|
||||
COMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS)
|
||||
@@ -45,7 +46,7 @@
|
||||
query-ms-ole.lo=ms-ole.lo
|
||||
vpath %.c libole2
|
||||
vpath %.h libole2
|
||||
- LIBOLE2_CFLAGS = -I. `glib-config --cflags`
|
||||
+ LIBOLE2_CFLAGS = -I. `$(GLIB_CONFIG) --cflags`
|
||||
endif
|
||||
|
||||
GRETLINC = -I$(topsrc)/lib/src
|
||||
GRETLLIB = ../lib/libgretl.la
|
||||
-GTKINC = `gtk-config --cflags`
|
||||
-GTKLIB = `gtk-config --libs`
|
||||
+GTKINC = `$(GTK_CONFIG) --cflags`
|
||||
+GTKLIB = `$(GTK_CONFIG) --libs`
|
||||
|
||||
PLUGINS = stats_tables.so panel_data.so progress_bar.so \
|
||||
gnumeric_import.so excel_import.so
|
||||
@@ -85,15 +86,15 @@
|
||||
all: $(PLUGINS)
|
||||
@@ -98,15 +99,15 @@
|
||||
.PHONY:
|
||||
|
||||
install: $(PLUGINS) installdirs
|
||||
|
@ -1,10 +1,10 @@
|
||||
--- plugin/workbook.c.orig Thu Apr 11 05:33:44 2002
|
||||
+++ plugin/workbook.c Thu May 2 01:27:51 2002
|
||||
@@ -2,6 +2,7 @@
|
||||
|
||||
--- plugin/workbook.c.orig Fri May 31 22:22:42 2002
|
||||
+++ plugin/workbook.c Sat Jul 27 08:45:00 2002
|
||||
@@ -24,6 +24,7 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <glib.h>
|
||||
+#include <wchar.h>
|
||||
#include "biff.h"
|
||||
#include "importer.h"
|
||||
|
||||
#ifdef G_OS_WIN32
|
||||
# include "../winconfig.h"
|
||||
|
@ -16,6 +16,7 @@ include/gretl/graphing.h
|
||||
include/gretl/interact.h
|
||||
include/gretl/internal.h
|
||||
include/gretl/libgretl.h
|
||||
include/gretl/libprob.h
|
||||
include/gretl/monte_carlo.h
|
||||
include/gretl/nonparam.h
|
||||
include/gretl/printout.h
|
||||
@ -139,8 +140,10 @@ lib/gretl/gretl-logo.xpm
|
||||
lib/gretl/gretl.hlp
|
||||
lib/gretl/gretl.stamp
|
||||
lib/gretl/gretlcli.hlp
|
||||
lib/gretl/gretlcli.hlp.es
|
||||
lib/gretl/plugins/excel_import.so
|
||||
lib/gretl/plugins/gnumeric_import.so
|
||||
lib/gretl/plugins/mp_ols.so
|
||||
lib/gretl/plugins/panel_data.so
|
||||
lib/gretl/plugins/progress_bar.so
|
||||
lib/gretl/plugins/stats_tables.so
|
||||
@ -228,25 +231,26 @@ lib/gretl/scripts/testinp
|
||||
lib/gretl/scripts/wg_ps_descriptions
|
||||
lib/libgretl.a
|
||||
lib/libgretl.so
|
||||
lib/libgretl.so.12
|
||||
lib/libgretl.so.15
|
||||
share/aclocal/gretl.m4
|
||||
%%GNOME:%%share/gnome/apps/Applications/gretl.desktop
|
||||
%%GNOME:%%share/gnome/help/gretl/C/a3374.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/a3476.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/a3503.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/a3537.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/b3661.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c1058.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c1299.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/a3408.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/a3512.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/a3539.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/a3573.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/b3703.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c1067.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c1310.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c137.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c208.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c21.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c3260.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c3299.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c434.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c577.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c764.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c912.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c972.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c217.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c3294.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c3333.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c443.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c586.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c773.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c921.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c981.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/docbook.css
|
||||
%%GNOME:%%share/gnome/help/gretl/C/figures/adf1.png
|
||||
%%GNOME:%%share/gnome/help/gretl/C/figures/adf2.png
|
||||
@ -270,6 +274,7 @@ lib/libgretl.so.12
|
||||
%%GNOME:%%share/gnome/help/gretl/C/figures/plot_control.png
|
||||
%%GNOME:%%share/gnome/help/gretl/C/figures/resid.png
|
||||
%%GNOME:%%share/gnome/help/gretl/C/figures/scriptwin.png
|
||||
%%GNOME:%%share/gnome/help/gretl/C/figures/selector.png
|
||||
%%GNOME:%%share/gnome/help/gretl/C/figures/session.png
|
||||
%%GNOME:%%share/gnome/help/gretl/C/figures/tip.png
|
||||
%%GNOME:%%share/gnome/help/gretl/C/figures/tipbak.png
|
||||
@ -279,26 +284,26 @@ lib/libgretl.so.12
|
||||
%%GNOME:%%share/gnome/help/gretl/C/figures/yhat.png
|
||||
%%GNOME:%%share/gnome/help/gretl/C/index.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/topic.dat
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x1014.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x1047.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x1158.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x1223.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x1339.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x3138.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x3387.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x3455.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x490.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x537.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x585.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x619.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x646.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x1023.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x1056.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x1169.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x1234.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x1350.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x3167.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x3421.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x3489.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x499.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x546.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x594.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x628.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x655.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x69.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x732.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x741.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x84.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x852.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x882.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x896.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x948.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x861.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x891.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x905.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x957.html
|
||||
%%GNOME:%%share/gnome/mime-info/gretl.keys
|
||||
%%GNOME:%%share/gnome/mime-info/gretl.mime
|
||||
%%GNOME:%%share/gnome/pixmaps/gnome-application-x-gretldata.png
|
||||
|
@ -7,7 +7,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= gretl
|
||||
PORTVERSION= 0.994
|
||||
PORTVERSION= 0.998a
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
@ -30,7 +30,7 @@ USE_LIBTOOL= yes
|
||||
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
CONFIGURE_ARGS= --with-gmake
|
||||
CONFIGURE_ARGS= --with-gmake --without-gmp
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
MAN1= gretl.1 gretl-config.1
|
||||
|
@ -1 +1 @@
|
||||
MD5 (gretl-0.994.tar.gz) = a4f69d758c52b9f60c74c85e50f0cdd9
|
||||
MD5 (gretl-0.998a.tar.gz) = 97a5e3803ed0ee58188c46e0f0a777b8
|
||||
|
@ -1,8 +1,8 @@
|
||||
--- gui/Makefile.in.orig Mon Apr 22 01:43:31 2002
|
||||
+++ gui/Makefile.in Thu May 2 01:49:12 2002
|
||||
@@ -41,21 +41,20 @@
|
||||
LIBS = `gnome-config --libs gnomeui print` `gtkextra-config --libs` ../lib/libgretl.la
|
||||
GUI_CFLAGS = `gnome-config --cflags gnomeui print` `gtkextra-config --cflags`
|
||||
--- gui/Makefile.in.orig Thu Jul 11 00:20:39 2002
|
||||
+++ gui/Makefile.in Sat Jul 27 09:04:18 2002
|
||||
@@ -44,8 +44,8 @@
|
||||
LIBS = $(GNOME_LIBS) $(GTK_EXTRA_LIBS) ../lib/libgretl.la
|
||||
GUI_CFLAGS = $(GNOME_CFLAGS) $(GTK_EXTRA_CFLAGS)
|
||||
desktopdir = $(gnome_prefix)/share/gnome/apps/Applications
|
||||
- mimedir = $(gnome_prefix)/share/mime-info
|
||||
- gpixmaps = $(gnome_prefix)/share/pixmaps
|
||||
@ -11,23 +11,25 @@
|
||||
ghelpdir = $(gnome_prefix)/share/gnome/help/gretl
|
||||
query_install_gnome = install-gnome
|
||||
else
|
||||
- LIBS = `gtk-config --libs` `gtkextra-config --libs` ../lib/libgretl.la
|
||||
- GUI_CFLAGS = `gtk-config --cflags` `gtkextra-config --cflags`
|
||||
+ LIBS = `$(GTK_CONFIG) --libs` `gtkextra-config --libs` ../lib/libgretl.la
|
||||
+ GUI_CFLAGS = `$(GTK_CONFIG) --cflags` `gtkextra-config --cflags`
|
||||
@@ -54,7 +54,7 @@
|
||||
endif
|
||||
ifeq ($(USE_NLS),yes)
|
||||
datadir = @datadir@
|
||||
- localedir = $(datadir)/locale
|
||||
+ localedir = $(prefix)/share/locale
|
||||
DEFS = -DLOCALEDIR=\"$(localedir)\"
|
||||
endif
|
||||
|
||||
override CFLAGS += $(PIXBUF_CFLAGS)
|
||||
override LIBS += $(PIXBUF_LIBS)
|
||||
@@ -63,7 +63,7 @@
|
||||
|
||||
# Directories
|
||||
-bindir = $(prefix)/bin
|
||||
bindir = $(prefix)/bin
|
||||
-gretldir = $(prefix)/share/gretl
|
||||
+gretldir = $(libdir)/gretl
|
||||
tooldir = $(topsrc)/tools
|
||||
libsrc = $(topsrc)/lib/src
|
||||
clisrc = $(topsrc)/cli
|
||||
@@ -90,7 +89,7 @@
|
||||
@@ -94,7 +94,7 @@
|
||||
$(LIBTOOL) $(INSTALL_PROGRAM) -s $(PROG) $(bindir)/$(PROG)
|
||||
|
||||
install-data: installdirs
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- lib/Makefile.in.orig Mon Apr 22 01:43:31 2002
|
||||
+++ lib/Makefile.in Wed May 1 23:59:51 2002
|
||||
--- lib/Makefile.in.orig Thu Jul 11 00:20:39 2002
|
||||
+++ lib/Makefile.in Sat Jul 27 08:40:14 2002
|
||||
@@ -11,8 +11,8 @@
|
||||
XML_CFLAGS = @XML_CFLAGS@
|
||||
XML_LIBS = @XML_LIBS@
|
||||
@ -11,7 +11,7 @@
|
||||
endif
|
||||
ifeq ($(INSTALL_DATA),)
|
||||
INSTALL_DATA = $(INSTALL) -m 644
|
||||
@@ -27,7 +27,7 @@
|
||||
@@ -28,7 +28,7 @@
|
||||
|
||||
# General compile options and libs:
|
||||
LIBGRETL = libgretl.la
|
||||
@ -20,7 +20,7 @@
|
||||
|
||||
#### End of system configuration section. ####
|
||||
|
||||
@@ -61,14 +61,14 @@
|
||||
@@ -65,15 +65,15 @@
|
||||
.PHONY:
|
||||
|
||||
install: $(LIBGRETL) install-data
|
||||
@ -33,8 +33,9 @@
|
||||
|
||||
install-data: installdirs
|
||||
$(INSTALL_DATA) $(srcdir)/*.h $(includedir)
|
||||
$(INSTALL_DATA) ../gretl.m4 $(aclocaldir)
|
||||
- $(INSTALL_PROGRAM) ../gretl-config $(bindir)
|
||||
+ $(INSTALL_SCRIPT) ../gretl-config $(bindir)
|
||||
|
||||
installdirs:
|
||||
$(topsrc)/tools/mkinstalldirs $(libdir) $(includedir)
|
||||
$(topsrc)/tools/mkinstalldirs $(libdir) $(includedir) $(aclocaldir)
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- plugin/Makefile.in.orig Thu Mar 28 07:05:24 2002
|
||||
+++ plugin/Makefile.in Thu May 2 01:46:10 2002
|
||||
--- plugin/Makefile.in.orig Thu Jul 11 00:20:39 2002
|
||||
+++ plugin/Makefile.in Sat Jul 27 08:43:08 2002
|
||||
@@ -2,6 +2,7 @@
|
||||
|
||||
prefix = @prefix@
|
||||
@ -8,7 +8,7 @@
|
||||
CC = @CC@
|
||||
CFLAGS = @CFLAGS@
|
||||
MAKE = @MAKE@
|
||||
@@ -21,7 +22,7 @@
|
||||
@@ -25,7 +26,7 @@
|
||||
endif
|
||||
|
||||
# Installation directory
|
||||
@ -16,19 +16,17 @@
|
||||
+gretldir = $(libdir)/gretl
|
||||
|
||||
LIBTOOL = $(topsrc)/libtool
|
||||
COMPILE = $(LIBTOOL) --mode=compile $(CC) -c -fPIC -DPIC $(CFLAGS)
|
||||
@@ -29,8 +30,8 @@
|
||||
COMPILE = $(LIBTOOL) --mode=compile $(CC) -c $(CFLAGS)
|
||||
@@ -45,7 +46,7 @@
|
||||
query-ms-ole.lo=ms-ole.lo
|
||||
vpath %.c libole2
|
||||
vpath %.h libole2
|
||||
- LIBOLE2_CFLAGS = -I. `glib-config --cflags`
|
||||
+ LIBOLE2_CFLAGS = -I. `$(GLIB_CONFIG) --cflags`
|
||||
endif
|
||||
|
||||
GRETLINC = -I$(topsrc)/lib/src
|
||||
GRETLLIB = ../lib/libgretl.la
|
||||
-GTKINC = `gtk-config --cflags`
|
||||
-GTKLIB = `gtk-config --libs`
|
||||
+GTKINC = `$(GTK_CONFIG) --cflags`
|
||||
+GTKLIB = `$(GTK_CONFIG) --libs`
|
||||
|
||||
PLUGINS = stats_tables.so panel_data.so progress_bar.so \
|
||||
gnumeric_import.so excel_import.so
|
||||
@@ -85,15 +86,15 @@
|
||||
all: $(PLUGINS)
|
||||
@@ -98,15 +99,15 @@
|
||||
.PHONY:
|
||||
|
||||
install: $(PLUGINS) installdirs
|
||||
|
@ -1,10 +1,10 @@
|
||||
--- plugin/workbook.c.orig Thu Apr 11 05:33:44 2002
|
||||
+++ plugin/workbook.c Thu May 2 01:27:51 2002
|
||||
@@ -2,6 +2,7 @@
|
||||
|
||||
--- plugin/workbook.c.orig Fri May 31 22:22:42 2002
|
||||
+++ plugin/workbook.c Sat Jul 27 08:45:00 2002
|
||||
@@ -24,6 +24,7 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <glib.h>
|
||||
+#include <wchar.h>
|
||||
#include "biff.h"
|
||||
#include "importer.h"
|
||||
|
||||
#ifdef G_OS_WIN32
|
||||
# include "../winconfig.h"
|
||||
|
@ -16,6 +16,7 @@ include/gretl/graphing.h
|
||||
include/gretl/interact.h
|
||||
include/gretl/internal.h
|
||||
include/gretl/libgretl.h
|
||||
include/gretl/libprob.h
|
||||
include/gretl/monte_carlo.h
|
||||
include/gretl/nonparam.h
|
||||
include/gretl/printout.h
|
||||
@ -139,8 +140,10 @@ lib/gretl/gretl-logo.xpm
|
||||
lib/gretl/gretl.hlp
|
||||
lib/gretl/gretl.stamp
|
||||
lib/gretl/gretlcli.hlp
|
||||
lib/gretl/gretlcli.hlp.es
|
||||
lib/gretl/plugins/excel_import.so
|
||||
lib/gretl/plugins/gnumeric_import.so
|
||||
lib/gretl/plugins/mp_ols.so
|
||||
lib/gretl/plugins/panel_data.so
|
||||
lib/gretl/plugins/progress_bar.so
|
||||
lib/gretl/plugins/stats_tables.so
|
||||
@ -228,25 +231,26 @@ lib/gretl/scripts/testinp
|
||||
lib/gretl/scripts/wg_ps_descriptions
|
||||
lib/libgretl.a
|
||||
lib/libgretl.so
|
||||
lib/libgretl.so.12
|
||||
lib/libgretl.so.15
|
||||
share/aclocal/gretl.m4
|
||||
%%GNOME:%%share/gnome/apps/Applications/gretl.desktop
|
||||
%%GNOME:%%share/gnome/help/gretl/C/a3374.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/a3476.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/a3503.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/a3537.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/b3661.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c1058.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c1299.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/a3408.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/a3512.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/a3539.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/a3573.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/b3703.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c1067.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c1310.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c137.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c208.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c21.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c3260.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c3299.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c434.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c577.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c764.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c912.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c972.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c217.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c3294.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c3333.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c443.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c586.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c773.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c921.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/c981.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/docbook.css
|
||||
%%GNOME:%%share/gnome/help/gretl/C/figures/adf1.png
|
||||
%%GNOME:%%share/gnome/help/gretl/C/figures/adf2.png
|
||||
@ -270,6 +274,7 @@ lib/libgretl.so.12
|
||||
%%GNOME:%%share/gnome/help/gretl/C/figures/plot_control.png
|
||||
%%GNOME:%%share/gnome/help/gretl/C/figures/resid.png
|
||||
%%GNOME:%%share/gnome/help/gretl/C/figures/scriptwin.png
|
||||
%%GNOME:%%share/gnome/help/gretl/C/figures/selector.png
|
||||
%%GNOME:%%share/gnome/help/gretl/C/figures/session.png
|
||||
%%GNOME:%%share/gnome/help/gretl/C/figures/tip.png
|
||||
%%GNOME:%%share/gnome/help/gretl/C/figures/tipbak.png
|
||||
@ -279,26 +284,26 @@ lib/libgretl.so.12
|
||||
%%GNOME:%%share/gnome/help/gretl/C/figures/yhat.png
|
||||
%%GNOME:%%share/gnome/help/gretl/C/index.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/topic.dat
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x1014.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x1047.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x1158.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x1223.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x1339.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x3138.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x3387.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x3455.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x490.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x537.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x585.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x619.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x646.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x1023.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x1056.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x1169.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x1234.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x1350.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x3167.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x3421.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x3489.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x499.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x546.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x594.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x628.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x655.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x69.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x732.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x741.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x84.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x852.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x882.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x896.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x948.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x861.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x891.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x905.html
|
||||
%%GNOME:%%share/gnome/help/gretl/C/x957.html
|
||||
%%GNOME:%%share/gnome/mime-info/gretl.keys
|
||||
%%GNOME:%%share/gnome/mime-info/gretl.mime
|
||||
%%GNOME:%%share/gnome/pixmaps/gnome-application-x-gretldata.png
|
||||
|
Loading…
Reference in New Issue
Block a user