Upgrade to 20-2.5, and merge all info page to a BIG file.

This commit is contained in:
Vanilla I. Shu 1998-09-18 21:51:43 +00:00
parent c9e86380dc
commit 43bb420e1f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=13214
5 changed files with 27 additions and 74 deletions

View File

@ -1,22 +1,24 @@
# New ports collection makefile for: elisp-manual
# Version required: 19-2.4.2
# Date created: 18 November 1997
# Whom: Don Croyle <croyle@gelemna.ft-wayne.in.us>
# New ports collection makefile for: elisp-manual
# Version required: 20-2.5
# Date created: 18 November 1997
# Whom: Don Croyle <croyle@gelemna.ft-wayne.in.us>
#
# $Id$
# $Id: Makefile,v 1.1.1.1 1998/04/27 14:53:00 kuriyama Exp $
#
DISTNAME= elisp-manual-19-2.4.2
DISTNAME= elisp-manual-20-2.5
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNU}
MAINTAINER= croyle@gelemna.ft-wayne.in.us
GNU_CONFIGURE= yes
ALL_TARGET= elisp
post-install:
if [ ! -f ${PREFIX}/info/dir ]; then \
${SED} -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/info/dir; \
pre-install:
@if [ ! -f ${PREFIX}/info/dir ]; then \
${SED} -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/info/dir; \
fi
install-info ${PREFIX}/info/elisp ${PREFIX}/info/dir
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (elisp-manual-19-2.4.2.tar.gz) = 59cb5619db537ff1a5e3843b21b26d3e
MD5 (elisp-manual-20-2.5.tar.gz) = d11034684296881718ee4eedaa6de56a

View File

@ -1,34 +1,21 @@
--- Makefile.orig Tue Dec 17 06:48:54 1996
+++ Makefile Mon Apr 27 21:55:29 1998
@@ -20,7 +20,7 @@
--- Makefile.in.orig Sun Aug 30 02:38:17 1998
+++ Makefile.in Fri Sep 18 22:36:14 1998
@@ -47,7 +47,7 @@
# Unless you have a nonstandard Emacs installation, these shouldn't have to
# be changed.
-prefix = /usr/local
+prefix = ${PREFIX}
infodir = ${prefix}/info
# The name of the manual:
@@ -53,10 +53,9 @@
# We depend on makeinfo.c rather than makeinfo -- there's no need to rebuild
# everything just because makeinfo isn't part of the distribution.
-elisp: $(srcs) index.texi makeinfo.c
- $(MAKE) makeinfo
+elisp: $(srcs) index.texi
elisp: $(srcs) index.texi
rm -f elisp-*
- ./makeinfo elisp.texi
+ makeinfo elisp.texi
- makeinfo elisp.texi
+ makeinfo --no-split elisp.texi
elisp.dvi: $(srcs) index.texi texindex
elisp.dvi: $(srcs) index.texi
# Avoid losing old contents of aux file entirely.
@@ -82,8 +81,7 @@
@@ -73,8 +73,7 @@
fi
install: elisp
./mkinstalldirs $(infodir)
- ./mkinstalldirs $(infodir)
- cp elisp elisp-* $(infodir)
- @echo also add the line for elisp to $(infodir)/dir.
+ ${BSD_INSTALL_DATA} elisp elisp-* $(infodir)
+ cp elisp $(infodir)
${INSTALL_INFO} --dir-file=${infodir}/dir --info-file=${infodir}/elisp
installall: install
install -c texinfo.tex $(texmacrodir)

View File

@ -1,5 +1,5 @@
*** ../elisp-manual-19-2.4.2/elisp.texi.orig Mon Dec 16 17:37:22 1996
--- ../elisp-manual-19-2.4.2/elisp.texi Tue Nov 18 19:33:09 1997
*** elisp.texi.orig Mon Dec 16 17:37:22 1996
--- elisp.texi Tue Nov 18 19:33:09 1997
***************
*** 3,8 ****
--- 3,12 ----

View File

@ -1,40 +1,4 @@
@unexec install-info --delete %D/info/elisp %D/info/dir
info/elisp
info/elisp-1
info/elisp-2
info/elisp-3
info/elisp-4
info/elisp-5
info/elisp-6
info/elisp-7
info/elisp-8
info/elisp-9
info/elisp-10
info/elisp-11
info/elisp-12
info/elisp-13
info/elisp-14
info/elisp-15
info/elisp-16
info/elisp-17
info/elisp-18
info/elisp-19
info/elisp-20
info/elisp-21
info/elisp-22
info/elisp-23
info/elisp-24
info/elisp-25
info/elisp-26
info/elisp-27
info/elisp-28
info/elisp-29
info/elisp-30
info/elisp-31
info/elisp-32
info/elisp-33
info/elisp-34
info/elisp-35
info/elisp-36
@exec [ -f %D/info/dir ] || sed -ne '1,/Menu:/p' /usr/share/info/dir > %D/info/dir
@exec install-info %D/info/elisp %D/info/dir