use ComplexProgramTargetNoMan to avoid making html manpage with XFree86-4.
pre-install -> post-build to make reinstall target working. change maintainer to ports@ due to maintainer does not have FreeBSD box anymore. PR: 23444 Submitted by: myself
This commit is contained in:
parent
8c8f40c0b1
commit
43a2aac35f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=36469
@ -11,15 +11,16 @@ CATEGORIES= x11
|
||||
MASTER_SITES= ${MASTER_SITE_SUNSITE}
|
||||
MASTER_SITE_SUBDIR= X11/desktop
|
||||
|
||||
MAINTAINER= steve@farrell.org
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= xforms:${PORTSDIR}/x11-toolkits/xforms
|
||||
|
||||
USE_IMAKE= yes
|
||||
USE_XPM= yes
|
||||
NO_INSTALL_MANPAGES= yes
|
||||
|
||||
pre-install:
|
||||
@cd ${WRKSRC}/xbackdrop/backdrops; ${MV} index index.orig; ${SED} -e 's,/usr/lib,${PREFIX}/lib,' index.orig > index; ${RM} index.orig index~
|
||||
post-build:
|
||||
${RM} -f ${WRKSRC}/xbackdrop/backdrops/index~ ;\
|
||||
${PERL} -pi -e 's,/usr/lib,${PREFIX}/lib,' \
|
||||
${WRKSRC}/xbackdrop/backdrops/index
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- ./xprompt/Imakefile.orig Thu Sep 18 23:49:06 1997
|
||||
+++ ./xprompt/Imakefile Fri Sep 19 00:05:45 1997
|
||||
--- xprompt/Imakefile.orig Thu Jun 29 12:48:41 1995
|
||||
+++ xprompt/Imakefile Wed Nov 1 08:13:28 2000
|
||||
@@ -2,14 +2,14 @@
|
||||
SRCS = xprompt.c xprompt_cb.c xprompt_main.c
|
||||
OBJS = xprompt.o xprompt_cb.o xprompt_main.o
|
||||
@ -19,4 +19,5 @@
|
||||
+EXTRA_DEFINES = -DICON_DIR=\"${INCDIR}/pixmaps\"
|
||||
LDLIBS = $(EXTRA_LIBRARIES) $(EXTENSIONLIB) $(XLIB)
|
||||
|
||||
ComplexProgramTarget(xprompt)
|
||||
-ComplexProgramTarget(xprompt)
|
||||
+ComplexProgramTargetNoMan(xprompt)
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- ./tycoon/Imakefile.orig Thu Sep 18 23:46:15 1997
|
||||
+++ ./tycoon/Imakefile Thu Sep 18 23:47:03 1997
|
||||
@@ -26,8 +26,8 @@
|
||||
--- tycoon/Imakefile.orig Fri Jun 14 03:20:52 1996
|
||||
+++ tycoon/Imakefile Wed Nov 1 08:18:43 2000
|
||||
@@ -26,10 +26,10 @@
|
||||
VERSION=1.07o
|
||||
SRCS = wiconsh.c blip.c tycoon.c main.c DragAndDrop.c menu.c
|
||||
OBJS = wiconsh.o blip.o tycoon.o main.o DragAndDrop.o menu.o
|
||||
@ -11,3 +11,6 @@
|
||||
EXTRA_DEFINES = -DVERSION=\"$(VERSION)\"
|
||||
LDLIBS = $(EXTRA_LIBRARIES) $(XAWLIB) $(XMULIB) \
|
||||
$(XTOOLLIB) $(EXTENSIONLIB) $(XLIB)
|
||||
|
||||
-ComplexProgramTarget(tycoon)
|
||||
+ComplexProgramTargetNoMan(tycoon)
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- xbackdrop/Imakefile.orig Sat Mar 9 05:41:13 1996
|
||||
+++ xbackdrop/Imakefile Sun Nov 23 20:36:15 1997
|
||||
--- xbackdrop/Imakefile.orig Sat Mar 9 22:41:13 1996
|
||||
+++ xbackdrop/Imakefile Wed Nov 1 08:19:17 2000
|
||||
@@ -1,24 +1,28 @@
|
||||
-XBACKDROP_DIR = /usr/lib/X11/backdrops
|
||||
+XCOMM
|
||||
@ -24,7 +24,8 @@
|
||||
EXTRA_DEFINES = -DXBACKDROP_DIR=\"$(XBACKDROP_DIR)\"
|
||||
LDLIBS = $(EXTRA_LIBRARIES) $(EXTENSIONLIB) $(XLIB)
|
||||
|
||||
ComplexProgramTarget(xbackdrop)
|
||||
-ComplexProgramTarget(xbackdrop)
|
||||
+ComplexProgramTargetNoMan(xbackdrop)
|
||||
|
||||
-install:: xbackdrop @@\
|
||||
+install:: xbackdrop @@\
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- ./xchooser/Imakefile.orig Fri Sep 19 00:02:41 1997
|
||||
+++ ./xchooser/Imakefile Fri Sep 19 00:04:39 1997
|
||||
--- xchooser/Imakefile.orig Sun Oct 15 19:06:15 1995
|
||||
+++ xchooser/Imakefile Wed Nov 1 08:12:46 2000
|
||||
@@ -2,14 +2,14 @@
|
||||
SRCS = xchooser.c xchooser_cb.c xchooser_main.c
|
||||
OBJS = xchooser.o xchooser_cb.o xchooser_main.o
|
||||
@ -14,9 +14,10 @@
|
||||
|
||||
|
||||
-EXTRA_INCLUDES = -I/usr/local/include -I/u/grad/mitnits/lib -I.
|
||||
+EXTRA_INCLUDES = -I.
|
||||
-EXTRA_DEFINES = -DICON_DIR=\"/usr/include/X11/pixmaps\"
|
||||
+EXTRA_INCLUDES = -I.
|
||||
+EXTRA_DEFINES = -DICON_DIR=\"${INCDIR}/pixmaps\"
|
||||
LDLIBS = $(EXTRA_LIBRARIES) $(EXTENSIONLIB) $(XLIB)
|
||||
|
||||
ComplexProgramTarget(xchooser)
|
||||
-ComplexProgramTarget(xchooser)
|
||||
+ComplexProgramTargetNoMan(xchooser)
|
||||
|
@ -1,15 +1,16 @@
|
||||
--- ./fclock/Imakefile.orig Thu Sep 18 23:52:13 1997
|
||||
+++ ./fclock/Imakefile Thu Sep 18 23:52:46 1997
|
||||
--- fclock/Imakefile.orig Tue Sep 26 20:53:47 1995
|
||||
+++ fclock/Imakefile Wed Nov 1 08:18:31 2000
|
||||
@@ -1,9 +1,9 @@
|
||||
|
||||
SRCS = clock_main.c
|
||||
OBJS = clock_main.o
|
||||
-EXTRA_LIBRARIES = -L/usr/local/lib -lforms -lXpm -lm
|
||||
+EXTRA_LIBRARIES = -lxforms -lXpm -lm
|
||||
-EXTRA_INCLUDES = -I/usr/local/include -I.
|
||||
+EXTRA_INCLUDES = -I.
|
||||
-EXTRA_DEFINES = -DICON_DIR=\"/usr/include/X11/pixmaps\"
|
||||
+EXTRA_LIBRARIES = -lxforms -lXpm -lm
|
||||
+EXTRA_INCLUDES = -I.
|
||||
+EXTRA_DEFINES = -DICON_DIR=\"${INCDIR}/pixmaps/\"
|
||||
LDLIBS = $(EXTRA_LIBRARIES) $(EXTENSIONLIB) $(XLIB)
|
||||
|
||||
ComplexProgramTarget(fclock)
|
||||
-ComplexProgramTarget(fclock)
|
||||
+ComplexProgramTargetNoMan(fclock)
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- tyman/Imakefile.orig Thu Sep 18 23:53:43 1997
|
||||
+++ tyman/Imakefile Fri Sep 19 00:07:48 1997
|
||||
--- tyman/Imakefile.orig Fri Mar 1 22:37:02 1996
|
||||
+++ tyman/Imakefile Wed Nov 1 08:11:48 2000
|
||||
@@ -2,14 +2,14 @@
|
||||
SRCS = tyman.c tyman_cb.c tyman_main.c
|
||||
OBJS = tyman.o tyman_cb.o tyman_main.o
|
||||
@ -14,9 +14,10 @@
|
||||
|
||||
|
||||
-EXTRA_INCLUDES = -I/usr/local/include -I/u/grad/mitnits/lib -I.
|
||||
+EXTRA_INCLUDES = -I.
|
||||
-EXTRA_DEFINES = -DICON_DIR=\"/usr/include/X11/pixmaps\"
|
||||
+EXTRA_INCLUDES = -I.
|
||||
+EXTRA_DEFINES = -DICON_DIR=\"${INCDIR}/pixmaps/\"
|
||||
LDLIBS = $(EXTRA_LIBRARIES) $(EXTENSIONLIB) $(XLIB)
|
||||
|
||||
ComplexProgramTarget(tyman)
|
||||
-ComplexProgramTarget(tyman)
|
||||
+ComplexProgramTargetNoMan(tyman)
|
||||
|
Loading…
Reference in New Issue
Block a user