graphics/klatexformula:

- Update to 4.0.0 for Qt 5
- Remove stale patch
- Update WWW

PR:		232747
Approved by:	maintainer timeout (14 days)
This commit is contained in:
Max Brazhnikov 2018-11-11 11:47:09 +00:00
parent 0307c409d0
commit 43974ea389
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=484687
6 changed files with 70 additions and 58 deletions

View File

@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= klatexformula
PORTVERSION= 3.2.11
PORTREVISION= 3
PORTVERSION= 4.0.0
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@ -14,18 +13,18 @@ LICENSE= GPLv2
BUILD_DEPENDS= help2man:misc/help2man
USES= cmake:outsource desktop-file-utils ghostscript:run \
qt:4 shared-mime-info localbase
USE_QT= gui xml dbus designer_build linguisttools_build \
qmake_build moc_build rcc_build uic_build
qt:5 shared-mime-info tar:bzip2 localbase
USE_QT= core dbus gui sql svg widgets x11extras xml \
buildtools_build designer_build linguisttools_build \
qmake_build uitools_build
USE_TEX= latex dvipsk
CMAKE_ARGS= -DQT_QMAKE_EXECUTABLE_FINDQT=${QMAKE} \
-DKLF_BUILD_KTEXTEDITORPLUGIN=off \
-DKLF_INSTALL_POST_UPDATEMIMEDATABASE=off \
USE_LDCONFIG= yes
CMAKE_ARGS= -DKLF_INSTALL_POST_UPDATEMIMEDATABASE=off \
-DKLF_INSTALL_SHARE_MAN1_DIR=man/man1
PLIST_SUB= VERSION=${PORTVERSION}
post-patch:
${REINPLACE_CMD} '/link_libraries(klatexformula /s,), ${LIBS} -lX11),' \
${WRKSRC}/src/CMakeLists.txt
${REINPLACE_CMD} '/CMAKE_SYSTEM_NAME STREQUAL/s,Linux,FreeBSD,' \
${WRKSRC}/src/klftools/CMakeLists.txt
.include <bsd.port.mk>

View File

@ -1,2 +1,3 @@
SHA256 (klatexformula-3.2.11.tar.gz) = 8f0c26926c24e4987e785b69af30a35424b2fb98e7308c2dbbb606887842d5f2
SIZE (klatexformula-3.2.11.tar.gz) = 3234019
TIMESTAMP = 1540659053
SHA256 (klatexformula-4.0.0.tar.bz2) = 161d43ab02108a627c06e1b8d9b1918a1a327aa74bc35d8609fcd68f2926c6d0
SIZE (klatexformula-4.0.0.tar.bz2) = 4413235

View File

@ -0,0 +1,10 @@
--- src/klftools/klfadvancedconfigeditor.cpp.orig 2017-02-07 07:22:39 UTC
+++ src/klftools/klfadvancedconfigeditor.cpp
@@ -27,6 +27,7 @@
#include <QStandardItemEditorCreator>
#include <QMessageBox>
#include <QLineEdit>
+#include <QAction>
#include <klfitemviewsearchtarget.h>
#include "klfadvancedconfigeditor.h"

View File

@ -1,20 +0,0 @@
--- src/klftools/klfutil.cpp.orig 2014-07-28 22:23:49 UTC
+++ src/klftools/klfutil.cpp
@@ -853,7 +853,7 @@ KLF_EXPORT QVariant klfLoadVariantFromTe
// 3
"(?:" RX_COORD_SEP "|\\s*([+])\\s*)"
//4 5 6
- "(" RX_INT ")(?:"RX_COORD_SEP"|\\s*([x])\\s*)(" RX_INT ")\\s*\\)?");
+ "(" RX_INT ")(?:" RX_COORD_SEP "|\\s*([x])\\s*)(" RX_INT ")\\s*\\)?");
static const int RECTRX_X1 = 1, RECTRX_Y1 = 2, RECTRX_MIDDLESEP_PLUS = 3,
RECTRX_X2orW = 4, RECTRX_LASTSEP_X = 5, RECTRX_Y2orH = 6;
@@ -866,7 +866,7 @@ KLF_EXPORT QVariant klfLoadVariantFromTe
// 1 2 3
QRegExp brushrx("^(?:q?brush)?\\(?\\s*(?:([A-Za-z_]\\w*)" RX_COORD_SEP ")?(\\d+)" RX_COORD_SEP "(\\d+)"
// 4 5 6
- RX_COORD_SEP "(\\d+)" "("RX_COORD_SEP "(\\d+))?" "\\s*\\)?", Qt::CaseInsensitive);
+ RX_COORD_SEP "(\\d+)" "(" RX_COORD_SEP "(\\d+))?" "\\s*\\)?", Qt::CaseInsensitive);
static const int BRUSHRX_STYLE = 1, BRUSHRX_R = 2, BRUSHRX_G = 3, BRUSHRX_B = 4, BRUSHRX_A = 6;
// 1 2

View File

@ -1,7 +1,7 @@
KLatexFormula is a Qt 4 program to easily get an image from a LaTeX
KLatexFormula is a Qt program to easily get an image from a LaTeX
formula. Just enter a formula, click "Evaluate", then you can
drag & drop or copy the resulting image to another location (an
OpenOffice document, for example) or save it as an image (many
formats are available).
WWW: http://klatexformula.sourceforge.net
WWW: https://klatexformula.sourceforge.io

View File

@ -1,45 +1,67 @@
bin/klatexformula
bin/klatexformula_cmdl
include/klfapp/klfconfig.h
include/klfapp/klfdbus.h
include/klfapp/klflatexedit.h
include/klfapp/klflatexsymbols.h
include/klfapp/klflib.h
include/klfapp/klflibbrowser.h
include/klfapp/klflibdbengine.h
include/klfapp/klflibentryeditor.h
include/klfapp/klfliblegacyengine.h
include/klfapp/klflibview.h
include/klfapp/klfmain.h
include/klfapp/klfmainwin.h
include/klfapp/klfmime.h
include/klfapp/klfpluginiface.h
include/klfapp/klfsettings.h
include/klfapp/klfstylemanager.h
include/klfbackend/klfbackend.h
include/klfbackend/klfblockprocess.h
include/klfbackend/klfdebug.h
include/klfbackend/klfdefs.h
include/klfbackend/klffilterprocess.h
include/klfbackend/klflatexpreviewthread.h
include/klfbackend/klfuserscript.h
include/klftools/klfadvancedconfigeditor.h
include/klftools/klfcolorchooser.h
include/klftools/klfconfigbase.h
include/klftools/klfdatautil.h
include/klftools/klfdebug.h
include/klftools/klfdefs.h
include/klftools/klfdisplaylabel.h
include/klftools/klfenumlistwidget.h
include/klftools/klffactory.h
include/klftools/klfflowlayout.h
include/klftools/klfflowlistwidget.h
include/klftools/klfguiutil.h
include/klftools/klfitemviewsearchtarget.h
include/klftools/klfiteratorsearchable.h
include/klftools/klflatexedit.h
include/klftools/klfpathchooser.h
include/klftools/klfpixmapbutton.h
include/klftools/klfpobj.h
include/klftools/klfpobjeditwidget.h
include/klftools/klfprogerr.h
include/klftools/klfrelativefont.h
include/klftools/klfsearchbar.h
include/klftools/klfstyle.h
include/klftools/klfsidewidget.h
include/klftools/klfsysinfo.h
include/klftools/klfunitinput.h
include/klftools/klfutil.h
include/klftools/qtcolortriangle.h
lib/libklfapp.a
lib/libklfbackend.a
lib/libklftools.a
lib/libklfbackend.so
lib/libklfbackend.so.4
lib/libklfbackend_auto.a
lib/libklftools.so
lib/libklftools.so.4
man/man1/klatexformula.1.gz
man/man1/klatexformula_cmdl.1.gz
share/applications/klatexformula.desktop
share/klatexformula/rccresources/klfbaseplugins-%%VERSION%%.rcc
%%DATADIR%%/userscripts/customtemplate.klfuserscript/customtemplate.py
%%DATADIR%%/userscripts/customtemplate.klfuserscript/customtemplate_input.ui
%%DATADIR%%/userscripts/customtemplate.klfuserscript/scriptinfo.xml
%%DATADIR%%/userscripts/dvipng-backend.klfuserscript/dvipng-backend.py
%%DATADIR%%/userscripts/dvipng-backend.klfuserscript/dvipng_config.ui
%%DATADIR%%/userscripts/dvipng-backend.klfuserscript/scriptinfo.xml
%%DATADIR%%/userscripts/gif-convert.klfuserscript/gif-convert-export-profiles.xml
%%DATADIR%%/userscripts/gif-convert.klfuserscript/gif-convert.py
%%DATADIR%%/userscripts/gif-convert.klfuserscript/gif-convert_config.ui
%%DATADIR%%/userscripts/gif-convert.klfuserscript/scriptinfo.xml
%%DATADIR%%/userscripts/inkscapeformats.klfuserscript/config.ui
%%DATADIR%%/userscripts/inkscapeformats.klfuserscript/inkscape-export-profiles.xml
%%DATADIR%%/userscripts/inkscapeformats.klfuserscript/inkscapeformats.py
%%DATADIR%%/userscripts/inkscapeformats.klfuserscript/scriptinfo.xml
%%DATADIR%%/userscripts/klffeynmf.klfuserscript/inputform.ui
%%DATADIR%%/userscripts/klffeynmf.klfuserscript/klffeynmf.py
%%DATADIR%%/userscripts/klffeynmf.klfuserscript/scriptinfo.xml
%%DATADIR%%/userscripts/pyklfuserscript/__init__.py
%%DATADIR%%/userscripts/svg-dvisvgm.klfuserscript/config.ui
%%DATADIR%%/userscripts/svg-dvisvgm.klfuserscript/export-profiles.xml
%%DATADIR%%/userscripts/svg-dvisvgm.klfuserscript/scriptinfo.xml
%%DATADIR%%/userscripts/svg-dvisvgm.klfuserscript/svg-dvisvgm.py
share/mime/packages/klatexformula-mime.xml
share/pixmaps/klatexformula-128.png
share/pixmaps/klatexformula-16.png