New port alleyoop version 0.8.3: A graphical front-end to Valgrind
memory checker
This commit is contained in:
parent
4435c6db78
commit
43886434ac
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=137701
@ -30,6 +30,7 @@
|
||||
SUBDIR += ald
|
||||
SUBDIR += alf
|
||||
SUBDIR += allegro
|
||||
SUBDIR += alleyoop
|
||||
SUBDIR += anjuta
|
||||
SUBDIR += antlr
|
||||
SUBDIR += apache-ant
|
||||
|
47
devel/alleyoop/Makefile
Normal file
47
devel/alleyoop/Makefile
Normal file
@ -0,0 +1,47 @@
|
||||
# New ports collection makefile for: Alleyoop
|
||||
# Date created: Fri Jun 17 23:52:44 UTC 2005
|
||||
# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= alleyoop
|
||||
PORTVERSION= 0.8.3
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= lioux@FreeBSD.org
|
||||
COMMENT= A graphical front-end to Valgrind memory checker
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libbfd.a:${PORTSDIR}/devel/libbfd \
|
||||
${GNULIBIBERTY_WRKSRC}/libiberty.a:${PORTSDIR}/devel/gnulibiberty:build \
|
||||
${LOCALBASE}/include/libelf/elf_repl.h:${PORTSDIR}/devel/libelf
|
||||
RUN_DEPENDS= valgrind:${PORTSDIR}/devel/valgrind
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_X_PREFIX= yex
|
||||
USE_GETTEXT= yes
|
||||
USE_REINPLACE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GNOME= gnomehier \
|
||||
gconf2 \
|
||||
glib20 \
|
||||
gtk20 \
|
||||
libglade2 \
|
||||
libgnome \
|
||||
libgnomeui \
|
||||
pango
|
||||
|
||||
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${GNULIBIBERTY_WRKSRC} \
|
||||
${LDFLAGS} -L${LOCALBASE}/lib"
|
||||
|
||||
GCONF_SCHEMAS= ${PORTNAME}.schemas
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
GNULIBIBERTY= ${PORTSDIR}/devel/gnulibiberty
|
||||
GNULIBIBERTY_WRKSRC!= cd ${PORTSDIR}/devel/gnulibiberty && ${MAKE} -V WRKSRC
|
||||
|
||||
.include <bsd.port.post.mk>
|
2
devel/alleyoop/distinfo
Normal file
2
devel/alleyoop/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
MD5 (alleyoop-0.8.3.tar.gz) = 699b57bc6c0e4411c22739f61967c1ac
|
||||
SIZE (alleyoop-0.8.3.tar.gz) = 301948
|
14
devel/alleyoop/files/patch-configure
Normal file
14
devel/alleyoop/files/patch-configure
Normal file
@ -0,0 +1,14 @@
|
||||
--- configure.orig Sat Jun 18 00:47:36 2005
|
||||
+++ configure Sat Jun 18 00:48:09 2005
|
||||
@@ -7172,11 +7172,9 @@
|
||||
#endif
|
||||
/* We use char because int might match the return type of a gcc2
|
||||
builtin and then its argument prototype would still apply. */
|
||||
-char bfd_get_error ();
|
||||
int
|
||||
main ()
|
||||
{
|
||||
-bfd_get_error ();
|
||||
;
|
||||
return 0;
|
||||
}
|
20
devel/alleyoop/files/patch-src::legolas.c
Normal file
20
devel/alleyoop/files/patch-src::legolas.c
Normal file
@ -0,0 +1,20 @@
|
||||
--- src/legolas.c.orig Sun Jan 18 16:46:00 2004
|
||||
+++ src/legolas.c Sat Jun 18 01:05:39 2005
|
||||
@@ -25,7 +25,7 @@
|
||||
#include <config.h>
|
||||
#endif
|
||||
|
||||
-#include <elf.h>
|
||||
+#include <libelf/libelf.h>
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
@@ -130,7 +130,7 @@
|
||||
case EM_RH32: return "TRW RH-32";
|
||||
case EM_RCE: return "Motorola RCE";
|
||||
case EM_ARM: return "ARM";
|
||||
- case EM_FAKE_ALPHA: return "Digital Alpha";
|
||||
+ case EM_ALPHA: return "Digital Alpha";
|
||||
case EM_SH: return "Hitachi SH";
|
||||
case EM_SPARCV9: return "SPARC v9 64-bit";
|
||||
case EM_TRICORE: return "Siemens Tricore";
|
16
devel/alleyoop/pkg-descr
Normal file
16
devel/alleyoop/pkg-descr
Normal file
@ -0,0 +1,16 @@
|
||||
[ excerpt from developer's www site ]
|
||||
|
||||
Alleyoop is a graphical front-end to the increasingly popular
|
||||
Valgrind memory checker for x86 GNU/Linux using the Gtk+ widget
|
||||
set and other GNOME libraries for the X-Windows environment.
|
||||
|
||||
Features include a right-click context menu to intelligently suppress
|
||||
errors or launch an editor on the source file/jumping to the exact
|
||||
line of the error condition. A searchbar at the top of the viewer
|
||||
can be used to limit the viewable errors to those that match the
|
||||
regex criteria entered. Also included is a fully functional
|
||||
Suppressions editor.
|
||||
|
||||
WWW: http://alleyoop.sourceforge.net/
|
||||
|
||||
-- lioux@FreeBSD.org
|
35
devel/alleyoop/pkg-plist
Normal file
35
devel/alleyoop/pkg-plist
Normal file
@ -0,0 +1,35 @@
|
||||
bin/alleyoop
|
||||
share/locale/az/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/ca/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/cs/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/de/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/el/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/en_CA/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/en_GB/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/es/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/fr/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/ga/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/gu/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/hr/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/it/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/ja/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/mn/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/ms/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/nb/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/nl/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/no/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/pl/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/pt/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/ru/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/sk/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/sq/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/sr/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/sr@Latn/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/sv/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/uk/LC_MESSAGES/alleyoop.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/alleyoop.mo
|
||||
@exec rmdir %D/share/pixmaps 2>/dev/null || true
|
||||
@unexec rmdir %D/share/pixmaps 2>/dev/null || true
|
||||
@unexec rmdir %D/etc/gconf/schemas 2>/dev/null || true
|
||||
@unexec rmdir %D/etc/gconf 2>/dev/null || true
|
Loading…
Reference in New Issue
Block a user