Update to 2.16.2.

This commit is contained in:
Joe Marcus Clarke 2006-11-08 05:17:13 +00:00
parent ed945071b5
commit 4364d7029c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=176784
4 changed files with 14 additions and 33 deletions

View File

@ -7,8 +7,7 @@
#
PORTNAME= gnome-power-manager
PORTVERSION= 2.16.1
PORTREVISION= 1
PORTVERSION= 2.16.2
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@ -29,10 +28,17 @@ INSTALLS_ICONS= yes
USE_AUTOTOOLS= libtool:15
USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui libwnck \
gnomedocutils
CONFIGURE_ARGS= --disable-icon-framing
CONFIGURE_ARGS= --disable-icon-framing \
--docdir=${PREFIX}/share/doc/${PORTNAME} \
--with-doc-dir=${PREFIX}/share/doc \
--disable-docbook-docs
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
GCONF_SCHEMAS= gnome-power-manager.schemas
post-patch:
@${REINPLACE_CMD} -e 's|-lresolv||' \
${WRKSRC}/configure
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
MD5 (gnome2/gnome-power-manager-2.16.1.tar.bz2) = 6798ee24e5e94befab5a7584c19771cb
SHA256 (gnome2/gnome-power-manager-2.16.1.tar.bz2) = c2bddef973b8a72b8da03b2cffad5107bfaefb64bd42a0763d9d925e222a3490
SIZE (gnome2/gnome-power-manager-2.16.1.tar.bz2) = 1862984
MD5 (gnome2/gnome-power-manager-2.16.2.tar.bz2) = e7af47f4d49f7a10728216922dc82b4b
SHA256 (gnome2/gnome-power-manager-2.16.2.tar.bz2) = a0894478b9f5e7fd48a3cf8f7abd8fe27b74fc9dec165c603d3840416b12eae9
SIZE (gnome2/gnome-power-manager-2.16.2.tar.bz2) = 1863372

View File

@ -1,27 +0,0 @@
Index: gpm-manager.c
===================================================================
RCS file: /cvs/gnome/gnome-power-manager/src/gpm-manager.c,v
retrieving revision 1.172.2.2
diff -u -r1.172.2.2 gpm-manager.c
--- src/gpm-manager.c 19 Oct 2006 16:47:59 -0000 1.172.2.2
+++ src/gpm-manager.c 6 Nov 2006 19:02:16 -0000
@@ -680,6 +680,10 @@
manager->priv->dpms_throttle_id = 0;
}
} else {
+ /* if throttle already exists then remove */
+ if (manager->priv->dpms_throttle_id > 0) {
+ gpm_screensaver_remove_throttle (manager->priv->screensaver, manager->priv->dpms_throttle_id);
+ }
manager->priv->dpms_throttle_id = gpm_screensaver_add_throttle (manager->priv->screensaver, _("Display power management activated"));
}
}
@@ -2863,6 +2867,8 @@
/* Do we ignore inhibit requests? */
manager->priv->ignore_inhibits = gconf_client_get_bool (manager->priv->gconf_client,
GPM_PREF_IGNORE_INHIBITS, NULL);
+ /* set no throttle */
+ manager->priv->dpms_throttle_id = -1;
}
/**

View File

@ -218,6 +218,7 @@ share/icons/hicolor/scalable/apps/gpm-ups-100-charging.svg
share/icons/hicolor/scalable/apps/gpm-ups-100.svg
share/icons/hicolor/scalable/apps/gpm-ups-charged.svg
share/icons/hicolor/scalable/apps/gpm-ups-missing.svg
share/locale/ar/LC_MESSAGES/gnome-power-manager.mo
share/locale/bg/LC_MESSAGES/gnome-power-manager.mo
share/locale/bn/LC_MESSAGES/gnome-power-manager.mo
share/locale/bn_IN/LC_MESSAGES/gnome-power-manager.mo
@ -237,6 +238,7 @@ share/locale/fi/LC_MESSAGES/gnome-power-manager.mo
share/locale/fr/LC_MESSAGES/gnome-power-manager.mo
share/locale/gl/LC_MESSAGES/gnome-power-manager.mo
share/locale/gu/LC_MESSAGES/gnome-power-manager.mo
share/locale/he/LC_MESSAGES/gnome-power-manager.mo
share/locale/hi/LC_MESSAGES/gnome-power-manager.mo
share/locale/hu/LC_MESSAGES/gnome-power-manager.mo
share/locale/it/LC_MESSAGES/gnome-power-manager.mo