Resurrect, overhaul, and maintain audio/aylet. Project page is available. The

GUI functionality of the former slave port (audio/xaylet) is now an option of
audio/aylet without a slave port.

Modify MOVED to document the changes.
This commit is contained in:
Emanuel Haupt 2017-05-08 14:47:33 +00:00
parent 32a389c9f9
commit 432eadbca7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=440435
7 changed files with 83 additions and 2 deletions

3
MOVED
View File

@ -2095,9 +2095,7 @@ security/libfwbuilder||2011-05-02|libfwbuilder merged into fwbuilder
games/monopd||2011-05-03|Removed, depends on an expired library: devel/libcapsinetwork
devel/libcapsinetwork||2011-05-03|Has expired: Upstream disappeared and distfile is no longer available
audio/albumart||2011-05-03|Has expired: Upstream disappeared and distfile is no longer available
audio/aylet||2011-05-03|Has expired: Upstream disappeared and distfile is no longer available
audio/cantus||2011-05-03|Has expired: Upstream disappeared and distfile is no longer available
audio/xaylet||2011-05-03|Has expired: Upstream disappeared and distfile is no longer available
science/oases||2011-05-03|Has expired: Upstream disappeared and distfile is no longer available
shells/pash||2011-05-03|Has expired: Upstream disappeared and distfile is no longer available
www/codeigniter-devel||2011-05-03|Removed
@ -9380,3 +9378,4 @@ devel/ccons||2017-05-07|Has expired: Unfetchable for more than six months (googl
chinese/fortune||2017-05-07|Has expired: Unfetchable for more than six months (google code has gone away)
benchmarks/gobench||2017-05-07|Has expired: Builds each time it runs
sysutils/grok||2017-05-07|Has expired: Unfetchable for more than six months (google code has gone away)
audio/xaylet|audio/aylet|2017-05-07|Moved to a single port with GUI option

View File

@ -47,6 +47,7 @@
SUBDIR += autocd
SUBDIR += autotalent
SUBDIR += autozen
SUBDIR += aylet
SUBDIR += baresip
SUBDIR += baudline
SUBDIR += bcg729

30
audio/aylet/Makefile Normal file
View File

@ -0,0 +1,30 @@
# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
# $FreeBSD$
PORTNAME= aylet
PORTVERSION= 0.5
PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://www.worldofspectrum.org/pub/sinclair/music/players-unix/ \
LOCAL/ehaupt
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Aylet plays music files in the .ay format
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
USES= gettext-runtime pkgconfig
OPTIONS_DEFINE= GUI
OPTIONS_DEFAULT=GUI
OPTIONS_SUB= yes
GUI_USE= XORG=x11,xext,xi GNOME=gtk12
ALL_TARGET= aylet
GUI_ALL_TARGET= xaylet
PLIST_FILES= bin/aylet %%GUI%%bin/xaylet man/man1/aylet.1.gz
.include <bsd.port.mk>

3
audio/aylet/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1494173493
SHA256 (aylet-0.5.tar.gz) = c8c428a63abe5087b0345709a9a8034c2e6873b6071d9f7b05578aae0f3a4f72
SIZE (aylet-0.5.tar.gz) = 43577

View File

@ -0,0 +1,38 @@
--- Makefile.orig 2005-12-18 03:05:08 UTC
+++ Makefile
@@ -2,7 +2,7 @@
# You need an ANSI C compiler. gcc is probably best.
#
-CC=gcc
+CC?=gcc
# Compiler options (and sound driver) to use. This one is for Linux,
# and other OSS-using systems.
@@ -19,10 +19,10 @@ CURSES_LIB=-lncurses
# dest for make install
#
-PREFIX=/usr/local
-BINDIR=$(PREFIX)/bin
+PREFIX?=/usr/local
+BINDIR=$(DESTDIR)$(PREFIX)/bin
XBINDIR=$(BINDIR)
-MANDIR=$(PREFIX)/man/man1
+MANDIR=$(DESTDIR)$(PREFIX)/man/man1
# if you want the X version to be installed in the usual X executables
# directory, uncomment this (altering if necessary):
@@ -52,10 +52,9 @@ installdirs:
/bin/sh ./mkinstalldirs $(BINDIR) $(XBINDIR) $(MANDIR)
install: installdirs
- if [ -f aylet ]; then install -m 755 aylet $(BINDIR); fi
- if [ -f xaylet ]; then install -m 755 xaylet $(XBINDIR); fi
+ if [ -f aylet ]; then strip aylet; install -m 755 aylet $(BINDIR); fi
+ if [ -f xaylet ]; then strip xaylet; install -m 755 xaylet $(XBINDIR); fi
install -m 644 aylet.1 $(MANDIR)
- ln -sf $(MANDIR)/aylet.1 $(MANDIR)/xaylet.1
uninstall:
$(RM) $(BINDIR)/aylet $(XBINDIR)/xaylet

6
audio/aylet/pkg-descr Normal file
View File

@ -0,0 +1,6 @@
aylet plays music files in the `.ay' format. These files are essentially
wrappers around bits of Z80 code which play music on the Sinclair ZX Spectrum
128's sound hardware - either the beeper, or (eponymously) the AY-3-8912 sound
chip. Files using the Amstrad CPC ports are also supported.
WWW: http://www.worldofspectrum.org/

4
audio/aylet/pkg-message Normal file
View File

@ -0,0 +1,4 @@
===============================================================================
A huge .ay file collection can be found at:
ftp://ftp.worldofspectrum.org/pub/sinclair/music/ay/
===============================================================================