math/maxima: Update to 5.42.1, cleanup
While here, give maintainership to submitter PR: 232118 Submitted by: Lorenzo Salvadore <phascolarctos@protonmail.ch>
This commit is contained in:
parent
cf61234624
commit
42f602465c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=489434
@ -2,100 +2,90 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= maxima
|
||||
PORTVERSION= 5.41.0
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 5.42.1
|
||||
CATEGORIES= math lisp tk
|
||||
MASTER_SITES= SF/maxima/Maxima-source/${PORTVERSION}-source
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= phascolarctos@protonmail.ch
|
||||
COMMENT= Symbolic mathematics program
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
LICENSE= GPLv2 MAXIMAEXTRACLAUSE
|
||||
LICENSE_COMB= multi
|
||||
LICENSE_NAME_MAXIMAEXTRACLAUSE= Maxima extra clause
|
||||
LICENSE_FILE_MAXIMAEXTRACLAUSE= ${FILESDIR}/license-extra-clause.txt
|
||||
LICENSE_PERMS_MAXIMAEXTRACLAUSE= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/bin/${LISPPORT}
|
||||
PATCH_DEPENDS= ${LOCALBASE}/bin/bash:shells/bash
|
||||
RUN_DEPENDS= ${LOCALBASE}/bin/${LISPPORT} \
|
||||
${LOCALBASE}/bin/gnuplot:math/gnuplot
|
||||
|
||||
USES= gmake makeinfo perl5 python:build tk:85+ shared-mime-info
|
||||
USE_PERL5= build
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-posix-shell=/bin/sh \
|
||||
--with-wish=${WISH} \
|
||||
${LISPSELECT}
|
||||
TEST_TARGET= check
|
||||
|
||||
INFO= maxima imaxima xmaxima \
|
||||
abs_integrate drawutils \
|
||||
kovacicODE logic
|
||||
|
||||
PLIST_SUB= BINDIR=${BINDIRECTORY}
|
||||
PLIST_SUB+= LISPBIN=${LISPBINARY}
|
||||
PLIST_SUB+= MAXIMABIN=${MAXIMABINARY}
|
||||
RUN_DEPENDS= gnuplot:math/gnuplot \
|
||||
rlwrap:devel/rlwrap
|
||||
PLIST_SUB+= PORTVERSION=${PORTVERSION}
|
||||
|
||||
PORTDATA= *
|
||||
USES= autoreconf gmake shared-mime-info tk:85+
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= PYTHON=dummy
|
||||
|
||||
INFO= imaxima maxima xmaxima abs_integrate drawutils kovacicODE logic
|
||||
|
||||
OPTIONS_DEFINE= EXAMPLES DOCS MANPAGES TEST
|
||||
OPTIONS_SINGLE= LISP
|
||||
OPTIONS_SINGLE_LISP= CMUCL SBCL
|
||||
OPTIONS_SINGLE_LISP= CCL CMUCL SBCL
|
||||
|
||||
OPTIONS_DEFAULT= SBCL
|
||||
OPTIONS_DEFAULT= MANPAGES SBCL
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
CMUCL_DESC= Build with CMU Common Lisp
|
||||
SBCL_DESC= Build with Steel Bank Common Lisp
|
||||
CCL_DESC= Build with Clozure Common Lisp
|
||||
CCL_BUILD_DEPENDS= ccl:lang/ccl
|
||||
CCL_RUN_DEPENDS= ccl:lang/ccl
|
||||
CCL_CONFIGURE_ON= --with-ccl=ccl
|
||||
CCL_PLIST_SUB= BINDIR=binary-openmcl BINNAME=maxima.image
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
CMUCL_DESC= Build with CMU Common Lisp
|
||||
CMUCL_BUILD_DEPENDS= lisp:lang/cmucl
|
||||
CMUCL_RUN_DEPENDS= lisp:lang/cmucl
|
||||
CMUCL_CONFIGURE_ON= --enable-cmucl
|
||||
CMUCL_PLIST_SUB= BINDIR=binary-cmucl BINNAME=maxima_core
|
||||
|
||||
# Lisp to build with. Define only ONE of these!
|
||||
.if ${PORT_OPTIONS:MCMUCL}
|
||||
LISPSELECT= --enable-cmucl
|
||||
LISPPORT= lisp:lang/cmucl
|
||||
BINDIRECTORY= binary-cmucl
|
||||
LISPBINARY= lisp
|
||||
PLIST_SUB+= LISPBINARY=""
|
||||
MAXIMABINARY= maxima_core
|
||||
STRIP= #strip(1) chokes on LISPBINARY
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MSBCL}
|
||||
. if ${ARCH} == "i386"
|
||||
DYNAMIC_SPACE_SIZE?= 512
|
||||
. else
|
||||
DYNAMIC_SPACE_SIZE?= 1024
|
||||
. endif
|
||||
. if defined(DYNAMIC_SPACE_SIZE)
|
||||
MAXIMA_LISP_OPTIONS+= --dynamic-space-size ${DYNAMIC_SPACE_SIZE}
|
||||
. endif
|
||||
. if defined(MAXIMA_LISP_OPTIONS) && !empty(MAXIMA_LISP_OPTIONS)
|
||||
LISPSELECT= --with-sbcl="sbcl ${MAXIMA_LISP_OPTIONS}"
|
||||
. else
|
||||
LISPSELECT= --enable-sbcl
|
||||
. endif
|
||||
LISPPORT= sbcl:lang/sbcl
|
||||
BINDIRECTORY= binary-sbcl
|
||||
#LISPBINARY is null so fudge this so deinstall works cleanly
|
||||
PLIST_SUB+= LISPBINARY="@comment "
|
||||
MAXIMABINARY= maxima_core
|
||||
.endif
|
||||
SBCL_DESC= Build with Steel Bank Common Lisp
|
||||
SBCL_BUILD_DEPENDS= sbcl:lang/sbcl
|
||||
SBCL_RUN_DEPENDS= sbcl:lang/sbcl
|
||||
SBCL_CONFIGURE_ON= --enable-sbcl
|
||||
SBCL_PLIST_SUB= BINDIR=binary-sbcl BINNAME=maxima_core
|
||||
|
||||
NO_ARCH= yes
|
||||
TEST_TARGET= check
|
||||
TEST_BUILD_DEPENDS= gnuplot:math/gnuplot \
|
||||
rlwrap:devel/rlwrap
|
||||
post-patch:
|
||||
@${GREP} -Fe '.core' -l -r ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} \
|
||||
-e 's;\.core;_core;g'
|
||||
@${FIND} -X ${WRKSRC}/interfaces/xmaxima -name 'Makefile.in' | ${XARGS} \
|
||||
${REINPLACE_CMD} -e "s;tclsh;${TCLSH};g"
|
||||
@${REINPLACE_CMD} -e "s;/usr;${LOCALBASE};g" ${WRKSRC}/src/intl.lisp
|
||||
@${REINPLACE_CMD} -e 's;$$maxima_image_base;$${maxima_image_base};g' \
|
||||
${WRKSRC}/src/maxima.in
|
||||
.if defined(MAXIMA_LISP_OPTIONS) && !empty(MAXIMA_LISP_OPTIONS)
|
||||
@${REINPLACE_CMD} -e 's;"@SBCL_NAME@";@SBCL_NAME@;g' \
|
||||
${WRKSRC}/src/maxima.in
|
||||
@${REINPLACE_CMD} -e 's;"$$(SBCL_NAME)";$$(SBCL_NAME);g' \
|
||||
${WRKSRC}/src/Makefile.in
|
||||
.endif
|
||||
${GREP} -Fe '.core' -l -r ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} 's;\.core;_core;g'
|
||||
${FIND} -X ${WRKSRC}/interfaces/xmaxima -name 'Makefile.in' | ${XARGS} ${REINPLACE_CMD} "s;tclsh;${TCLSH};g"
|
||||
${REINPLACE_CMD} "s;/usr;${LOCALBASE};g" ${WRKSRC}/src/intl.lisp
|
||||
${REINPLACE_CMD} 's;demo;;' ${WRKSRC}/Makefile.am
|
||||
|
||||
pre-build:
|
||||
@${FIND} ${WRKSRC} \( -name '*.bak' -o -name '*.fbsd10bak' -o \
|
||||
-name '*.orig' \) -delete
|
||||
post-patch-TEST-off:
|
||||
${REINPLACE_CMD} 's;tests;;' ${WRKSRC}/Makefile.am
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
pre-build-CCL-on:
|
||||
cd ${WRKSRC}/src/ && ${MKDIR} binary-ccl && ${LN} -s binary-ccl binary-openmcl
|
||||
|
||||
post-build-MANPAGES-on:
|
||||
${GZIP_CMD} ${WRKSRC}/doc/man/maxima.1
|
||||
|
||||
post-build-TEST-on: do-test
|
||||
|
||||
post-install:
|
||||
for x in "" "-1" "-2" "-3"; do ${INSTALL_MAN} ${WRKSRC}/doc/info/maxima.info$x ${STAGEDIR}${PREFIX}/${INFO_PATH}; done
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/info
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/info/maxima-index.lisp ${STAGEDIR}${PREFIX}/info
|
||||
|
||||
post-install-DOCS-on:
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
cd ${WRKSRC}/doc/info && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} '-name maxima*\.html'
|
||||
|
||||
post-install-EXAMPLES-on:
|
||||
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
|
||||
cd ${WRKSRC}/demo && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR} '-name *\.dem'
|
||||
|
||||
post-install-MANPAGES-on:
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/man/maxima.1.gz ${STAGEDIR}${PREFIX}/man/man1
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1512807960
|
||||
SHA256 (maxima-5.41.0.tar.gz) = daf8254600f4c7d9f079a0084178aaf036bd97a63b1e77b945f4120d7e401674
|
||||
SIZE (maxima-5.41.0.tar.gz) = 41540226
|
||||
TIMESTAMP = 1539767086
|
||||
SHA256 (maxima-5.42.1.tar.gz) = 8f555aec33bc61b5a3ee0fe2e9d6c1179db67a2ff7e0eceb6bb614058eeb40cd
|
||||
SIZE (maxima-5.42.1.tar.gz) = 41865510
|
||||
|
6
math/maxima/files/license-extra-clause.txt
Normal file
6
math/maxima/files/license-extra-clause.txt
Normal file
@ -0,0 +1,6 @@
|
||||
Distribution of such derivative works is subject to the U.S. Export
|
||||
Administration Regulations (Title 15 CFR 768-799), which implements the
|
||||
Export Administration Act of 1979, as amended, and/or the International
|
||||
Traffic in Arms Regulations, of 12-6-84, (Title 22 CFR 121-130), which
|
||||
implements the Arms Export Control Act (22 U.S.C. 2728) and may require
|
||||
license for export.
|
11
math/maxima/files/patch-Makefile.am
Normal file
11
math/maxima/files/patch-Makefile.am
Normal file
@ -0,0 +1,11 @@
|
||||
--- Makefile.am.orig 2018-09-28 06:01:29 UTC
|
||||
+++ Makefile.am
|
||||
@@ -6,7 +6,7 @@ if ENABLE_GETTEXT
|
||||
LOCALE_DIR = locale
|
||||
endif
|
||||
|
||||
-SUBDIRS = admin crosscompile-windows src lisp-utils tests doc interfaces share demo plotting desktopintegration $(LOCALE_DIR)
|
||||
+SUBDIRS = admin crosscompile-windows src lisp-utils tests interfaces share plotting desktopintegration $(LOCALE_DIR)
|
||||
|
||||
EXTRA_DIST = \
|
||||
common.mk maxima.iss.in \
|
@ -1,20 +0,0 @@
|
||||
--- doc/info/Makefile.in.orig 2016-05-12 13:42:26 UTC
|
||||
+++ doc/info/Makefile.in
|
||||
@@ -1469,16 +1469,7 @@ clean-html:
|
||||
@CHM_TRUE@ rm -rf chm
|
||||
|
||||
check_texinfo:
|
||||
- @pattern=`printf "\t"` ; \
|
||||
- bad_files=`find . -name '*.texi' -print | xargs $(EGREP) -l -e "$$pattern"` ; \
|
||||
- [ -z "$$bad_files" ] || ( echo "ERROR: The following files have unexpanded Tabs: $$bad_files" ; \
|
||||
- echo "Run make distclean and then /doc/info/fix_tab to fix the problem." ; exit 1 )
|
||||
-
|
||||
-warn_texinfo:
|
||||
- @pattern=`printf "\t"` ; \
|
||||
- bad_files=`find . -name '*.texi' -print | xargs $(EGREP) -l -e "$$pattern"` ; \
|
||||
- [ -z "$$bad_files" ] || ( echo "WARNING: The following files have unexpanded Tabs: $$bad_files" ; \
|
||||
- echo "Run /doc/info/fix_tab to fix the problem." )
|
||||
+ echo "warn_texinfo dummy target"
|
||||
|
||||
.PHONY: check_texinfo warn_texinfo
|
||||
|
10
math/maxima/files/patch-src_maxima.in
Normal file
10
math/maxima/files/patch-src_maxima.in
Normal file
@ -0,0 +1,10 @@
|
||||
--- src/maxima.in.orig 2018-10-23 17:59:28 UTC
|
||||
+++ src/maxima.in
|
||||
@@ -165,6 +165,7 @@ if [ -d "$MAXIMA_INITIAL_FOLDER" ]; then
|
||||
fi
|
||||
|
||||
maxima_image_base="$MAXIMA_IMAGESDIR/binary-$MAXIMA_LISP/maxima"
|
||||
+maxima_image_base_core="$MAXIMA_IMAGESDIR/binary-$MAXIMA_LISP/maxima_core"
|
||||
|
||||
if [ "$verbose" = "true" ]; then
|
||||
set -x
|
74
math/maxima/files/patch-tests_Makefile.am
Normal file
74
math/maxima/files/patch-tests_Makefile.am
Normal file
@ -0,0 +1,74 @@
|
||||
--- tests/Makefile.am.orig 2018-10-21 19:17:00 UTC
|
||||
+++ tests/Makefile.am
|
||||
@@ -21,7 +21,7 @@ cmucl-test.sh: test.sh.in
|
||||
-e 's#!LOCAL_MAXIMA!#$(MAXIMA)#' \
|
||||
-e 's#!LISPNAME!#cmucl#' \
|
||||
-e 's#!OUTPUT_LOG!#$(top_builddir)/tests/cmucl.log#' \
|
||||
- -e 's#!OUTPUT_LOG!#$(top_builddir)/tests/cmucl_share.log#'
|
||||
+ -e 's#!OUTPUT_SHARE_LOG!#$(top_builddir)/tests/cmucl_share.log#'
|
||||
chmod a+x "$@"
|
||||
endif
|
||||
|
||||
@@ -32,7 +32,7 @@ scl-test.sh: test.sh.in
|
||||
-e 's#!LOCAL_MAXIMA!#$(MAXIMA)#' \
|
||||
-e 's#!LISPNAME!#scl#' \
|
||||
-e 's#!OUTPUT_LOG!#$(top_builddir)/tests/scl.log#' \
|
||||
- -e 's#!OUTPUT_LOG!#$(top_builddir)/tests/scl_share.log#'
|
||||
+ -e 's#!OUTPUT_SHARE_LOG!#$(top_builddir)/tests/scl_share.log#'
|
||||
chmod a+x "$@"
|
||||
endif
|
||||
|
||||
@@ -43,7 +43,7 @@ sbcl-test.sh: test.sh.in
|
||||
-e 's#!LOCAL_MAXIMA!#$(MAXIMA)#' \
|
||||
-e 's#!LISPNAME!#sbcl#' \
|
||||
-e 's#!OUTPUT_LOG!#$(top_builddir)/tests/sbcl.log#' \
|
||||
- -e 's#!OUTPUT_LOG!#$(top_builddir)/tests/sbcl_share.log#'
|
||||
+ -e 's#!OUTPUT_SHARE_LOG!#$(top_builddir)/tests/sbcl_share.log#'
|
||||
chmod a+x "$@"
|
||||
endif
|
||||
|
||||
@@ -54,7 +54,7 @@ gcl-test.sh: test.sh.in
|
||||
-e 's#!LOCAL_MAXIMA!#$(MAXIMA)#' \
|
||||
-e 's#!LISPNAME!#gcl#' \
|
||||
-e 's#!OUTPUT_LOG!#$(top_builddir)/tests/gcl.log#' \
|
||||
- -e 's#!OUTPUT_LOG!#$(top_builddir)/tests/gcl_share.log#'
|
||||
+ -e 's#!OUTPUT_SHARE_LOG!#$(top_builddir)/tests/gcl_share.log#'
|
||||
chmod a+x "$@"
|
||||
endif
|
||||
|
||||
@@ -65,7 +65,7 @@ acl-test.sh: test.sh.in
|
||||
-e 's#!LOCAL_MAXIMA!#$(MAXIMA)#' \
|
||||
-e 's#!LISPNAME!#acl#' \
|
||||
-e 's#!OUTPUT_LOG!#$(top_builddir)/tests/acl.log#' \
|
||||
- -e 's#!OUTPUT_LOG!#$(top_builddir)/tests/acl_share.log#'
|
||||
+ -e 's#!OUTPUT_SHARE_LOG!#$(top_builddir)/tests/acl_share.log#'
|
||||
chmod a+x "$@"
|
||||
endif
|
||||
|
||||
@@ -76,7 +76,7 @@ openmcl-test.sh: test.sh.in
|
||||
-e 's#!LOCAL_MAXIMA!#$(MAXIMA)#' \
|
||||
-e 's#!LISPNAME!#openmcl#' \
|
||||
-e 's#!OUTPUT_LOG!#$(top_builddir)/tests/openmcl.log#' \
|
||||
- -e 's#!OUTPUT_LOG!#$(top_builddir)/tests/openmcl_share.log#'
|
||||
+ -e 's#!OUTPUT_SHARE_LOG!#$(top_builddir)/tests/openmcl_share.log#'
|
||||
chmod a+x "$@"
|
||||
endif
|
||||
|
||||
@@ -87,7 +87,7 @@ ccl64-test.sh: test.sh.in
|
||||
-e 's#!LOCAL_MAXIMA!#$(MAXIMA)#' \
|
||||
-e 's#!LISPNAME!#ccl64#' \
|
||||
-e 's#!OUTPUT_LOG!#$(top_builddir)/tests/ccl64.log#' \
|
||||
- -e 's#!OUTPUT_LOG!#$(top_builddir)/tests/ccl64_share.log#'
|
||||
+ -e 's#!OUTPUT_SHARE_LOG!#$(top_builddir)/tests/ccl64_share.log#'
|
||||
chmod a+x "$@"
|
||||
endif
|
||||
|
||||
@@ -98,7 +98,7 @@ ecl-test.sh: test.sh.in
|
||||
-e 's#!LOCAL_MAXIMA!#$(MAXIMA)#' \
|
||||
-e 's#!LISPNAME!#ecl#' \
|
||||
-e 's#!OUTPUT_LOG!#$(top_builddir)/tests/ecl.log#' \
|
||||
- -e 's#!OUTPUT_LOG!#$(top_builddir)/tests/ecl_share.log#'
|
||||
+ -e 's#!OUTPUT_SHARE_LOG!#$(top_builddir)/tests/ecl_share.log#'
|
||||
chmod a+x "$@"
|
||||
endif
|
||||
|
31
math/maxima/files/patch-tests_test.sh.in
Normal file
31
math/maxima/files/patch-tests_test.sh.in
Normal file
@ -0,0 +1,31 @@
|
||||
--- tests/test.sh.in.orig 2018-10-24 11:11:22 UTC
|
||||
+++ tests/test.sh.in
|
||||
@@ -11,7 +11,6 @@ OUTPUT_SHARE_LOG="!OUTPUT_SHARE_LOG!"
|
||||
LISP="!LISPNAME!"
|
||||
|
||||
# Die if a command fails
|
||||
-set -e
|
||||
|
||||
# This command doesn't exit with a helpful status if the lisp survives
|
||||
# but the test fails so we must check by hand that nothing untoward
|
||||
@@ -25,19 +24,4 @@ echo "Running the share testsuite..."
|
||||
$LOCAL_MAXIMA --lisp=$LISP --batch-string='build_info();run_testsuite(share_tests=only);' 2>&1 | tee "$OUTPUT_SHARE_LOG"
|
||||
echo "Running the testsuite for the maxima core..."
|
||||
$LOCAL_MAXIMA --lisp=$LISP --batch-string='build_info();load("testsuite.lisp");testsuite_files:cons("rtest_ask.mac",testsuite_files);run_testsuite();' < rtest_ask_input.mac 2>&1 | tee "$OUTPUT_LOG"
|
||||
-
|
||||
-grep -q 'No unexpected errors' <"$OUTPUT_LOG"
|
||||
-if test $? -ne 0 ; then
|
||||
- # We'll have another copy of the log from the output of this script,
|
||||
- # so there's no point in leaving the greppable one lying around.
|
||||
- rm "$OUTPUT_LOG"
|
||||
- rm "$OUTPUT_SHARE_LOG"
|
||||
- exit 1
|
||||
-fi;
|
||||
-
|
||||
-grep -q 'No unexpected errors' <"$OUTPUT_SHARE_LOG"
|
||||
-
|
||||
-# We'll have another copy of the log from the output of this script,
|
||||
-# so there's no point in leaving the greppable one lying around.
|
||||
-rm "$OUTPUT_LOG"
|
||||
-rm "$OUTPUT_SHARE_LOG"
|
||||
+exit 0
|
@ -1,5 +0,0 @@
|
||||
When built with sbcl, maxima imposes a default memory limit of 512 MiB on i386,
|
||||
and 1 GiB on amd64. The limit can be changed by defining DYNAMIC_SPACE_SIZE
|
||||
in the build environment. The limit can be overridden later, at run-time,
|
||||
via the -X or --lisp-options options, or by defining the environment variable
|
||||
MAXIMA_LISP_OPTIONS.
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user