editors/codelite: Fix build when devel/check is installed.

Set correct include-path if devel/check is installed for check.h

PR:		218297
Submitted by:	w.schwarzenfeld@utanet.at
Reported by:	w.schwarzenfeld@utanet.at
This commit is contained in:
Mahdi Mokhtari 2018-01-18 11:16:24 +00:00
parent cd883f5f56
commit 42c1216a4e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=459322

View File

@ -0,0 +1,14 @@
--- sdk/codelite_cppcheck/CMakeLists.txt.orig 2018-01-17 21:37:24 UTC
+++ sdk/codelite_cppcheck/CMakeLists.txt
@@ -5,8 +5,10 @@ cmake_minimum_required(VERSION 2.6.2)
# visual studio, and in our makefiles.
project(codelitegcc)
+set (CMAKE_INCLUDE_DIRECTORIES ON)
+
# Include paths
-include_directories("${CL_SRC_ROOT}/sdk/codelite_cppcheck/lib" "${CL_SRC_ROOT}/sdk/codelite_cppcheck/cli")
+include_directories(BEFORE "${CL_SRC_ROOT}/sdk/codelite_cppcheck/lib" "${CL_SRC_ROOT}/sdk/codelite_cppcheck/cli")
set( ADDITIONAL_LIBRARIES "" )