lang/julia: Update to 1.8.4 and Makefile cleanup

PR:		268629
Reported by:	rizor.reardon@yahoo.com(maintainer)

(cherry picked from commit 434d421449)
This commit is contained in:
Wen Heping 2022-12-29 20:02:23 +08:00
parent a9ba9254bf
commit 4282288956
6 changed files with 23 additions and 20 deletions

View File

@ -1,7 +1,6 @@
PORTNAME= julia
DISTVERSION= 1.8.3
DISTVERSION= 1.8.4
DISTVERSIONSUFFIX= -full
PORTREVISION= 3
CATEGORIES= lang math
MASTER_SITES= https://github.com/JuliaLang/${PORTNAME}/releases/download/v${DISTVERSION}/
@ -32,16 +31,13 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libopenlibm.so:math/openlibm
RUN_DEPENDS= ${MY_DEPENDS}
USES= gmake compiler:c++14-lang cpe fortran python perl5 \
shebangfix blaslapack:openblas
USES= gmake cpe fortran python perl5 blaslapack:openblas
CPE_VENDOR= julialang
USE_CXXSTD= c++14
USE_LDCONFIG= yes
SHEBANG_GLOB= *.sh
MAKE_ARGS+= NO_GIT=1 \
USE_BINARYBUILDER=0 \
prefix=${PREFIX} \
@ -83,7 +79,6 @@ OPTIONS_DEFINE= DEBUG DOCS NATIVE
OPTIONS_DEFAULT= DOCS
OPTIONS_SUB= yes
NATIVE_DESC= Build with native CPU JIT tuning
NATIVE_MAKE_ARGS= JULIA_CPU_TARGET=native

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1668644873
SHA256 (julia-1.8.3-full.tar.gz) = 52b6895a9d4ad2fe36db261ee8c4c8cc9212b837a12f93002faaf537a2151f50
SIZE (julia-1.8.3-full.tar.gz) = 275266765
TIMESTAMP = 1671919330
SHA256 (julia-1.8.4-full.tar.gz) = 1cd032262c5c42048a7819bccd684e843bbb8f66cf9ff56c315881ea431f0033
SIZE (julia-1.8.4-full.tar.gz) = 275343783

View File

@ -1,6 +1,6 @@
--- Make.inc.orig 2022-11-21 01:55:42 UTC
--- Make.inc.orig 2022-12-23 22:14:27 UTC
+++ Make.inc
@@ -251,7 +251,7 @@ docdir := $(prefix)/$(framework_documentation)
@@ -251,7 +251,7 @@ libdir := $(prefix)/$(framework_currver)
libexecdir := $(prefix)/$(framework_helpers)
datarootdir := $(prefix)/$(framework_resources)
docdir := $(prefix)/$(framework_documentation)
@ -9,7 +9,7 @@
man1dir := $(mandir)/man1
includedir := $(prefix)/$(framework_headers)
sysconfdir := $(prefix)/$(framework_resources)
@@ -279,7 +279,7 @@ build_datarootdir := $(build_prefix)/share
@@ -279,7 +279,7 @@ build_depsbindir := $(build_prefix)/tools
build_libdir := $(build_prefix)/lib
build_libexecdir := $(build_prefix)/libexec
build_datarootdir := $(build_prefix)/share
@ -18,7 +18,7 @@
build_man1dir := $(build_mandir)/man1
build_includedir := $(build_prefix)/include
build_sysconfdir := $(build_prefix)/etc
@@ -498,8 +498,8 @@ ifeq ($(USECLANG),1)
@@ -500,8 +500,8 @@ SHIPFLAGS := -O3 -ggdb2 -falign-functions
endif
ifeq ($(USECLANG),1)

View File

@ -1,6 +1,6 @@
--- Makefile.orig 2022-11-18 12:39:16 UTC
--- Makefile.orig 2022-12-23 22:14:27 UTC
+++ Makefile
@@ -229,7 +229,7 @@ endef
@@ -229,7 +229,7 @@ define stringreplace
endef
@ -31,7 +31,7 @@
# Update RPATH entries and JL_SYSTEM_IMAGE_PATH if $(private_libdir_rel) != $(build_private_libdir_rel)
ifneq ($(private_libdir_rel),$(build_private_libdir_rel))
@@ -392,26 +384,15 @@ endif
@@ -402,26 +394,15 @@ endif
endif
endif

View File

@ -1,4 +1,4 @@
--- base/Makefile.orig 2022-01-04 19:47:19 UTC
--- base/Makefile.orig 2022-12-23 22:14:27 UTC
+++ base/Makefile
@@ -190,7 +190,7 @@ symlink_p7zip: $(build_bindir)/7z$(EXE)
@ -9,3 +9,12 @@
endif
$(build_bindir)/7z$(EXE):
@@ -218,6 +218,8 @@ else
$(eval $(call symlink_system_library,CSL,libgcc_s,1))
endif
endif
+else
+$(eval $(call symlink_system_library,CSL,libgcc_s,1))
endif
ifneq (,$(LIBGFORTRAN_VERSION))
$(eval $(call symlink_system_library,CSL,libgfortran,$(LIBGFORTRAN_VERSION)))

View File

@ -753,8 +753,7 @@ libexec/7z
%%DATADIR%%/stdlib/v%%VERSION%%/Pkg/test/repl.jl
%%DATADIR%%/stdlib/v%%VERSION%%/Pkg/test/resolve.jl
%%DATADIR%%/stdlib/v%%VERSION%%/Pkg/test/resolve_utils.jl
%%DATADIR%%/stdlib/v%%VERSION%%/Pkg/test/resolvedata1.jl
%%DATADIR%%/stdlib/v%%VERSION%%/Pkg/test/resolvedata2.jl
%%DATADIR%%/stdlib/v%%VERSION%%/Pkg/test/resolvedata.tar.gz
%%DATADIR%%/stdlib/v%%VERSION%%/Pkg/test/runtests.jl
%%DATADIR%%/stdlib/v%%VERSION%%/Pkg/test/sandbox.jl
%%DATADIR%%/stdlib/v%%VERSION%%/Pkg/test/subdir.jl