Update to 2.2.28

Changes:	https://github.com/Unidata/UDUNITS-2/blob/master/CHANGE_LOG
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2021-01-03 20:05:21 +00:00
parent 23f93d6d1f
commit 424da78664
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=560099
3 changed files with 28 additions and 7 deletions

View File

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= udunits
PORTVERSION= 2.2.26
PORTREVISION= 2
PORTVERSION= 2.2.28
CATEGORIES= science math
MASTER_SITES= ftp://ftp.unidata.ucar.edu/pub/udunits/ \
LOCAL/sunpoet
@ -18,17 +17,19 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= libexpat.so:textproc/expat2
OPTIONS_DEFINE= DOCS
USES= libtool localbase
CFLAGS+= -D__BSD_VISIBLE
CONFIGURE_ENV= ac_cv_header_CUnit_CUnit_h=no
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
TEST_TARGET= check
USE_LDCONFIG= yes
USES= libtool localbase
INFO= udunits2 udunits2lib udunits2prog
OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e '/install-data-hook$$/d' ${WRKSRC}/lib/Makefile.in

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1514030046
SHA256 (udunits-2.2.26.tar.gz) = 368f4869c9c7d50d2920fa8c58654124e9ed0d8d2a8c714a9d7fdadc08c7356d
SIZE (udunits-2.2.26.tar.gz) = 1227596
TIMESTAMP = 1609598847
SHA256 (udunits-2.2.28.tar.gz) = 590baec83161a3fd62c00efa66f6113cec8a7c461e3f61a5182167e0cc5d579e
SIZE (udunits-2.2.28.tar.gz) = 1224503

View File

@ -0,0 +1,20 @@
--- lib/xml.c.orig 2020-12-07 18:37:03 UTC
+++ lib/xml.c
@@ -38,7 +38,7 @@
#endif
#include <sys/stat.h>
#include <sys/types.h>
-#if defined(__linux__)
+#if defined(__linux__) || defined(__FreeBSD__)
#include <dlfcn.h>
#elif defined(__APPLE__)
#define _DARWIN_C_SOURCE
@@ -2137,7 +2137,7 @@ default_udunits2_xml_path()
if (absXmlPathname[0] == 0) {
const char* prefix = NULL; // Installation directory
-# if defined(__APPLE__) || defined(__linux__)
+# if defined(__APPLE__) || defined(__linux__) || defined(__FreeBSD__)
Dl_info info;
const char sep = '/'; // Pathname component separator
char buf[PATH_MAX];