upgrade to 0.12.1

take maintainership

PR:		103211
Submitted by:	Alex Samorukov <samm@os2.kiev.ua>
This commit is contained in:
Ying-Chieh Liao 2006-09-22 07:45:58 +00:00
parent b1000fb4e6
commit 424d45ee07
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=173574
9 changed files with 135 additions and 145 deletions

View File

@ -6,40 +6,41 @@
#
PORTNAME= pilot-link
PORTVERSION= 0.11.8
PORTREVISION= 4
DISTVERSION= 0.12.1
PORTEPOCH= 1
CATEGORIES= palm comms
MASTER_SITES= ${MASTER_SITE_GENTOO}
MASTER_SITE_SUBDIR= distfiles
MASTER_SITES= http://downloads.pilot-link.org/
MAINTAINER= ports@FreeBSD.org
COMMENT= PalmPilot communications utilities (backup/restore/install/debug/...)
MAINTAINER= samm@os2.kiev.ua
COMMENT= Suite of tools used to connect and sync your Palm handled
USE_BZIP2= yes
FETCH_CMD= /usr/bin/fetch -pRr
USE_ICONV= yes
USE_GETOPT_LONG=yes
USE_BZIP2= yes
USE_GNOME= gnometarget gnomehack
GNU_CONFIGURE= yes
CFLAGS+= -I${WRKSRC}/popt -I${LOCALBASE}/include
CONFIGURE_ARGS+=--with-libiconv=${LOCALBASE} --with-included-popt --enable-conduits \
--mandir=${MANPREFIX}/man
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS:S/-Werror//}" # clear -Werror from CFLAGS
USE_LDCONFIG= yes
USE_PERL5= yes
TCL_VER?= 8.4
CFLAGS+= -I${LOCALBASE}/include
HAS_CONFIGURE= yes
CONFIGURE_ARGS+=--with-perl5=${PERL5} --with-libiconv=${LOCALBASE} --program-transform-name=
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
OPTIONS= PNG "build with png support" off \
THREADS "built-in thread safety" on
OPTIONS= TCL "Build Tcl/Tk bindings" off
.include "${.CURDIR}/manpages.mk"
.include <bsd.port.pre.mk>
.if defined(WITH_TCL)
LIB_DEPENDS+= tk${TCL_VER:S/.//}:${PORTSDIR}/x11-toolkits/tk${TCL_VER:S/.//}
CONFIGURE_ARGS+=--with-tclinclude=${LOCALBASE}/include/tcl${TCL_VER}/ --with-tcl=${LOCALBASE}/lib/tcl${TCL_VER}/
PLIST_SUB+= WITH_TCL=""
.else
PLIST_SUB+= WITH_TCL="@comment "
.if !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --enable-threads
LDFLAGS+= ${PTHREAD_LIBS}
.endif
.include <bsd.port.post.mk>
.if defined(WITH_PNG)
LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
CONFIGURE_ARGS+= --with-libpng=${PREFIX}
.else
CONFIGURE_ARGS+= --disable-png
.endif
.include "${.CURDIR}/manpages.mk"
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
MD5 (pilot-link-0.11.8.tar.bz2) = 586f84add601e8b86da3093ab784e997
SHA256 (pilot-link-0.11.8.tar.bz2) = 952a97df5d13d926f0d5ce487e15268b1400fa0e7c43ea9303fba92818cce1cb
SIZE (pilot-link-0.11.8.tar.bz2) = 649034
MD5 (pilot-link-0.12.1.tar.bz2) = 80579c6f68eb583f54294d5651c4632b
SHA256 (pilot-link-0.12.1.tar.bz2) = 4f8b152749db32d531333cf439ff546beade3df7416071de9d1fad496635dec3
SIZE (pilot-link-0.12.1.tar.bz2) = 931338

View File

@ -1,16 +0,0 @@
--- configure.orig Tue Jul 1 14:08:40 2003
+++ configure Wed Dec 17 23:43:55 2003
@@ -1746,11 +1746,11 @@
# Use test -z because SunOS4 sh mishandles braces in ${var-val}.
# It thinks the first close brace ends the variable substitution.
-test -z "$INSTALL_PROGRAM" && INSTALL_PROGRAM='${INSTALL}'
+INSTALL_PROGRAM='${INSTALL}'
test -z "$INSTALL_SCRIPT" && INSTALL_SCRIPT='${INSTALL}'
-test -z "$INSTALL_DATA" && INSTALL_DATA='${INSTALL} -m 644'
+INSTALL_DATA='${INSTALL} -m 644'
echo "$as_me:$LINENO: checking whether build environment is sane" >&5
echo $ECHO_N "checking whether build environment is sane... $ECHO_C" >&6

View File

@ -1,17 +0,0 @@
--- bindings/Tcl/tclAppInit.c.orig Sat Feb 19 19:14:05 2005
+++ bindings/Tcl/tclAppInit.c Sat Feb 19 19:14:16 2005
@@ -15,14 +15,6 @@
#include "tcl.h"
-/*
- * The following variable is a special hack that is needed in order for
- * Sun shared libraries to be used for Tcl.
- */
-
-extern int matherr();
-int *tclDummyMathPtr = (int *) matherr;
-
EXTERN int Pitcl_Init _ANSI_ARGS_((Tcl_Interp *interp));
#ifdef TCL_TEST

View File

@ -0,0 +1,15 @@
--- ltmain.sh.orig Fri Sep 22 15:15:14 2006
+++ ltmain.sh Fri Sep 22 15:15:24 2006
@@ -6003,10 +6003,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false ; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View File

@ -1,14 +0,0 @@
$FreeBSD$
--- src/read-todos.c.orig Mon Feb 2 23:09:47 2004
+++ src/read-todos.c Mon Feb 2 23:10:22 2004
@@ -184,7 +184,7 @@
printf("Priority: %d\n", t.priority);
printf("Completed: %s\n", t.complete ? "Yes" : "No");
if (t.indefinite)
- printf("Due: No Date");
+ printf("Due: No Date\n");
else
printf("Due: %s", asctime(&t.due));
if (t.description)

View File

@ -0,0 +1,15 @@
--- doc/xml/Makefile.in.ori Wed Sep 13 08:03:19 2006
+++ doc/xml/Makefile.in Wed Sep 13 08:03:24 2006
@@ -582,9 +582,9 @@
all:
- $(XSLTPROC) $(XSLTPROC_FLAGS) -o $(top_srcdir)/doc/man/ \
- $(top_srcdir)/../doc/xml/docbook.xsl \
- $(top_srcdir)/../doc/xml/pilot-link.docbook
+# $(XSLTPROC) $(XSLTPROC_FLAGS) -o $(top_srcdir)/doc/man/ \
+# $(top_srcdir)/../doc/xml/docbook.xsl \
+# $(top_srcdir)/../doc/xml/pilot-link.docbook
distclean-local:
$(RM) -f xml/catalog.xml

View File

@ -1,23 +1,36 @@
MAN1+= addresses.1
MAN1+= dlpsh.1
MAN1+= hinotes.1
MAN1+= ietf2datebook.1
MAN1+= install-datebook.1
MAN1+= install-expenses.1
MAN1+= install-hinote.1
MAN1+= install-memo.1
MAN1+= install-netsync.1
MAN1+= install-todo.1
MAN1+= install-user.1
MAN1+= memos.1
MAN1+= pi-getram.1
MAN1+= pi-getrom.1
MAN1+= pilot-addresses.1
MAN1+= pilot-foto.1
MAN1+= pilot-xfer.1
MAN1+= read-expenses.1
MAN1+= read-ical.1
MAN1+= read-notepad.1
MAN1+= read-palmpix.1
MAN1+= read-todos.1
MAN7+= pilot-link.7
MAN1+= ietf2datebook.1
MAN1+= install-datebook.1
MAN1+= install-expenses.1
MAN1+= install-hinote.1
MAN1+= install-memo.1
MAN1+= install-netsync.1
MAN1+= install-todo.1
MAN1+= install-todos.1
MAN1+= install-user.1
MAN1+= pilot-addresses.1
MAN1+= pilot-clip.1
MAN1+= pilot-csd.1
MAN1+= pilot-debugsh.1
MAN1+= pilot-dedupe.1
MAN1+= pilot-dlpsh.1
MAN1+= pilot-file.1
MAN1+= pilot-foto.1
MAN1+= pilot-getram.1
MAN1+= pilot-getrom.1
MAN1+= pilot-getromtoken.1
MAN1+= pilot-hinotes.1
MAN1+= pilot-memos.1
MAN1+= pilot-nredir.1
MAN1+= pilot-reminders.1
MAN1+= pilot-schlep.1
MAN1+= pilot-treofoto.1
MAN1+= pilot-wav.1
MAN1+= pilot-xfer.1
MAN1+= read-expenses.1
MAN1+= read-ical.1
MAN1+= read-notepad.1
MAN1+= read-palmpix.1
MAN1+= read-screenshot.1
MAN1+= read-todos.1
MAN1+= read-veo.1
MAN7+= pilot-link.7

View File

@ -1,8 +1,3 @@
bin/addresses
bin/ccexample
bin/debugsh
bin/dlpsh
bin/hinotes
bin/install-datebook
bin/install-expenses
bin/install-hinote
@ -11,43 +6,45 @@ bin/install-netsync
bin/install-todo
bin/install-todos
bin/install-user
bin/memos
bin/money2qif
bin/pi-csd
bin/pi-getram
bin/pi-getrom
bin/pi-getromtoken
bin/pi-nredir
bin/pilot-addresses
bin/pilot-archive
bin/pilot-clip
bin/pilot-datebook
bin/pilot-csd
bin/pilot-debugsh
bin/pilot-dedupe
bin/pilot-dlpsh
bin/pilot-file
bin/pilot-foto
bin/pilot-prc
bin/pilot-getram
bin/pilot-getrom
bin/pilot-getromtoken
bin/pilot-hinotes
bin/pilot-memos
bin/pilot-nredir
bin/pilot-reminders
bin/pilot-schlep
bin/pilot-treofoto
bin/pilot-wav
bin/pilot-xfer
%%WITH_TCL%%bin/pitclsh
bin/read-expenses
bin/read-ical
bin/read-notepad
bin/read-palmpix
bin/read-screenshot
bin/read-todos
bin/reminders
bin/read-veo
include/pi-address.h
include/pi-address.hxx
include/pi-appinfo.h
include/pi-appinfo.hxx
include/pi-args.h
include/pi-buffer.h
include/pi-cmp.h
include/pi-contact.h
include/pi-datebook.h
include/pi-datebook.hxx
include/pi-debug.h
include/pi-dlp.h
include/pi-dlp.hxx
include/pi-error.h
include/pi-expense.h
include/pi-file.h
include/pi-foto.h
include/pi-header.h
include/pi-hinote.h
include/pi-inet.h
@ -55,7 +52,6 @@ include/pi-macros.h
include/pi-mail.h
include/pi-md5.h
include/pi-memo.h
include/pi-memo.hxx
include/pi-money.h
include/pi-net.h
include/pi-notepad.h
@ -69,38 +65,35 @@ include/pi-source.h
include/pi-sync.h
include/pi-sys.h
include/pi-syspkt.h
include/pi-threadsafe.h
include/pi-todo.h
include/pi-todo.hxx
include/pi-usb.h
include/pi-util.h
include/pi-veo.h
include/pi-versamail.h
include/pi-version.h
lib/libpisock++.a
lib/libpisock++.la
lib/libpisock++.so
lib/libpisock++.so.0
lib/libpisock.a
lib/libpisock.la
lib/libpisock.so
lib/libpisock.so.8
lib/libpisock.so.9
lib/libpisync.a
lib/libpisync.la
lib/libpisync.so
lib/libpisync.so.0
%%WITH_TCL%%lib/libpitcl.a
%%WITH_TCL%%lib/libpitcl.so.0
%%WITH_TCL%%lib/libpitcl.so
libdata/pkgconfig/pilot-link.pc
share/aclocal/pilot-link.m4
share/pilot-link/getrom.prc
share/pilot-link/getrom2.prc
share/pilot-link/pix/b1.gif
share/pilot-link/pix/b2.gif
share/pilot-link/pix/b3.gif
share/pilot-link/pix/b4.gif
share/pilot-link/pix/b5.gif
share/pilot-link/pix/b6.gif
share/pilot-link/pix/b7.gif
share/pilot-link/pix/case.gif
share/pilot-link/pix/case.xbm
share/pilot-link/pix/casemask.xbm
@dirrm share/pilot-link/pix
@dirrm share/pilot-link
%%DATADIR%%/pix/b1.gif
%%DATADIR%%/pix/b2.gif
%%DATADIR%%/pix/b3.gif
%%DATADIR%%/pix/b4.gif
%%DATADIR%%/pix/b5.gif
%%DATADIR%%/pix/b6.gif
%%DATADIR%%/pix/b7.gif
%%DATADIR%%/pix/case.gif
%%DATADIR%%/pix/case.xbm
%%DATADIR%%/pix/casemask.xbm
%%DATADIR%%/prc/getrom.prc
%%DATADIR%%/prc/getrom2.prc
%%DATADIR%%/udev/60-libpisock.rules
@dirrm %%DATADIR%%/pix
@dirrm %%DATADIR%%/prc
@dirrm %%DATADIR%%/udev
@dirrm %%DATADIR%%