Add oglext 1.0.2, a library for easier access to OpenGL extensions.

PR:		62297
Submitted by:	Igor Pokrovsky <tiamat@comset.net>
This commit is contained in:
Thierry Thomas 2004-05-29 22:08:55 +00:00
parent e4bf8af6bd
commit 42413271df
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=110324
7 changed files with 169 additions and 0 deletions

View File

@ -263,6 +263,7 @@
SUBDIR += ocaml-images
SUBDIR += ocaml-lablgl
SUBDIR += ocrad
SUBDIR += oglext
SUBDIR += opendis
SUBDIR += opendx
SUBDIR += opendx-samples

46
graphics/oglext/Makefile Normal file
View File

@ -0,0 +1,46 @@
# New ports collection makefile for: oglext
# Date created: 01 Feb 2004
# Whom: Igor Pokrovsky <tiamat@comset.net>
#
# $FreeBSD$
#
PORTNAME= oglext
PORTVERSION= 1.0.2
CATEGORIES= graphics devel
MASTER_SITES= http://www.julius.caesar.de/oglext/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= tiamat@comset.net
COMMENT= A library for easier access to OpenGL extensions
USE_ZIP= yes
USE_GMAKE= yes
USE_GL= yes
USE_X_PREFIX= yes
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
REINPLACE_ARGS= -i ""
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
BUILD_WRKSRC= ${WRKSRC}/src
MAKEFILE= ${WRKSRC}/build/linux-gcc/Makefile
MAKE_ENV= AR="${AR}" LN="${LN}" RM="${RM}"
pre-patch:
@${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e "s/`${PRINTF} '\r'`//"
do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/libOglExt.so.1 ${PREFIX}/lib
${LN} -sf ${PREFIX}/lib/libOglExt.so.1 ${PREFIX}/lib/libOglExt.so
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/libOglExt.a ${PREFIX}/lib
# install includes in separate dir to avoid conflicts with Mesa
@${MKDIR} ${PREFIX}/include/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/include/*.h ${PREFIX}/include/${PORTNAME}
.ifndef (NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
.endif
.include <bsd.port.mk>

2
graphics/oglext/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (oglext-1.0.2-src.zip) = 569e331cb6131e75e105b9c6a0e4ae6a
SIZE (oglext-1.0.2-src.zip) = 172296

View File

@ -0,0 +1,91 @@
--- build/linux-gcc/Makefile.orig Mon Feb 2 19:30:41 2004
+++ build/linux-gcc/Makefile Mon Feb 2 19:34:14 2004
@@ -8,28 +8,28 @@
####### Compiler, tools and options
-CC = gcc
-CXX = g++
-LEX = flex
-YACC = yacc
-CFLAGS = -pipe -Wall -W -fPIC
-CXXFLAGS = -pipe -Wall -W -fPIC
-LEXFLAGS =
-YACCFLAGS= -d
-LINK = g++
+#CC = gcc
+#CXX = g++
+#LEX = flex
+#YACC = yacc
+CFLAGS += -pipe -Wall -W -fPIC -I${X11BASE}/include
+CXXFLAGS += -pipe -Wall -W -fPIC -I${X11BASE}/include
+#LEXFLAGS =
+#YACCFLAGS= -d
+LINK = ${CXX}
LFLAGS = -shared -Wl,-soname,libOglExt.so.1
-LIBS =
-AR = ar cqs
-RANLIB =
-TAR = tar -cf
-GZIP = gzip -9f
-COPY = cp -f
-COPY_FILE= $(COPY) -p
-COPY_DIR = $(COPY) -pR
-DEL_FILE = rm -f
-SYMLINK = ln -sf
-DEL_DIR = rmdir
-MOVE = mv -f
+LIBS = -L${X11BASE}/lib -lGL
+#AR = ${AR} cqs
+#RANLIB =
+#TAR = ${TAR} -cf
+#GZIP = ${GZIP_CMD} -9f
+#COPY = ${CP} -f
+#COPY_FILE= $(COPY) -p
+#COPY_DIR = $(COPY) -pR
+DEL_FILE = ${RM} -f
+SYMLINK = ${LN} -sf
+#DEL_DIR = ${RMDIR}
+#MOVE = ${MV} -f
####### Output directory
@@ -45,12 +45,12 @@
RenderingContext.cpp
OBJECTS = OglExt.o \
RenderingContext.o
-TARGET = libOglExt.so.1.0.0
+TARGET = libOglExt.so.1
TARGETA = libOglExt.a
-TARGETD = libOglExt.so.1.0.0
-TARGET0 = libOglExt.so
-TARGET1 = libOglExt.so.1
-TARGET2 = libOglExt.so.1.0
+#TARGETD = libOglExt.so.1.0.0
+#TARGET0 = libOglExt.so
+#TARGET1 = libOglExt.so.1
+#TARGET2 = libOglExt.so.1.0
first: all
####### Implicit rules
@@ -74,15 +74,15 @@
####### Build rules
-all: Makefile $(TARGET)
+all: $(TARGET) $(TARGETA)
$(TARGET): $(OBJECTS)
- -$(DEL_FILE) $(TARGET) $(TARGET0) $(TARGET1) $(TARGET2)
+ -$(DEL_FILE) $(TARGET)
$(LINK) $(LFLAGS) -o $(TARGET) $(OBJECTS) $(LIBS)
- -ln -s $(TARGET) $(TARGET0)
- -ln -s $(TARGET) $(TARGET1)
- -ln -s $(TARGET) $(TARGET2)
+$(TARGETA): $(OBJECTS)
+ -$(DEL_FILE) $(TARGETA)
+ $(AR) cqs $@ $(OBJECTS)
clean:
-$(DEL_FILE) $(OBJECTS)

View File

@ -0,0 +1,11 @@
--- src/Macros.h.orig Mon Feb 2 19:23:57 2004
+++ src/Macros.h Mon Feb 2 19:24:13 2004
@@ -18,7 +18,7 @@
#define _OGL_MACROS_H_
#ifndef _WIN32
-
+ #define GLX_GLXEXT_PROTOTYPES
#include <GL/glx.h>
#endif

View File

@ -0,0 +1,9 @@
OglExt is a free OpenGL extension library, enabling the easy access of all
functionality up to OpenGL version 1.4 as well as API functions of more than
200 OpenGL extensions. With OglExt you don't need to use glXGetProcAddress[ARB]
anymore. See README for more information.
WWW: http://www.julius.caesar.de/oglext/
- Igor Pokrovsky
tiamat@comset.net

View File

@ -0,0 +1,9 @@
include/oglext/OglExt.h
include/oglext/glext.h
lib/libOglExt.a
lib/libOglExt.so
lib/libOglExt.so.1
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/extensionlist.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/oglext