Add pdbc, the PalmOS database compiler/decompiler.
PR: ports/69728 Submitted by: Eric P. Scott <eps+psub0407@ana.com>
This commit is contained in:
parent
1928b42c5f
commit
423da2c5dd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=115176
@ -22,6 +22,7 @@
|
||||
SUBDIR += palmos-sdk
|
||||
SUBDIR += palmpower
|
||||
SUBDIR += pdbar
|
||||
SUBDIR += pdbc
|
||||
SUBDIR += pilot-link
|
||||
SUBDIR += pilot_makedoc
|
||||
SUBDIR += pilrc
|
||||
|
42
palm/pdbc/Makefile
Normal file
42
palm/pdbc/Makefile
Normal file
@ -0,0 +1,42 @@
|
||||
# New ports collection makefile for: pdbc
|
||||
# Date created: 28 Jul 2004
|
||||
# Whom: Eric P. Scott
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= pdbc
|
||||
PORTVERSION= 0.9.5
|
||||
CATEGORIES= palm
|
||||
MASTER_SITES= http://trials.palmgear.com/dl2.php/29490.zip/
|
||||
DISTFILES= ${PORTNAME}_${PORTVERSION}${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Palm DataBase Compiler/Decompiler
|
||||
|
||||
USE_ZIP= YES
|
||||
EXTRACT_BEFORE_ARGS= -q -a
|
||||
BUILD_WRKSRC= ${WRKSRC}/src
|
||||
USE_BISON= YES
|
||||
USE_GMAKE= YES
|
||||
MAKEFILE= Makefile.unix
|
||||
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
|
||||
|
||||
MAN1= pdbc.1 pdbdec.1
|
||||
MAN5= pdbc.5
|
||||
PLIST_FILES= bin/pdbc bin/pdbdec
|
||||
|
||||
post-extract:
|
||||
${CHMOD} -R u+rw,go-w ${WRKSRC}
|
||||
${MV} ${WRKSRC}/man/man4/pdbc.4 ${WRKSRC}/man/man4/pdbc.5
|
||||
${MV} ${WRKSRC}/man/man4 ${WRKSRC}/man/man5
|
||||
${CHMOD} a-x ${WRKSRC}/src/* ${WRKSRC}/man/man?/*
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/pdbc ${PREFIX}/bin
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/pdbdec ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/man/man1/pdbc.1 ${MANPREFIX}/man/man1
|
||||
${INSTALL_MAN} ${WRKSRC}/man/man1/pdbdec.1 ${MANPREFIX}/man/man1
|
||||
${INSTALL_MAN} ${WRKSRC}/man/man5/pdbc.5 ${MANPREFIX}/man/man5
|
||||
|
||||
.include <bsd.port.mk>
|
2
palm/pdbc/distinfo
Normal file
2
palm/pdbc/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
MD5 (pdbc_0.9.5.zip) = 8bd31307bc79134cce63876a8b0534f6
|
||||
SIZE (pdbc_0.9.5.zip) = 220150
|
11
palm/pdbc/files/patch-man-man1-pdbc.1
Normal file
11
palm/pdbc/files/patch-man-man1-pdbc.1
Normal file
@ -0,0 +1,11 @@
|
||||
--- man/man1/pdbc.1.orig Fri May 14 00:21:49 2004
|
||||
+++ man/man1/pdbc.1 Wed Jul 28 13:16:48 2004
|
||||
@@ -320,7 +320,7 @@
|
||||
.Ve
|
||||
.SH "SEE ALSO"
|
||||
.IX Header "SEE ALSO"
|
||||
-pdbc(4), pdbdec(1)
|
||||
+pdbc(5), pdbdec(1)
|
||||
|
||||
.SH "BUGS"
|
||||
.IX Header "BUGS"
|
20
palm/pdbc/files/patch-man-man1-pdbdec.1
Normal file
20
palm/pdbc/files/patch-man-man1-pdbdec.1
Normal file
@ -0,0 +1,20 @@
|
||||
--- man/man1/pdbdec.1.orig Fri May 14 00:21:49 2004
|
||||
+++ man/man1/pdbdec.1 Wed Jul 28 13:24:37 2004
|
||||
@@ -326,7 +326,7 @@
|
||||
\&\fBpdbdec\fR converts binary \s-1PDB\s0 file into an ascii text source file.
|
||||
.SH "SOURCE FILE FORMAT (OUTPUT)"
|
||||
.IX Header "SOURCE FILE FORMAT (OUTPUT)"
|
||||
-For the syntax of the source file format consult \fIpdbc\fR\|(4).
|
||||
+For the syntax of the source file format consult \fIpdbc\fR\|(5).
|
||||
.SH "ERRORS"
|
||||
.IX Header "ERRORS"
|
||||
.SH "DIAGNOSTICS"
|
||||
@@ -361,7 +361,7 @@
|
||||
.IX Item "pdbdec mystuff.pdb"
|
||||
.SH "SEE ALSO"
|
||||
.IX Header "SEE ALSO"
|
||||
-pdbc(1), pdbc(4)
|
||||
+pdbc(1), pdbc(5)
|
||||
|
||||
.SH "BUGS"
|
||||
.IX Header "BUGS"
|
31
palm/pdbc/files/patch-man-man5-pdbc.5
Normal file
31
palm/pdbc/files/patch-man-man5-pdbc.5
Normal file
@ -0,0 +1,31 @@
|
||||
--- man/man5/pdbc.5.orig Fri May 14 00:21:49 2004
|
||||
+++ man/man5/pdbc.5 Wed Jul 28 13:34:22 2004
|
||||
@@ -128,8 +128,8 @@
|
||||
.rm #[ #] #H #V #F C
|
||||
.\" ========================================================================
|
||||
.\"
|
||||
-.IX Title "PDBC_FILE 1"
|
||||
-.TH PDBC_FILE 1 "2004-04-28" "pdbc 1.0" "Palm Development File Formats"
|
||||
+.IX Title "PDBC 5"
|
||||
+.TH PDBC 5 "2004-04-28" "pdbc 1.0" "Palm Development File Formats"
|
||||
.SH "NAME"
|
||||
\&\fBpdbc\fR \- palm database source file format
|
||||
.SH "DESCRIPTION"
|
||||
@@ -456,7 +456,7 @@
|
||||
.Sp
|
||||
Backslash ('\e') can be used to escape special characters
|
||||
(\e\e, \ea, \eb, \ef, \en, \er, \et, \ev, \eddd)
|
||||
-as described in \fIprintf\fR\|(5).
|
||||
+as described in \fIprintf\fR\|(1).
|
||||
.Sp
|
||||
Depending on the current string padding \s-1NULL\s0 bytes may be appended.
|
||||
.Sp
|
||||
@@ -806,7 +806,7 @@
|
||||
.Ve
|
||||
.SH "SEE ALSO"
|
||||
.IX Header "SEE ALSO"
|
||||
-pdbc(1), pdbdec(1), printf(5)
|
||||
+pdbc(1), pdbdec(1), printf(1)
|
||||
|
||||
.SH "AUTHOR"
|
||||
.IX Header "AUTHOR"
|
15
palm/pdbc/pkg-descr
Normal file
15
palm/pdbc/pkg-descr
Normal file
@ -0,0 +1,15 @@
|
||||
pdbc is a compiler that converts a source file into a Palm DataBase (PDB) file
|
||||
or Palm Resource (PRC) file. The language the pdbc compiler understands is
|
||||
designed to be easy to understand and write. Yet it is powerful enough to give
|
||||
the freedom to describe the binary content of the database records in a variety
|
||||
of ways. It is also easy to generate the pdbc source file from another
|
||||
language (e.g. Perl).
|
||||
|
||||
In addition to the pdbc tool there is also pdbdec. pdbdec is a decompiler
|
||||
which converts any PDB or PRC file into a pdbc source file. This is useful to
|
||||
check the correctness of the pdbc generated file and to analyze other PDB
|
||||
files.
|
||||
|
||||
pdbc and pdbdec are command line tools.
|
||||
|
||||
WWW: http://obermuhlner.com/public/Projects/Palm/PDBC/
|
Loading…
Reference in New Issue
Block a user