Add gkrellmwireless, a plugin for gkrellm that monitors the signal

quality of a wireless card (wi0 only).
This commit is contained in:
Jim Mock 2002-03-05 07:06:00 +00:00
parent 5adafd9478
commit 422cf1395e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=55553
7 changed files with 76 additions and 0 deletions

View File

@ -134,6 +134,7 @@
SUBDIR += gift
SUBDIR += gkrellm_snmp
SUBDIR += gkrellmqst
SUBDIR += gkrellmwireless
SUBDIR += gnet
SUBDIR += gnomba
SUBDIR += gnome-vnc

View File

@ -0,0 +1,22 @@
# New ports collection makefile for: gkrellm-wireless
# Date Created: 4 Mar 2002
# Whom: Jim Mock <jim@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= gkrellmwireless
PORTVERSION= 0.2.2
CATEGORIES= net
MASTER_SITES= http://gkrellm.luon.net/files/
MAINTAINER= jim@FreeBSD.org
BUILD_DEPENDS= ${X11BASE}/include/gkrellm/gkrellm.h:${PORTSDIR}/sysutils/gkrellm
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm
USE_X_PREFIX= yes
USE_IMLIB= yes
USE_GMAKE= yes
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (gkrellmwireless-0.2.2.tar.gz) = c187d6bc720080acaabc88c76160a49a

View File

@ -0,0 +1,44 @@
--- Makefile.orig Sun Sep 9 07:12:41 2001
+++ Makefile Mon Mar 4 22:51:36 2002
@@ -1,36 +1,24 @@
# Depends on gmake..
#
-OS = $(shell uname)
-
-ifeq ($(OS),FreeBSD)
- GTK_CONFIG = gtk12-config
- INCLUDE = -I/usr/src/sys
-elseif eq ($(OS),NetBSD)
- GTK_CONFIG = gtk-config
-else
-# default to the linux
- GTK_CONFIG = gtk-config
-endif
-
GTK_INCLUDE = `$(GTK_CONFIG) --cflags gthread`
GTK_LIB = `$(GTK_CONFIG) --libs gthread`
-IMLIB_INCLUDE = `imlib-config --cflags-gdk`
-IMLIB_LIB = `imlib-config --libs-gdk`
+IMLIB_INCLUDE = `${IMLIB_CONFIG} --cflags-gdk`
+IMLIB_LIB = `${IMLIB_CONFIG} --libs-gdk`
-FLAGS = -g -O2 -Wall -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE) $(INCLUDE)
+CFLAGS = -g -O2 -Wall -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE) $(INCLUDE)
LIBS = $(GTK_LIB) $(IMLIB_LIB)
LFLAGS = -shared
-CC = gcc $(CFLAGS) $(FLAGS)
+CC ?= gcc $(CFLAGS) $(FLAGS)
OBJS = wireless.o
INSTALL = install -c -s
INSTALL_PERMS = -m 755
-PLUGIN_DIR = /usr/lib/gkrellm/plugins
+PLUGIN_DIR = ${PREFIX}/libexec/gkrellm/plugins
all: wireless.so

View File

@ -0,0 +1 @@
GKrellM wireless plugin

View File

@ -0,0 +1,6 @@
A plugin for gkrellm that monitors the signal quality of a wireless card
(wi0 only).
WWW: http://gkrellm.luon.net/gkrellmwireless.phtml
- jim <jim@FreeBSD.org>

View File

@ -0,0 +1 @@
libexec/gkrellm/plugins/wireless.so