Delete two unneeded patches.

PR:		misc/135400
Submitted by:	John Fox Maule <john@fox-maule.dk>
This commit is contained in:
Martin Blapp 2009-06-09 08:22:09 +00:00
parent 9562da5160
commit 41e5f0b9a0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=235480
2 changed files with 0 additions and 49 deletions

View File

@ -1,35 +0,0 @@
--- vmblock-fuse/Makefile.am.orig 2009-02-18 17:00:54.000000000 +0900
+++ vmblock-fuse/Makefile.am 2009-03-01 16:41:24.000000000 +0900
@@ -17,13 +17,13 @@
bin_PROGRAMS = vmware-vmblock-fuse
-# _XOPEN_SOURCE needs to be defined to at least 500 when compiling
-# vmblock-fuse's os.h to get pthread_rwlock_t.
+# _XOPEN_SOURCE needs to be defined to at least 600 when compiling
+# vmblock-fuse's fsops.c to get lstat.
# -D_FILE_OFFSET_BITS=64 required for fuse.
AM_CFLAGS =
AM_CFLAGS += -Dvmblock_fuse
-AM_CFLAGS += -D_XOPEN_SOURCE=500
+AM_CFLAGS += -D_XOPEN_SOURCE=600
AM_CFLAGS += -DUSERLEVEL
AM_CFLAGS += -D_FILE_OFFSET_BITS=64
AM_CFLAGS += @FUSE_CPPFLAGS@
--- vmblock-fuse/Makefile.in.orig 2009-02-18 17:03:18.000000000 +0900
+++ vmblock-fuse/Makefile.in 2009-03-01 16:50:47.000000000 +0900
@@ -263,10 +263,10 @@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-# _XOPEN_SOURCE needs to be defined to at least 500 when compiling
-# vmblock-fuse's os.h to get pthread_rwlock_t.
+# _XOPEN_SOURCE needs to be defined to at least 600 when compiling
+# vmblock-fuse's fsops.c to get lstat.
# -D_FILE_OFFSET_BITS=64 required for fuse.
-AM_CFLAGS = -Dvmblock_fuse -D_XOPEN_SOURCE=500 -DUSERLEVEL \
+AM_CFLAGS = -Dvmblock_fuse -D_XOPEN_SOURCE=600 -DUSERLEVEL \
-D_FILE_OFFSET_BITS=64 @FUSE_CPPFLAGS@ @VMWARE_USER_CPPFLAGS@
vmware_vmblock_fuse_LDADD = ../lib/misc/libMisc.la @FUSE_LIBS@ \
$(am__append_1)

View File

@ -1,14 +0,0 @@
--- vmblock-fuse/block.c.orig 2009-02-18 17:02:53.000000000 +0900
+++ vmblock-fuse/block.c 2009-03-01 16:37:11.000000000 +0900
@@ -519,11 +519,7 @@
struct DblLnkLst_Links *curr;
/* XXX The following is only temporary. */
-#ifdef __FreeBSD__
- os_assert_rwlock_held(&blockedFilesLock);
-#else
ASSERT(os_rwlock_held(&blockedFilesLock));
-#endif
DblLnkLst_ForEach(curr, &blockedFiles) {
BlockInfo *currBlock = DblLnkLst_Container(curr, BlockInfo, links);