Remove support for antique perl.

Hat:	portmgr
This commit is contained in:
Mark Linimon 2007-09-08 00:45:08 +00:00
parent 8bf833f731
commit 41a56135d1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=199068
58 changed files with 29 additions and 612 deletions

View File

@ -22,13 +22,4 @@ PERL_CONFIGURE= yes
MAN3= Class::DBI::Loader::Relationship.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES= ${PATCHDIR}/500503-Relationship.pm
post-configure:
${PERL} -pi -e 's,/usr/local/,\$$(PREFIX)/,g' ${WRKSRC}/Makefile
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,33 +0,0 @@
--- Relationship.pm.orig Wed Nov 9 02:28:38 2005
+++ Relationship.pm Wed Nov 9 14:27:27 2005
@@ -1,9 +1,8 @@
package Class::DBI::Loader::Relationship;
-use 5.006;
use strict;
-use warnings;
-our $VERSION = '1.3';
-our $DEBUG = 0;
+use vars qw($VERSION $DEBUG);
+$VERSION = '1.3';
+$DEBUG = 0;
1;
@@ -96,7 +95,7 @@
"$via_c->has_a(".to_S($to)." => $to_c)\n".
"$from_c->$method($mapper => [ $via_c => ".to_S($to)." ])\n".
"$to_c->has_many(".to_PL($from)." => [ $via_c => ".to_S($from)." ])\n"
- if $DEBUG;
+ if $Class::DBI::Loader::Relationship::DEBUG;
$via_c->has_a(to_S($from) => $from_c);
$via_c->has_a(to_S($to) => $to_c);
@@ -106,7 +105,7 @@
}
return "$from_c->$method($mapper => $to_c);\n".
($method ne "has_a" && "$to_c->has_a(".to_S($from)." => $from_c);\n")
- if $DEBUG;
+ if $Class::DBI::Loader::Relationship::DEBUG;
$from_c->$method($mapper => $to_c);
$to_c->has_a(to_S($from) => $from_c) unless $method eq "has_a";
}

View File

@ -21,10 +21,4 @@ PERL_CONFIGURE= YES
MAN3= Search::Namazu.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-Namazu.xs
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,18 +0,0 @@
--- Namazu.xs.orig Fri Jun 2 21:58:37 2006
+++ Namazu.xs Fri Jun 2 21:59:07 2006
@@ -46,6 +46,15 @@
}
#endif
+/* try to be compatible with older perls */
+/* SvPV_nolen() macro first defined in 5.005_55 */
+/* this is slow, not threadsafe, but works */
+#include "patchlevel.h"
+#if (PATCHLEVEL == 4) || ((PATCHLEVEL == 5) && (SUBVERSION < 55))
+static STRLEN nolen_na;
+# define SvPV_nolen(sv) SvPV ((sv), nolen_na)
+#endif
+
/* for old perl (< 5.004_04?) */
#if !defined(PL_na) && defined(na)
#define PL_na na

View File

@ -40,18 +40,10 @@ MOZ_MK_OPTIONS= MOZ_CO_PROJECT=calendar
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/www/mozilla/Makefile.common"
.if ${OSVERSION} < 500000
BROKEN= does not build
.endif
.if ${ARCH}=="sparc64"
IGNORE= does not build
.endif
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif
post-patch:
@${SED} -e 's|@SUNBIRD_ICON@|${SUNBIRD_ICON}|' \
${FILESDIR}/sunbird.desktop.in >${WRKDIR}/sunbird.desktop

View File

@ -1,10 +0,0 @@
--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
+++ config/make-jars.pl Wed Oct 13 16:17:07 2004
@@ -40,6 +40,7 @@
last if ($arg eq "--");
}
my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
+splice @ARGV, $ddindex, $#ARGV;
getopts("d:s:t:f:avlD:o:p:xz:");

View File

@ -40,18 +40,10 @@ MOZ_MK_OPTIONS= MOZ_CO_PROJECT=calendar
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/www/mozilla/Makefile.common"
.if ${OSVERSION} < 500000
BROKEN= does not build
.endif
.if ${ARCH}=="sparc64"
IGNORE= does not build
.endif
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif
post-patch:
@${SED} -e 's|@SUNBIRD_ICON@|${SUNBIRD_ICON}|' \
${FILESDIR}/sunbird.desktop.in >${WRKDIR}/sunbird.desktop

View File

@ -1,10 +0,0 @@
--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
+++ config/make-jars.pl Wed Oct 13 16:17:07 2004
@@ -40,6 +40,7 @@
last if ($arg eq "--");
}
my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
+splice @ARGV, $ddindex, $#ARGV;
getopts("d:s:t:f:avlD:o:p:xz:");

View File

@ -40,18 +40,10 @@ MOZ_MK_OPTIONS= MOZ_CO_PROJECT=calendar
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/www/mozilla/Makefile.common"
.if ${OSVERSION} < 500000
BROKEN= does not build
.endif
.if ${ARCH}=="sparc64"
IGNORE= does not build
.endif
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif
post-patch:
@${SED} -e 's|@SUNBIRD_ICON@|${SUNBIRD_ICON}|' \
${FILESDIR}/sunbird.desktop.in >${WRKDIR}/sunbird.desktop

View File

@ -1,10 +0,0 @@
--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
+++ config/make-jars.pl Wed Oct 13 16:17:07 2004
@@ -40,6 +40,7 @@
last if ($arg eq "--");
}
my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
+splice @ARGV, $ddindex, $#ARGV;
getopts("d:s:t:f:avlD:o:p:xz:");

View File

@ -19,8 +19,4 @@ PERL_CONFIGURE= yes
MAN3= File::BaseDir.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} <= 500503
EXTRA_PATCHES= ${PATCHDIR}/500503-*
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,39 +0,0 @@
--- BaseDir.pm.orig Sun Aug 22 11:18:29 2004
+++ BaseDir.pm Sun Aug 22 11:20:04 2004
@@ -5,26 +5,28 @@
require File::Spec;
require Exporter;
-our @ISA = qw(Exporter);
-our @EXPORT_OK = qw(
+use vars qw(@ISA @EXPORT_OK $VERSION);
+@ISA = qw(Exporter);
+@EXPORT_OK = qw(
xdg_data_home xdg_data_dirs xdg_data_files
xdg_config_home xdg_config_dirs xdg_config_files
xdg_cache_home
);
-our $VERSION = 0.02;
+$VERSION = 0.02;
my $rootdir = File::Spec->rootdir();
-our $xdg_data_home = File::Spec->catdir($ENV{HOME}, qw/.local share/);
-our @xdg_data_dirs = (
+use vars qw($xdg_data_home @xdg_data_dirs $xdg_config_home @xdg_config_dirs $xdg_cache_home);
+$xdg_data_home = File::Spec->catdir($ENV{HOME}, qw/.local share/);
+@xdg_data_dirs = (
File::Spec->catdir($rootdir, qw/usr local share/),
File::Spec->catdir($rootdir, qw/usr share/),
);
-our $xdg_config_home = File::Spec->catdir($ENV{HOME}, '.config');
-our @xdg_config_dirs = ( File::Spec->catdir($rootdir, qw/etc xdg/) );
+$xdg_config_home = File::Spec->catdir($ENV{HOME}, '.config');
+@xdg_config_dirs = ( File::Spec->catdir($rootdir, qw/etc xdg/) );
-our $xdg_cache_home = File::Spec->catdir($ENV{HOME}, '.cache');
+$xdg_cache_home = File::Spec->catdir($ENV{HOME}, '.cache');
sub new { bless \$VERSION, shift } # what else is there to bless ?

View File

@ -169,12 +169,4 @@ MAN3= Locale::RecodeData::IBM862.3 \
Locale::RecodeData::IBM290.3 \
Locale::RecodeData::IBM903.3 \
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} > 500600
PLIST_SUB= NEWPERL=""
.else
PLIST_SUB= NEWPERL="@comment "
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -145,11 +145,11 @@
%%SITE_PERL%%/Locale/Recode.pm
%%SITE_PERL%%/Locale/gettext_xs.pod
%%SITE_PERL%%/Locale/Messages.pm
%%NEWPERL%%%%SITE_PERL%%/Locale/gettext_xs.pm
%%NEWPERL%%%%SITE_PERL%%/mach/auto/Locale/gettext_xs/gettext_xs.so
%%NEWPERL%%%%SITE_PERL%%/mach/auto/Locale/gettext_xs/gettext_xs.bs
%%NEWPERL%%@dirrm %%SITE_PERL%%/mach/auto/Locale/gettext_xs
%%NEWPERL%%@unexec rmdir %D/%%SITE_PERL%%/mach/auto/Locale
%%SITE_PERL%%/Locale/gettext_xs.pm
%%SITE_PERL%%/mach/auto/Locale/gettext_xs/gettext_xs.so
%%SITE_PERL%%/mach/auto/Locale/gettext_xs/gettext_xs.bs
@dirrm %%SITE_PERL%%/mach/auto/Locale/gettext_xs
@unexec rmdir %D/%%SITE_PERL%%/mach/auto/Locale
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/libintl-perl
@dirrm %%SITE_PERL%%/Locale/RecodeData
@dirrm %%SITE_PERL%%/Locale/Recode

View File

@ -68,11 +68,4 @@ MAN3= Log::Log4perl.3 \
Log::Log4perl::Resurrector.3 \
Log::Log4perl::Util.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} == 500602
EXTRA_PATCHES= ${FILESDIR}/500602-patch-lib__Log__Log4perl__Config__DOMConfigurator.pm
post-patch:
${RM} ${WRKSRC}/lib/Log/Log4perl/Config/DOMConfigurator.pm.orig
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,10 +0,0 @@
--- ./lib/Log/Log4perl/Config/DOMConfigurator.pm.orig Thu Jun 1 23:08:48 2006
+++ ./lib/Log/Log4perl/Config/DOMConfigurator.pm Thu Jun 1 23:09:44 2006
@@ -61,6 +61,7 @@
my $config = $doc->getElementsByTagName("$LOG4J_PREFIX:configuration")->item(0)||
$doc->getElementsByTagName("$LOG4PERL_PREFIX:configuration")->item(0);
+ use utf8;
my $threshold = uc(subst($config->getAttribute('threshold')));
if ($threshold) {
$l4p_tree->{threshold}{value} = $threshold;

View File

@ -22,13 +22,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}/makefiles/Linux
SUBDIRS= ${DOCSDIR} ${DOCSDIR}/misc ${EXAMPLESDIR} \
${EXAMPLESDIR}/include ${EXAMPLESDIR}/tab ${EXAMPLESDIR}/tpl
.include <bsd.port.pre.mk>
pre-fetch:
.if !defined(WITH_FIXPERL) && ${PERL_LEVEL} <= 500503
IGNORE= Follow instructions in pkg-message and restart with -DWITH_FIXPERL
.endif
.if !defined(NOPORTDOCS)
post-install:
${MKDIR} ${SUBDIRS}
@ -42,4 +35,4 @@ post-install:
${CP} ${WRKSRC}/../../doc/example.cfg/tpl/*.tpl ${EXAMPLESDIR}/tpl
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,6 +0,0 @@
******************************************************************
If you are using perl 5.00503, please disable #define HAS_SIGSETJMP
line in /usr/libdata/perl/5.00503/mach/CORE/config.h
******************************************************************

View File

@ -46,12 +46,6 @@ OPTIONS= GNOMEDB "Enable libgnomedb support" off
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
PLIST_SUB+= PERL="@comment "
.else
PLIST_SUB+= PERL=""
.endif
.if defined(WITH_GNOMEDB)
USE_GNOME+= libgnomedb
CONFIGURE_ARGS+= --with-gda

View File

@ -212,11 +212,11 @@ lib/gnumeric/%%VERSION%%/plugins/oleo/plugin.xml
lib/gnumeric/%%VERSION%%/plugins/openoffice/openoffice.la
lib/gnumeric/%%VERSION%%/plugins/openoffice/openoffice.so
lib/gnumeric/%%VERSION%%/plugins/openoffice/plugin.xml
%%PERL%%lib/gnumeric/%%VERSION%%/plugins/perl-func/perl_func.pl
%%PERL%%lib/gnumeric/%%VERSION%%/plugins/perl-func/plugin.xml
%%PERL%%lib/gnumeric/%%VERSION%%/plugins/perl-loader/perl_loader.la
%%PERL%%lib/gnumeric/%%VERSION%%/plugins/perl-loader/perl_loader.so
%%PERL%%lib/gnumeric/%%VERSION%%/plugins/perl-loader/plugin.xml
lib/gnumeric/%%VERSION%%/plugins/perl-func/perl_func.pl
lib/gnumeric/%%VERSION%%/plugins/perl-func/plugin.xml
lib/gnumeric/%%VERSION%%/plugins/perl-loader/perl_loader.la
lib/gnumeric/%%VERSION%%/plugins/perl-loader/perl_loader.so
lib/gnumeric/%%VERSION%%/plugins/perl-loader/plugin.xml
lib/gnumeric/%%VERSION%%/plugins/plan_perfect/plan_perfect.la
lib/gnumeric/%%VERSION%%/plugins/plan_perfect/plan_perfect.so
lib/gnumeric/%%VERSION%%/plugins/plan_perfect/plugin.xml
@ -904,8 +904,8 @@ share/locale/zh_TW/LC_MESSAGES/gnumeric.mo
@dirrm lib/gnumeric/%%VERSION%%/plugins/py-func
@dirrm lib/gnumeric/%%VERSION%%/plugins/psiconv
@dirrm lib/gnumeric/%%VERSION%%/plugins/plan_perfect
%%PERL%%@dirrm lib/gnumeric/%%VERSION%%/plugins/perl-loader
%%PERL%%@dirrm lib/gnumeric/%%VERSION%%/plugins/perl-func
@dirrm lib/gnumeric/%%VERSION%%/plugins/perl-loader
@dirrm lib/gnumeric/%%VERSION%%/plugins/perl-func
@dirrm lib/gnumeric/%%VERSION%%/plugins/openoffice
@dirrm lib/gnumeric/%%VERSION%%/plugins/oleo
@dirrm lib/gnumeric/%%VERSION%%/plugins/numtheory

View File

@ -23,10 +23,5 @@ MAN3= IO::Socket::INET6.3
PERL_CONFIGURE= yes
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES= ${PATCHDIR}/5.005_03.diff
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,32 +0,0 @@
$FreeBSD$
--- INET6.pm.orig
+++ INET6.pm
@@ -10,7 +10,7 @@
package IO::Socket::INET6;
use strict;
-our(@ISA, $VERSION);
+use vars qw(@ISA $VERSION);
use IO::Socket;
use Socket;
use Socket6;
@@ -22,7 +22,7 @@
$VERSION = "2.51";
#Purpose: allow protocol independent protocol and original interface.
-my $EINVAL = exists(&Errno::EINVAL) ? Errno::EINVAL() : 1;
+my $EINVAL = defined(&Errno::EINVAL) ? Errno::EINVAL() : 1;
IO::Socket::INET6->register_domain( AF_INET6 );
@@ -190,7 +190,7 @@
}
if ($arg->{ReusePort}) {
- $sock->sockopt(SO_REUSEPORT,1) or
+ $sock->sockopt(0x0200,1) or
return _error($sock, $!, "sockopt: $!");
}

View File

@ -23,10 +23,5 @@ MAN3= IO::Socket::INET6.3
PERL_CONFIGURE= yes
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES= ${PATCHDIR}/5.005_03.diff
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,32 +0,0 @@
$FreeBSD$
--- INET6.pm.orig
+++ INET6.pm
@@ -10,7 +10,7 @@
package IO::Socket::INET6;
use strict;
-our(@ISA, $VERSION);
+use vars qw(@ISA $VERSION);
use IO::Socket;
use Socket;
use Socket6;
@@ -22,7 +22,7 @@
$VERSION = "2.51";
#Purpose: allow protocol independent protocol and original interface.
-my $EINVAL = exists(&Errno::EINVAL) ? Errno::EINVAL() : 1;
+my $EINVAL = defined(&Errno::EINVAL) ? Errno::EINVAL() : 1;
IO::Socket::INET6->register_domain( AF_INET6 );
@@ -190,7 +190,7 @@
}
if ($arg->{ReusePort}) {
- $sock->sockopt(SO_REUSEPORT,1) or
+ $sock->sockopt(0x0200,1) or
return _error($sock, $!, "sockopt: $!");
}

View File

@ -26,15 +26,4 @@ PERL_CONFIGURE= yes
MAN3= Digest::SHA2.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES= ${PATCHDIR}/extrapatch-SHA2.xs
post-patch:
${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1); $$1/;' ${WRKSRC}/SHA2.pm
${PERL} -pi -e '$$_="" if m{warnings}' ${WRKSRC}/SHA2.pm ${WRKSRC}/t/*.t
${PERL} -pi -e 's/\)/, char **env\)/ if m{int main}' ${WRKSRC}/_sha2.c
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,18 +0,0 @@
--- SHA2.xs.orig Sat Dec 24 21:15:29 2005
+++ SHA2.xs Sat Dec 24 21:16:10 2005
@@ -4,6 +4,15 @@
#include "ppport.h"
#include "_sha2.c"
+/* try to be compatible with older perls */
+/* SvPV_nolen() macro first defined in 5.005_55 */
+/* this is slow, not threadsafe, but works */
+#include "patchlevel.h"
+#if (PATCHLEVEL == 4) || ((PATCHLEVEL == 5) && (SUBVERSION < 55))
+static STRLEN nolen_na;
+# define SvPV_nolen(sv) SvPV ((sv), nolen_na)
+#endif
+
typedef struct sha2 {
SHA256_CTX ctx256;
SHA384_CTX ctx384;

View File

@ -21,15 +21,4 @@ PERL_CONFIGURE= yes
MAN1= whirlpoolsum.1
MAN3= Digest::Whirlpool.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES= ${PATCHDIR}/extrapatch-Whirlpool.xs
post-patch:
${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1); $$1/;' ${WRKSRC}/Whirlpool.pm
${PERL} -pi -e '$$_="" if m{warnings}' ${WRKSRC}/Whirlpool.pm ${WRKSRC}/t/*.t
${PERL} -pi -e 's/\)/, char **env\)/ if m{int main}' ${WRKSRC}/_whirlpool.c
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,18 +0,0 @@
--- Whirlpool.xs.orig Sat Dec 24 23:41:30 2005
+++ Whirlpool.xs Sat Dec 24 23:42:16 2005
@@ -4,6 +4,15 @@
#include "ppport.h"
#include "_whirlpool.c"
+/* try to be compatible with older perls */
+/* SvPV_nolen() macro first defined in 5.005_55 */
+/* this is slow, not threadsafe, but works */
+#include "patchlevel.h"
+#if (PATCHLEVEL == 4) || ((PATCHLEVEL == 5) && (SUBVERSION < 55))
+static STRLEN nolen_na;
+# define SvPV_nolen(sv) SvPV ((sv), nolen_na)
+#endif
+
typedef struct whirlpool {
NESSIEstruct state;
}* Digest__Whirlpool;

View File

@ -32,13 +32,4 @@ post-install:
${INSTALL_DATA} ${SRCDIR}/req.conf ${EXAMPLESDIR}/req.conf
.endif
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-SSLeay.xs
post-patch:
${PERL} -pi -e 's/\$\^V/\$\]/' ${WRKSRC}/Net-SSLeay-Handle-*/Handle.pm
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,16 +0,0 @@
--- SSLeay.xs.orig Sat Dec 31 17:20:25 2005
+++ SSLeay.xs Sat Dec 31 17:23:39 2005
@@ -94,6 +94,13 @@
}
#endif
+#ifndef XST_mPVN
+#define XST_mPVN(i,v,n) (ST(i) = sv_2mortal(newSVpvn(v,n)))
+#endif
+#ifndef XSRETURN_PVN
+#define XSRETURN_PVN(v,n) STMT_START { XST_mPVN(0,v,n); XSRETURN(1); } STMT_END
+#endif
+
/* OpenSSL-0.9.3a has some strange warning about this in
* openssl/des.h
*/

View File

@ -25,19 +25,8 @@ MAN3= Pod::Checker.3 Pod::Find.3 Pod::InputObjects.3 \
Pod::ParseUtils.3 Pod::Parser.3 Pod::PlainText.3 Pod::Select.3 \
Pod::Usage.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
PLIST_SUB+= PL_FILES=""
.else
.undef MAN1
PLIST_SUB+= PL_FILES="@comment "
.endif
post-patch:
.if ${PERL_LEVEL} >= 500600
@${REINPLACE_CMD} -e '/EXE_FILES/d' ${WRKSRC}/Makefile.PL
.endif
@${FIND} ${WRKSRC} -name \*.orig -exec ${RM} {} \;
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,6 +1,6 @@
%%PL_FILES%%bin/pod2usage
%%PL_FILES%%bin/podchecker
%%PL_FILES%%bin/podselect
bin/pod2usage
bin/podchecker
bin/podselect
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/Parser/.packlist
%%SITE_PERL%%/Pod/Checker.pm
%%SITE_PERL%%/Pod/Find.pm

View File

@ -26,10 +26,4 @@ PERL_ABASE= ${SITE_PERL}/${PERL_ARCH}
MAN3= XML::LibXSLT.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES= ${FILESDIR}/500503-*
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,26 +0,0 @@
--- LibXSLT.xs.orig Mon Mar 1 21:42:43 2004
+++ LibXSLT.xs Sun May 16 20:21:57 2004
@@ -29,6 +29,23 @@
}
#endif
+#ifndef dTHX
+#define dTHX extern int errno
+#endif
+
+#ifndef SvPV_nolen
+#define SvPV_nolen(sv) \
+ ((SvFLAGS(sv) & (SVf_POK)) == SVf_POK \
+ ? SvPVX(sv) : sv_2pv_nolen(sv))
+
+static char *
+sv_2pv_nolen(register SV *sv)
+{
+ STRLEN n_a;
+ return sv_2pv(sv, &n_a);
+}
+#endif
+
#define SET_CB(cb, fld) \
RETVAL = cb ? newSVsv(cb) : &PL_sv_undef;\
if (SvOK(fld)) {\

View File

@ -22,26 +22,13 @@ BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
MAN1= pod2man.1 pod2text.1
MAN3= Pod::Man.3 Pod::ParseLink.3 Pod::Text.3 Pod::Text::Color.3 \
Pod::Text::Overstrike.3 Pod::Text::Termcap.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} >= 500600
.undef MAN1
PLIST_SUB= PL_FILES="@comment "
.else
RUN_DEPENDS+= ${SITE_PERL}/Term/ANSIColor.pm:${PORTSDIR}/devel/p5-Term-ANSIColor
PLIST_SUB= PL_FILES=""
.endif
post-patch:
.if ${PERL_LEVEL} >= 500600
@${REINPLACE_CMD} -Ee '/(pod2man|pod2text)/d' ${WRKSRC}/Makefile.PL
.endif
@${REINPLACE_CMD} -e 's/->\$$method;/->\$$method\(\);/g' ${WRKSRC}/lib/Pod/*.pm
@${REINPLACE_CMD} -e 's/\$${char}/(\$${char})/g' ${WRKSRC}/lib/Pod/Text/*.pm
@${FIND} ${WRKSRC} -name "*.bak" -delete
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,5 +1,3 @@
%%PL_FILES%%bin/pod2man
%%PL_FILES%%bin/pod2text
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/.packlist
%%SITE_PERL%%/Pod/Man.pm
%%SITE_PERL%%/Pod/ParseLink.pm

View File

@ -66,10 +66,6 @@ MOZ_OPTIONS+= --disable-svg
#MOZ_OPTIONS+= --enable-svg --enable-svg-renderer=cairo
#.endif
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif
post-extract::
@${SED} -e 's|@FIREFOX_ICON@|${FIREFOX_ICON}|' -e 's|@MOZILLA@|${MOZILLA}|' \
-e 's|@MOZILLA_NAME@|${MOZILLA_NAME}|' \

View File

@ -1,10 +0,0 @@
--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
+++ config/make-jars.pl Wed Oct 13 16:17:07 2004
@@ -40,6 +40,7 @@
last if ($arg eq "--");
}
my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
+splice @ARGV, $ddindex, $#ARGV;
getopts("d:s:t:f:avlD:o:p:xz:");

View File

@ -64,10 +64,6 @@ IGNORE= does not run, update to 6.2-RELEASE or newer
MOZ_OPTIONS+= --enable-svg --enable-svg-renderer=cairo
.endif
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif
post-extract::
@${SED} -e 's|@FIREFOX_ICON@|${FIREFOX_ICON}|' -e 's|@MOZILLA@|${MOZILLA}|' \
-e 's|@MOZILLA_NAME@|${MOZILLA_NAME}|' \

View File

@ -1,10 +0,0 @@
--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
+++ config/make-jars.pl Wed Oct 13 16:17:07 2004
@@ -40,6 +40,7 @@
last if ($arg eq "--");
}
my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
+splice @ARGV, $ddindex, $#ARGV;
getopts("d:s:t:f:avlD:o:p:xz:");

View File

@ -64,10 +64,6 @@ IGNORE= does not run, update to 6.2-RELEASE or newer
MOZ_OPTIONS+= --enable-svg --enable-svg-renderer=cairo
.endif
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif
post-extract::
@${SED} -e 's|@FIREFOX_ICON@|${FIREFOX_ICON}|' -e 's|@MOZILLA@|${MOZILLA}|' \
-e 's|@MOZILLA_NAME@|${MOZILLA_NAME}|' \

View File

@ -1,10 +0,0 @@
--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
+++ config/make-jars.pl Wed Oct 13 16:17:07 2004
@@ -40,6 +40,7 @@
last if ($arg eq "--");
}
my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
+splice @ARGV, $ddindex, $#ARGV;
getopts("d:s:t:f:avlD:o:p:xz:");

View File

@ -63,10 +63,6 @@ IGNORE= core dumps on ${ARCH}, kern.osreldate>=601101 needed
MOZ_OPTIONS+= --enable-svg --enable-svg-renderer=cairo
.endif
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif
post-extract::
@${SED} -e 's|@FIREFOX_ICON@|${FIREFOX_ICON}|' \
<${FILESDIR}/firefox.desktop.in >${WRKDIR}/${MOZILLA}.desktop

View File

@ -1,10 +0,0 @@
--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
+++ config/make-jars.pl Wed Oct 13 16:17:07 2004
@@ -40,6 +40,7 @@
last if ($arg eq "--");
}
my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
+splice @ARGV, $ddindex, $#ARGV;
getopts("d:s:t:f:avlD:o:p:xz:");

View File

@ -66,10 +66,6 @@ MOZ_OPTIONS+= --disable-svg
#MOZ_OPTIONS+= --enable-svg --enable-svg-renderer=cairo
#.endif
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif
post-extract::
@${SED} -e 's|@FIREFOX_ICON@|${FIREFOX_ICON}|' -e 's|@MOZILLA@|${MOZILLA}|' \
-e 's|@MOZILLA_NAME@|${MOZILLA_NAME}|' \

View File

@ -1,10 +0,0 @@
--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
+++ config/make-jars.pl Wed Oct 13 16:17:07 2004
@@ -40,6 +40,7 @@
last if ($arg eq "--");
}
my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
+splice @ARGV, $ddindex, $#ARGV;
getopts("d:s:t:f:avlD:o:p:xz:");

View File

@ -66,10 +66,6 @@ MOZ_OPTIONS+= --disable-svg
#MOZ_OPTIONS+= --enable-svg --enable-svg-renderer=cairo
#.endif
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif
post-extract::
@${SED} -e 's|@FIREFOX_ICON@|${FIREFOX_ICON}|' -e 's|@MOZILLA@|${MOZILLA}|' \
-e 's|@MOZILLA_NAME@|${MOZILLA_NAME}|' \

View File

@ -1,10 +0,0 @@
--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
+++ config/make-jars.pl Wed Oct 13 16:17:07 2004
@@ -40,6 +40,7 @@
last if ($arg eq "--");
}
my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
+splice @ARGV, $ddindex, $#ARGV;
getopts("d:s:t:f:avlD:o:p:xz:");

View File

@ -64,10 +64,6 @@ IGNORE= does not run, update to 6.2-RELEASE or newer
MOZ_OPTIONS+= --enable-svg --enable-svg-renderer=cairo
.endif
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif
post-extract::
@${SED} -e 's|@FIREFOX_ICON@|${FIREFOX_ICON}|' -e 's|@MOZILLA@|${MOZILLA}|' \
-e 's|@MOZILLA_NAME@|${MOZILLA_NAME}|' \

View File

@ -1,10 +0,0 @@
--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
+++ config/make-jars.pl Wed Oct 13 16:17:07 2004
@@ -40,6 +40,7 @@
last if ($arg eq "--");
}
my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
+splice @ARGV, $ddindex, $#ARGV;
getopts("d:s:t:f:avlD:o:p:xz:");

View File

@ -68,10 +68,6 @@ IGNORE= core dumps on ${ARCH}, need kern.osreldate>=601101
MOZ_OPTIONS+= --enable-svg --enable-svg-renderer=cairo
.endif
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif
post-extract::
@${SED} -e 's|@FLOCK_ICON@|${FLOCK_ICON}|' -e 's|@MOZILLA@|${MOZILLA}|' \
-e 's|@MOZILLA_NAME@|${MOZILLA_NAME}|' \

View File

@ -1,10 +0,0 @@
--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
+++ config/make-jars.pl Wed Oct 13 16:17:07 2004
@@ -40,6 +40,7 @@
last if ($arg eq "--");
}
my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
+splice @ARGV, $ddindex, $#ARGV;
getopts("d:s:t:f:avlD:o:p:xz:");

View File

@ -37,10 +37,6 @@ BROKEN= does not build
IGNORE= does not build
.endif
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif
post-patch:
@${RM} -f ${WRKSRC}/config.status ${WRKSRC}/config.cache
@${ECHO_CMD} "LDFLAGS += -L${LOCALBASE}/lib" >> ${WRKSRC}/toolkit/components/Makefile.in

View File

@ -1,10 +0,0 @@
--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
+++ config/make-jars.pl Wed Oct 13 16:17:07 2004
@@ -40,6 +40,7 @@
last if ($arg eq "--");
}
my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
+splice @ARGV, $ddindex, $#ARGV;
getopts("d:s:t:f:avlD:o:p:xz:");

View File

@ -37,10 +37,6 @@ BROKEN= does not build
IGNORE= does not build
.endif
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-config_make-jars.pl
.endif
post-patch:
@${RM} -f ${WRKSRC}/config.status ${WRKSRC}/config.cache
@${ECHO_CMD} "LDFLAGS += -L${LOCALBASE}/lib" >> ${WRKSRC}/toolkit/components/Makefile.in

View File

@ -1,10 +0,0 @@
--- config/make-jars.pl.orig Wed Oct 13 16:17:11 2004
+++ config/make-jars.pl Wed Oct 13 16:17:07 2004
@@ -40,6 +40,7 @@
last if ($arg eq "--");
}
my $defines = join(' ', @ARGV[ $ddindex .. $#ARGV ]);
+splice @ARGV, $ddindex, $#ARGV;
getopts("d:s:t:f:avlD:o:p:xz:");

View File

@ -50,15 +50,6 @@ post-configure:
-e 'if (/manifypods :/) {$$_ .= "\tlib/CGI/Kwiki/Config.pm \\\n\tlib/CGI/Kwiki/Config_yaml.pm \\\n" };' \
-e 'if (/\@\$$\(POD2MAN\)/) { $$_ .= "\tlib/CGI/Kwiki/Config.pm \\\n\t\$$(INST_MAN3DIR)/CGI::Kwiki::Config.\$$(MAN3EXT) \\\n\tlib/CGI/Kwiki/Config_yaml.pm \\\n\t\$$(INST_MAN3DIR)/CGI::Kwiki::Config_yaml.\$$(MAN3EXT) \\\n"};' \
${WRKSRC}/Makefile
.if ${PERL_LEVEL} < 500601
EXTRA_PATCHES= ${FILESDIR}/p5005-patch-CGI-Kwiki-Template.pm
post-patch:
${PERL} -pi -e '$$_ = "" if /warnings/;' \
-e 's/\$$\w+(->\w+)?->\$$\w+\b(?!\()/$$&()/g;' \
${WRKSRC}/lib/CGI/Kwiki/New.pm \
${WRKSRC}/lib/CGI/Kwiki/Prefs.pm
@${FIND} ${WRKSRC} -name \*.orig | ${XARGS} ${RM}
.endif
.endif
.include <bsd.port.post.mk>

View File

@ -1,12 +0,0 @@
--- lib/CGI/Kwiki/Template.pm.orig Fri Aug 29 09:30:19 2003
+++ lib/CGI/Kwiki/Template.pm Wed Oct 15 11:37:23 2003
@@ -71,7 +71,8 @@
my ($self, $text, $v) = @_;
my $re;
$text = $self->loc($text);
- $re = qr/\[((?:(?>[^\[\]]+)|(??{$re}))*)\]/;
+ #$re = qr/\[((?:(?>[^\[\]]+)|(??{$re}))*)\]/;
+ $re = qr/\[((?:(?>[^\[\]]+)|\[[^\[\]]*\])*)\]/;
$text =~ s{$re}
{<a href="[% script %]?$1">$1</a>}g;
$text =~ s{\[%\s+(\w+)\s+%\]\n?}