wb compatible open source shared whiteboard program

This commit is contained in:
Assar Westerlund 2001-05-11 19:31:14 +00:00
parent df4bb3e2a4
commit 41802de459
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=42535
7 changed files with 90 additions and 0 deletions

View File

@ -1,5 +1,6 @@
# $FreeBSD$
#
SUBDIR += wbd
SUBDIR += imm
SUBDIR += nte

21
mbone/wbd/Makefile Normal file
View File

@ -0,0 +1,21 @@
# New ports collection makefile for: wbd
# Date created: 11 May 2001
# Whom: assar
#
# $FreeBSD$
#
PORTNAME= wbd
PORTVERSION= 1.0u4
CATEGORIES= mbone
MASTER_SITES= http://www-mice.cs.ucl.ac.uk/multimedia/software/wbd/1.0ucl4/
DISTNAME= wbd-1.0ucl4
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= tk80.1:${PORTSDIR}/x11-toolkits/tk80
WRKSRC= ${WRKDIR}/wbd
MAKEFILE= makefile
.include <bsd.port.mk>

1
mbone/wbd/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (wbd-1.0ucl4.tar.gz) = 08fe22da79d3b6b0a62bc65fde4fdd57

61
mbone/wbd/files/patch-aa Normal file
View File

@ -0,0 +1,61 @@
--- makefile.orig Thu Jan 29 12:46:41 1998
+++ makefile Fri May 11 19:42:18 2001
@@ -3,12 +3,12 @@
YFLAGS = -dv
CFLAGS = -g $(LIBFLAGS) $(IFLAGS) -DSTAND_ALONE
-LIBDIR = /cs/research/mice/starship/common/solaris/lib
-INCDIR = /cs/research/mice/starship/common/solaris/include
+LIBDIR = $(PREFIX)/lib
+INCDIR = $(PREFIX)/include
# The files needed from the tcl/tk library directories...
-LIBRARY_TK = $(LIBDIR)/tk4.2
-LIBRARY_TCL = $(LIBDIR)/tcl7.6
+LIBRARY_TK = $(LIBDIR)/tk8.0
+LIBRARY_TCL = $(LIBDIR)/tcl8.0
# Uncomment these lines for SGI (IRIX 5.3).
@@ -32,10 +32,10 @@
#LIBS = -ll -ltk4.2 -ltcl7.6 -lm -lX11
# Uncomment these lines for Sun (SunOS 5.5.1).
-CC = gcc -DFNDELAY=O_NDELAY -DBYTE_ORDER=4321 -ansi
-LIBFLAGS = -L$(LIBDIR) -L/usr/openwin/lib
-IFLAGS = -I$(INCDIR) -I/usr/openwin/include
-LIBS = -ll -ltk4.2 -ltcl7.6 -lm -lX11 -lsocket -lnsl -ldl
+#CC = gcc -DFNDELAY=O_NDELAY -DBYTE_ORDER=4321 -ansi
+#LIBFLAGS = -L$(LIBDIR) -L/usr/openwin/lib
+#IFLAGS = -I$(INCDIR) -I/usr/openwin/include
+#LIBS = -ll -ltk4.2 -ltcl7.6 -lm -lX11 -lsocket -lnsl -ldl
# Uncomment these lines for NetBSD 1.2.
#CC = cc -ansi
@@ -43,6 +43,12 @@
#IFLAGS = -I$(INCDIR)
#LIBS = -ll -ltk4.2 -ltcl7.6 -lm -lX11
+# Uncomment these lines for FreeBSD
+CC = cc
+LIBFLAGS = -L$(LIBDIR) -L/usr/X11R6/lib
+IFLAGS = -I$(INCDIR)/tk8.0 -I$(INCDIR)/tcl8.0 -I/usr/X11R6/include
+LIBS = -ll -ltk80 -ltcl80 -lm -lX11
+
# Tcl initialisation files to be compiled into a C string.
TCL_FILES = \
$(LIBRARY_TCL)/init.tcl \
@@ -74,8 +80,13 @@
SRC = main.c comms.c db.c wbd.tcl
OBJ = main.o comms.o db.o tcllibs.o
+all : wbd
+
wbd : $(OBJ) $(INC)
$(CC) $(CFLAGS) $(OBJ) $(LIBS) -o wbd
+
+install : wbd
+ install -c wbd $(PREFIX)/bin/wbd
clean :
rm -f *.o tcl2c wbd core

1
mbone/wbd/pkg-comment Normal file
View File

@ -0,0 +1 @@
A shared drawing (whiteboard) tool using multicast, compatible with wb

4
mbone/wbd/pkg-descr Normal file
View File

@ -0,0 +1,4 @@
This is a port of wbd, a open-source program compatible with the LBL
program wb, which is multicast-based whiteboard program.
WWW: http://www-mice.cs.ucl.ac.uk/multimedia/software/wbd/

1
mbone/wbd/pkg-plist Normal file
View File

@ -0,0 +1 @@
bin/wbd