Move package files from plist to Makefile, remove pkg-plist.

Respect CFLAGS by comment on CDEBUGFLAGS (aka -O2 -g -Wall).
This commit is contained in:
Sergey A. Osokin 2004-07-27 06:31:58 +00:00
parent 87f39b0573
commit 416121ea90
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=114846
3 changed files with 15 additions and 7 deletions

View File

@ -21,6 +21,8 @@ USE_IMAKE= yes
USE_XPM= yes
USE_MOTIF= yes
PLIST_FILES= bin/xmradio lib/X11/app-defaults/XMradio
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000

View File

@ -1,8 +1,8 @@
--- Imakefile.orig Wed Nov 1 09:53:30 2000
+++ Imakefile Wed Nov 1 09:54:05 2000
--- Imakefile.orig Wed Nov 14 01:33:48 2001
+++ Imakefile Tue Jul 27 10:25:29 2004
@@ -4,9 +4,10 @@
#endif
#ifdef NetBSDArchitecture
-LOCAL_LIBRARIES = XmClientLibs ${XMULIB} -lXpm -lossaudio -lm
+LOCAL_LIBRARIES = ${MOTIFLIB} ${XTOOLLIB} $(XPLIB) ${XLIB} ${XMULIB} -lXpm -los
@ -10,7 +10,15 @@
#else
-LOCAL_LIBRARIES = XmClientLibs ${XMULIB} -lXpm -lm
+LOCAL_LIBRARIES = ${MOTIFLIB} ${XTOOLLIB} $(XPLIB) ${XLIB} ${XMULIB} -lXpm -lm
EXTRA_LDOPTIONS = -L/usr/local/lib -Wl,-R/usr/local/lib
INCLUDES = -I/usr/local/include
@@ -15,7 +16,7 @@
SRCS = radio.c remote.c analyzer.c sample.c misc.c config.c version_check.c LiteClue.c lcd_net.c
OBJS = radio.o remote.o analyzer.o sample.o misc.o config.o version_check.o LiteClue.o lcd_net.o
-CDEBUGFLAGS = -O2 -g -Wall
+#CDEBUGFLAGS = -O2 -g -Wall
XCOMM CCOPTIONS= -DJUHA_DRIVER -DHAS_XPM
CCOPTIONS= -DHAS_XPM

View File

@ -1,2 +0,0 @@
bin/xmradio
lib/X11/app-defaults/XMradio