The Freedroid RPG is an extension/modification of the classical Freedroid
engine into an RPG. PR: ports/83658 Submitted by: Travis Poppe <tlp@liquidx.org>
This commit is contained in:
parent
34b109962e
commit
415e4bba79
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=139602
@ -151,6 +151,7 @@
|
||||
SUBDIR += freeciv-gtk2
|
||||
SUBDIR += freedoko
|
||||
SUBDIR += freedroid
|
||||
SUBDIR += freedroidrpg
|
||||
SUBDIR += freesci
|
||||
SUBDIR += freesweep
|
||||
SUBDIR += frikqcc
|
||||
|
43
games/freedroidrpg/Makefile
Normal file
43
games/freedroidrpg/Makefile
Normal file
@ -0,0 +1,43 @@
|
||||
# New ports collection makefile for: freedroidrpg
|
||||
# Date created: 18 Jul 2005
|
||||
# Whom: Travis Poppe <tlp@liquidx.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= freedroidrpg
|
||||
PORTVERSION= 0.9.13.r2
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= freedroid
|
||||
DISTNAME= ${PORTNAME}-0.9.13-rc2
|
||||
|
||||
MAINTAINER= alejandro@varnet.biz
|
||||
COMMENT= Modification of the classical Freedroid engine into an RPG
|
||||
|
||||
LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
|
||||
png:${PORTSDIR}/graphics/png \
|
||||
vorbis.3:${PORTSDIR}/audio/libvorbis
|
||||
|
||||
USE_XLIB= yes
|
||||
USE_BZIP2= yes
|
||||
USE_SDL= mixer image net sdl
|
||||
USE_REINPLACE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= gtk12
|
||||
|
||||
CONFIGURE_ARGS= --program-transform-name=
|
||||
|
||||
MAN6= freedroidRPG.6
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
BROKEN= "does not compile (missing fenv.h)"
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's#-lSDL # #' ${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.post.mk>
|
2
games/freedroidrpg/distinfo
Normal file
2
games/freedroidrpg/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
MD5 (freedroidrpg-0.9.13-rc2.tar.bz2) = eda34581d784cbd1db59ebc46208880e
|
||||
SIZE (freedroidrpg-0.9.13-rc2.tar.bz2) = 71145621
|
11
games/freedroidrpg/files/patch-DialogEditor.c
Normal file
11
games/freedroidrpg/files/patch-DialogEditor.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/DialogEditor.c.orig Mon Jul 18 02:45:24 2005
|
||||
+++ src/DialogEditor.c Mon Jul 18 02:46:23 2005
|
||||
@@ -32,6 +32,8 @@
|
||||
#define NATIVE_WIN32
|
||||
#endif
|
||||
|
||||
+#include <getopt.h>
|
||||
+
|
||||
#include <gtk/gtk.h>
|
||||
#include <gdk/gdk.h>
|
||||
#include <gdk/gdkkeysyms.h>
|
18
games/freedroidrpg/files/patch-init.c
Normal file
18
games/freedroidrpg/files/patch-init.c
Normal file
@ -0,0 +1,18 @@
|
||||
--- src/init.c.orig Mon Jul 18 02:00:54 2005
|
||||
+++ src/init.c Mon Jul 18 02:05:10 2005
|
||||
@@ -58,14 +58,9 @@
|
||||
* section about 'Arithmethic', subsection on floating point control
|
||||
* functions.
|
||||
* ---------------------------------------------------------------------- */
|
||||
-#if defined __APPLE_CC__
|
||||
-/* turn off these function-call on OS X, where there are not present */
|
||||
+/* turn off these function-call */
|
||||
int feenableexcept (int excepts) { return 0;}
|
||||
int fedisableexcept (int TheExceptionFlags ) { return 0; }
|
||||
-#else
|
||||
-extern int feenableexcept (int excepts);
|
||||
-extern int fedisableexcept (int TheExceptionFlags );
|
||||
-#endif
|
||||
|
||||
/* ----------------------------------------------------------------------
|
||||
*
|
20
games/freedroidrpg/files/patch-misc.c
Normal file
20
games/freedroidrpg/files/patch-misc.c
Normal file
@ -0,0 +1,20 @@
|
||||
--- src/misc.c.orig Mon Jul 18 02:13:52 2005
|
||||
+++ src/misc.c Mon Jul 18 02:19:36 2005
|
||||
@@ -294,7 +294,7 @@
|
||||
// including the operating system (or rather libc) call to main() in
|
||||
// the beginning of execution.
|
||||
//
|
||||
- backtrace_size = backtrace ( backtrace_array , MAX_CALLS_IN_BACKTRACE );
|
||||
+ // backtrace_size = backtrace ( backtrace_array , MAX_CALLS_IN_BACKTRACE );
|
||||
|
||||
fprintf ( stderr , "print_trace: Obtained %zd stack frames.\n", backtrace_size );
|
||||
|
||||
@@ -307,7 +307,7 @@
|
||||
// Also there might be a problem with non-ELF binaries, but let's
|
||||
// hope that it still works...
|
||||
//
|
||||
- backtrace_strings = backtrace_symbols ( backtrace_array , backtrace_size );
|
||||
+ // backtrace_strings = backtrace_symbols ( backtrace_array , backtrace_size );
|
||||
|
||||
fprintf ( stderr , "print_trace: Obtaining symbols now done.\n" );
|
||||
|
23
games/freedroidrpg/pkg-descr
Normal file
23
games/freedroidrpg/pkg-descr
Normal file
@ -0,0 +1,23 @@
|
||||
The Freedroid RPG is an extension/modification of the classical Freedroid
|
||||
engine into an RPG. The main differences to the classical version are as
|
||||
follows:
|
||||
|
||||
* The Tux is the main character of the rpg.
|
||||
* The game uses isometric viewpoint and animated pre-rendered 3d character
|
||||
models for all characters inside the game.
|
||||
* Dialogs and chatting with friendly droids and humans:
|
||||
Multiple-choice menus and voice samples (with subtitles for those
|
||||
without sound).
|
||||
* There is an item and inventory system that is modeled after some
|
||||
popular standards of the industry :)
|
||||
* An automap feature was added. (this is currently a bit unmaintained
|
||||
since part of the code needs to be re-written for proper OpenGL
|
||||
support in the automap display)
|
||||
* Saving and loading of games.
|
||||
* Shops to trade things and skills to learn.
|
||||
* Controls are different: Mouse is the input method of choice.
|
||||
* This is a graphically intense game. Therefore the archive size is
|
||||
comparably *huge* and not suitable for modem downloads with a dialup
|
||||
connection.
|
||||
|
||||
WWW: http://freedroid.sourceforge.net
|
5587
games/freedroidrpg/pkg-plist
Normal file
5587
games/freedroidrpg/pkg-plist
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user