- Update net/ndpi to 2.2.2 snapshot
- Update net/ntopng to 3.4 snapshot - Change versioning scheme to conform to porter's handbook best practices - Bump PORTEPOCH to avoid version number going backwards - Remove patches included upstream - Remove unneeded USE_LDCONFIG in ntopng
This commit is contained in:
parent
b1b32f2c80
commit
41241f7c87
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=471572
@ -2,7 +2,8 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ndpi
|
||||
PORTVERSION= 2.2.2018.01.31
|
||||
PORTVERSION= 2.2.2.d20180406
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= net
|
||||
|
||||
MAINTAINER= madpilot@FreeBSD.org
|
||||
@ -25,11 +26,18 @@ INSTALL_TARGET= install-strip
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= ntop
|
||||
GH_PROJECT= nDPI
|
||||
GH_TAGNAME= cf06823
|
||||
GH_TAGNAME= 0e11abc
|
||||
|
||||
PLIST_SUB= MAJOR_VER=${PORTVERSION:C/([[:digit:]])+\.([[:digit:]])+.*/\1.\2/}.0
|
||||
PLIST_SUB= MAJOR_VER=${PORTVERSION:R}
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} '/ndpi_config\.h/d' \
|
||||
${WRKSRC}/src/include/ndpi_main.h
|
||||
cd ${WRKSRC} && ${SH} autogen.sh
|
||||
|
||||
post-configure:
|
||||
@${REINPLACE_CMD} -e 's/#define PACKAGE/#define NDPI_PACKAGE/g' \
|
||||
-e 's/#define VERSION/#define NDPI_VERSION/g' \
|
||||
${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1521102931
|
||||
SHA256 (ntop-nDPI-2.2.2018.01.31-cf06823_GH0.tar.gz) = 8fd272ec7d65daa636dd63762b15b65fe062115e51560dd73f94a9fc55ff5a57
|
||||
SIZE (ntop-nDPI-2.2.2018.01.31-cf06823_GH0.tar.gz) = 19938657
|
||||
TIMESTAMP = 1528128978
|
||||
SHA256 (ntop-nDPI-2.2.2.d20180406-0e11abc_GH0.tar.gz) = f59b8b4d960fb6fe3bbf8d67785c6798c34165e12c217105de3860d8fac5c372
|
||||
SIZE (ntop-nDPI-2.2.2.d20180406-0e11abc_GH0.tar.gz) = 20449092
|
||||
|
@ -1,16 +1,16 @@
|
||||
--- autogen.sh.orig 2017-12-03 18:07:29 UTC
|
||||
--- autogen.sh.orig 2018-04-06 15:23:12 UTC
|
||||
+++ autogen.sh
|
||||
@@ -5,34 +5,4 @@ NDPI_MINOR="2"
|
||||
NDPI_PATCH="0"
|
||||
@@ -5,44 +5,9 @@ NDPI_MINOR="2"
|
||||
NDPI_PATCH="2"
|
||||
NDPI_VERSION_SHORT="$NDPI_MAJOR.$NDPI_MINOR.$NDPI_PATCH"
|
||||
|
||||
-/bin/rm -f configure config.h config.h.in src/lib/Makefile.in
|
||||
-rm -f configure config.h config.h.in src/lib/Makefile.in
|
||||
-
|
||||
-AUTOCONF=$(which autoconf)
|
||||
-AUTOMAKE=$(which automake)
|
||||
-LIBTOOL=$(which libtool)
|
||||
-LIBTOOLIZE=$(which libtoolize)
|
||||
-AUTORECONF=$(which autoreconf)
|
||||
-AUTOCONF=$(command -v autoconf)
|
||||
-AUTOMAKE=$(command -v automake)
|
||||
-LIBTOOL=$(command -v libtool)
|
||||
-LIBTOOLIZE=$(command -v libtoolize)
|
||||
-AUTORECONF=$(command -v autoreconf)
|
||||
-
|
||||
-if test -z $AUTOCONF; then
|
||||
- echo "autoconf is missing: please install it and try again"
|
||||
@ -32,6 +32,16 @@
|
||||
- exit
|
||||
-fi
|
||||
-
|
||||
cat configure.seed | sed "s/@NDPI_MAJOR@/$NDPI_MAJOR/g" | sed "s/@NDPI_MINOR@/$NDPI_MINOR/g" | sed "s/@NDPI_PATCH@/$NDPI_PATCH/g" | sed "s/@NDPI_VERSION_SHORT@/$NDPI_VERSION_SHORT/g" > configure.ac
|
||||
cat configure.seed | sed \
|
||||
-e "s/@NDPI_MAJOR@/$NDPI_MAJOR/g" \
|
||||
-e "s/@NDPI_MINOR@/$NDPI_MINOR/g" \
|
||||
-e "s/@NDPI_PATCH@/$NDPI_PATCH/g" \
|
||||
-e "s/@NDPI_VERSION_SHORT@/$NDPI_VERSION_SHORT/g" \
|
||||
> configure.ac
|
||||
-
|
||||
-autoreconf -ivf
|
||||
-cat configure | sed "s/#define PACKAGE/#define NDPI_PACKAGE/g" | sed "s/#define VERSION/#define NDPI_VERSION/g" > configure.tmp
|
||||
-cat configure.tmp > configure
|
||||
-
|
||||
-chmod +x configure
|
||||
-./configure $*
|
||||
|
@ -1,50 +0,0 @@
|
||||
From 2155dd9153457886c4f5dac58dcf269eeb2a8122 Mon Sep 17 00:00:00 2001
|
||||
From: Hidde van der Heide <hvanderheide@nexuz.net>
|
||||
Date: Thu, 19 Oct 2017 16:10:56 +0200
|
||||
Subject: [PATCH] Add libcache to installed headers and removed relative import
|
||||
|
||||
---
|
||||
example/Makefile.am | 2 +-
|
||||
src/include/ndpi_typedefs.h | 2 +-
|
||||
src/lib/Makefile.am | 3 ++-
|
||||
3 files changed, 4 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/example/Makefile.am b/example/Makefile.am
|
||||
index 7fc29402..6cc6a14c 100644
|
||||
--- example/Makefile.am
|
||||
+++ example/Makefile.am
|
||||
@@ -1,6 +1,6 @@
|
||||
bin_PROGRAMS = ndpiReader
|
||||
|
||||
-AM_CPPFLAGS = -I$(top_srcdir)/src/include @PCAP_INC@
|
||||
+AM_CPPFLAGS = -I$(top_srcdir)/src/include -I$(top_srcdir)/src/lib/third_party/include @PCAP_INC@
|
||||
AM_CFLAGS = @PTHREAD_CFLAGS@ # --coverage
|
||||
|
||||
LDADD = $(top_builddir)/src/lib/libndpi.la @JSON_C_LIB@ @PTHREAD_LIBS@ @PCAP_LIB@ @DL_LIB@ -lm
|
||||
diff --git a/src/include/ndpi_typedefs.h b/src/include/ndpi_typedefs.h
|
||||
index 33043fde..0587503f 100644
|
||||
--- src/include/ndpi_typedefs.h
|
||||
+++ src/include/ndpi_typedefs.h
|
||||
@@ -25,7 +25,7 @@
|
||||
#define __NDPI_TYPEDEFS_H__
|
||||
|
||||
#include "ndpi_define.h"
|
||||
-#include "../lib/third_party/include/libcache.h"
|
||||
+#include "libcache.h"
|
||||
|
||||
#define BT_ANNOUNCE
|
||||
#define SNAP_EXT
|
||||
diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
|
||||
index c2b4e4b1..39823d37 100644
|
||||
--- src/lib/Makefile.am
|
||||
+++ src/lib/Makefile.am
|
||||
@@ -12,7 +12,8 @@ libndpi_la_include_HEADERS = ../include/ndpi_api.h \
|
||||
../include/ndpi_includes.h \
|
||||
../include/ndpi_protocol_ids.h \
|
||||
../include/ndpi_protocols.h \
|
||||
- ../include/ndpi_typedefs.h
|
||||
+ ../include/ndpi_typedefs.h \
|
||||
+ third_party/include/libcache.h
|
||||
|
||||
libndpi_la_SOURCES = ndpi_content_match.c.inc \
|
||||
ndpi_main.c \
|
@ -1,10 +0,0 @@
|
||||
--- libndpi.sym.orig 2017-12-03 18:07:29 UTC
|
||||
+++ libndpi.sym
|
||||
@@ -58,4 +58,5 @@ ndpi_netbios_name_interpret
|
||||
ndpi_category_set_name
|
||||
ndpi_category_get_name
|
||||
ndpi_is_custom_category
|
||||
-ndpi_is_subprotocol_informative
|
||||
\ No newline at end of file
|
||||
+ndpi_is_subprotocol_informative
|
||||
+ndpi_set_proto_category
|
@ -1,6 +1,7 @@
|
||||
bin/ndpiReader
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/libcache.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_api.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_config.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_define.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_includes.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_main.h
|
||||
|
@ -2,7 +2,8 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ntopng
|
||||
PORTVERSION= 3.2.2018.03.13
|
||||
PORTVERSION= 3.4.d20180604
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= net
|
||||
|
||||
MAINTAINER= madpilot@FreeBSD.org
|
||||
@ -24,14 +25,13 @@ USES= autoreconf cpe gmake libtool localbase mysql pathfix pkgconfig \
|
||||
SUB_FILES= ntopng-geoipupdate.sh pkg-deinstall
|
||||
SHEBANG_FILES= httpdocs/misc/ntopng-add-user.sh
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
USERS= ntopng
|
||||
GROUPS= ntopng
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= ntop
|
||||
GH_TAGNAME= a7d7655
|
||||
GH_TAGNAME= 468d1eb
|
||||
|
||||
CPE_VENDOR= ntop
|
||||
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1521103085
|
||||
SHA256 (ntop-ntopng-3.2.2018.03.13-a7d7655_GH0.tar.gz) = 36d9fbd9135a7519d7eef85c6b9780387721c9253b9f29f97b4bcfb78e26a7f7
|
||||
SIZE (ntop-ntopng-3.2.2018.03.13-a7d7655_GH0.tar.gz) = 24195839
|
||||
TIMESTAMP = 1528128970
|
||||
SHA256 (ntop-ntopng-3.4.d20180604-468d1eb_GH0.tar.gz) = b021d7d97c2215997559bc164efca801ea889f00247ea3a16f3decf6bb2587d2
|
||||
SIZE (ntop-ntopng-3.4.d20180604-468d1eb_GH0.tar.gz) = 30715124
|
||||
|
@ -1,9 +1,9 @@
|
||||
--- autogen.sh.orig 2016-05-05 13:23:53 UTC
|
||||
--- autogen.sh.orig 2018-06-04 09:56:33 UTC
|
||||
+++ autogen.sh
|
||||
@@ -30,8 +30,3 @@ fi
|
||||
cat configure.seed | sed "s/@VERSION@/$VERSION/g" | sed "s/@SHORT_VERSION@/$SHORT_VERSION/g" | sed "s/@GIT_TAG@/$GIT_TAG/g" | sed "s/@GIT_DATE@/$GIT_DATE/g" | sed "s/@GIT_RELEASE@/$GIT_RELEASE/g" | sed "s/@GIT_BRANCH@/$GIT_BRANCH/g" | sed "s/@PRO_GIT_RELEASE@/$PRO_GIT_RELEASE/g" | sed "s/@PRO_GIT_DATE@/$PRO_GIT_DATE/g" > configure.ac
|
||||
@@ -38,8 +38,3 @@ cat configure.seed | sed \
|
||||
> configure.ac
|
||||
|
||||
/bin/rm -f config.h config.h.in *~ #*
|
||||
rm -f config.h config.h.in *~ #*
|
||||
-
|
||||
-echo "Wait please..."
|
||||
-autoreconf -if
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- configure.seed.orig 2018-01-12 09:48:20 UTC
|
||||
--- configure.seed.orig 2018-06-04 09:56:33 UTC
|
||||
+++ configure.seed
|
||||
@@ -29,26 +29,8 @@ fi
|
||||
@@ -27,33 +27,8 @@ fi
|
||||
# On CentOS 6 `git rev-list HEAD --count` does not work
|
||||
#
|
||||
#
|
||||
@ -25,38 +25,26 @@
|
||||
- LDFLAGS="${LDFLAGS} -L/opt/local/lib"
|
||||
-fi
|
||||
-
|
||||
if [ test -f /usr/bin/lsb_release ]; then
|
||||
CODENAME=`/usr/bin/lsb_release -c|cut -f 2`
|
||||
if [[ $CODENAME == "wheezy" ]]; then :
|
||||
@@ -64,26 +46,7 @@ GIT_BRANCH="@GIT_BRANCH@"
|
||||
PRO_GIT_RELEASE="@PRO_GIT_RELEASE@"
|
||||
PRO_GIT_DATE="@PRO_GIT_DATE@"
|
||||
|
||||
-AC_MSG_CHECKING(for nDPI)
|
||||
-NDPI_HOME=./nDPI
|
||||
-if test -d "$NDPI_HOME" ; then :
|
||||
- AC_MSG_RESULT(found in $NDPI_HOME)
|
||||
-else
|
||||
- NDPI_HOME=../nDPI
|
||||
- if test -d "$NDPI_HOME"; then :
|
||||
- AC_MSG_RESULT(found in $NDPI_HOME)
|
||||
- else
|
||||
- NDPI_HOME=$HOME/nDPI
|
||||
- if test -d "$NDPI_HOME"; then :
|
||||
- AC_MSG_RESULT(found in $NDPI_HOME)
|
||||
- else
|
||||
- AC_MSG_RESULT(not found)
|
||||
- echo "Please do cd ..; git clone https://github.com/ntop/nDPI.git; cd nDPI; ./autogen.sh; make; cd ../ntopng"
|
||||
- echo " and try again"
|
||||
- exit
|
||||
- fi
|
||||
-if [ test -f /usr/bin/lsb_release ]; then
|
||||
- CODENAME=`/usr/bin/lsb_release -c|cut -f 2`
|
||||
- if [[ $CODENAME == "wheezy" ]]; then :
|
||||
- CPPFLAGS="${CPPFLAGS} -DOLD_NETFILTER_INTERFACE=1"
|
||||
- fi
|
||||
-fi
|
||||
+NDPI_HOME=%%LOCALBASE%%
|
||||
-
|
||||
SHORT_MACHINE=`uname -m | cut -b1-3`
|
||||
|
||||
if test -d "/usr/include/openssl"; then :
|
||||
AC_DEFINE_UNQUOTED(NO_SSL_DL, 1, [has openssl])
|
||||
@@ -438,18 +401,6 @@ GMAKE=`which gmake`
|
||||
GIT_RELEASE="@GIT_RELEASE@"
|
||||
@@ -94,7 +69,7 @@ AC_ARG_WITH(ndpi-includes,
|
||||
PKG_CHECK_MODULES([NDPI], [libndpi >= 2.0], [
|
||||
NDPI_INC=`echo $NDPI_CFLAGS | sed -e "s/[ ]*$//"`/libndpi
|
||||
# Use static libndpi library as building against the dynamic library fails
|
||||
- NDPI_LIB="-Wl,-Bstatic $NDPI_LIBS -Wl,-Bdynamic"
|
||||
+ NDPI_LIB="$NDPI_LIBS"
|
||||
NDPI_LIB_DEP=
|
||||
], [
|
||||
AC_MSG_CHECKING(for nDPI source)
|
||||
@@ -505,18 +480,6 @@ GMAKE=`which gmake`
|
||||
if test x$GMAKE = x
|
||||
then
|
||||
GMAKE="make"
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- src/DivertInterface.cpp.orig 2018-01-18 14:31:32 UTC
|
||||
+++ src/DivertInterface.cpp
|
||||
@@ -101,7 +101,7 @@ DivertInterface::DivertInterface(const char *name) : N
|
||||
sin.sin_family = AF_INET, sin.sin_port = htons(port);
|
||||
sin_len = sizeof(struct sockaddr_in);
|
||||
|
||||
- if(bind(sock, (struct sockaddr *) &sin, sin_len) == -1) {
|
||||
+ if(::bind(sock, (struct sockaddr *) &sin, sin_len) == -1) {
|
||||
ntop->getTrace()->traceEvent(TRACE_ERROR, "Unable to bind divert socket to port %d", port);
|
||||
throw 1;
|
||||
}
|
@ -1,11 +0,0 @@
|
||||
--- src/Utils.cpp.orig 2018-01-12 09:48:20 UTC
|
||||
+++ src/Utils.cpp
|
||||
@@ -2370,7 +2370,7 @@ int Utils::bindSockToDevice(int sock, int family, cons
|
||||
|
||||
if(pAdapterFound != NULL) {
|
||||
int addrsize = (family == AF_INET6) ? sizeof(sockaddr_in6) : sizeof(sockaddr_in);
|
||||
- bindresult = bind(sock, pAdapterFound->ifa_addr, addrsize);
|
||||
+ bindresult = ::bind(sock, pAdapterFound->ifa_addr, addrsize);
|
||||
}
|
||||
|
||||
freeifaddrs(pList);
|
@ -1,29 +0,0 @@
|
||||
--- third-party/mongoose/mongoose.c.orig 2018-01-12 09:48:20 UTC
|
||||
+++ third-party/mongoose/mongoose.c
|
||||
@@ -730,7 +730,7 @@ struct mg_request_info *mg_get_request_info(struct mg_
|
||||
return &conn->request_info;
|
||||
}
|
||||
|
||||
-static void mg_strlcpy(register char *dst, register const char *src, size_t n) {
|
||||
+static void mg_strlcpy(char *dst, const char *src, size_t n) {
|
||||
for (; *src != '\0' && n > 1; n--) {
|
||||
*dst++ = *src++;
|
||||
}
|
||||
@@ -2139,7 +2139,7 @@ static void MD5Init(MD5_CTX *ctx) {
|
||||
}
|
||||
|
||||
static void MD5Transform(uint32_t buf[4], uint32_t const in[16]) {
|
||||
- register uint32_t a, b, c, d;
|
||||
+ uint32_t a, b, c, d;
|
||||
|
||||
a = buf[0];
|
||||
b = buf[1];
|
||||
@@ -4511,7 +4511,7 @@ static int set_ports_option(struct mg_context *ctx) {
|
||||
(void *)
|
||||
#endif
|
||||
&on, sizeof(on))) != 0 ||
|
||||
- (rc_bind = bind(so.sock,
|
||||
+ (rc_bind = ::bind(so.sock,
|
||||
&sa->sa,
|
||||
(sa->sa.sa_family == AF_INET) ? sizeof(sa->sin) : sizeof(sa->sin6))
|
||||
) != 0 ||
|
@ -1,11 +0,0 @@
|
||||
--- third-party/snmp/net.c.orig 2018-01-12 09:48:20 UTC
|
||||
+++ third-party/snmp/net.c
|
||||
@@ -64,7 +64,7 @@ int open_udp_socket(int port)
|
||||
si_me.sin_family = AF_INET;
|
||||
si_me.sin_port = htons(port);
|
||||
si_me.sin_addr.s_addr = htonl(INADDR_ANY);
|
||||
- if (bind(s, (struct sockaddr *) &si_me, sizeof(si_me)) != 0)
|
||||
+ if (::bind(s, (struct sockaddr *) &si_me, sizeof(si_me)) != 0)
|
||||
return(-1); //diep("bind");
|
||||
|
||||
return s;
|
@ -21,6 +21,7 @@ man/man8/ntopng.8.gz
|
||||
%%DATADIR%%/httpdocs/css/bubble-chart.css
|
||||
%%DATADIR%%/httpdocs/css/cal-heatmap.css
|
||||
%%DATADIR%%/httpdocs/css/cubism.css
|
||||
%%DATADIR%%/httpdocs/css/custom_theme.css
|
||||
%%DATADIR%%/httpdocs/css/datepicker.css
|
||||
%%DATADIR%%/httpdocs/css/dc.css
|
||||
%%DATADIR%%/httpdocs/css/flags.css
|
||||
@ -185,9 +186,11 @@ man/man8/ntopng.8.gz
|
||||
%%DATADIR%%/httpdocs/js/ntop.min.js
|
||||
%%DATADIR%%/httpdocs/js/ntop.min.js.map
|
||||
%%DATADIR%%/httpdocs/js/ntopng_utils.js
|
||||
%%DATADIR%%/httpdocs/js/ntopng_validators.js
|
||||
%%DATADIR%%/httpdocs/js/nv.d3.js
|
||||
%%DATADIR%%/httpdocs/js/pdfmake.js
|
||||
%%DATADIR%%/httpdocs/js/pie-chart.js
|
||||
%%DATADIR%%/httpdocs/js/quotas_utils.js
|
||||
%%DATADIR%%/httpdocs/js/rickshaw.js
|
||||
%%DATADIR%%/httpdocs/js/ripe_widget_api.js
|
||||
%%DATADIR%%/httpdocs/js/sankey.js
|
||||
@ -200,6 +203,7 @@ man/man8/ntopng.8.gz
|
||||
%%DATADIR%%/httpdocs/misc/ntopng-add-user.sh
|
||||
%%DATADIR%%/httpdocs/misc/ntopng_template_elk.json
|
||||
%%DATADIR%%/httpdocs/other/EtherOUI.txt
|
||||
%%DATADIR%%/httpdocs/other/TimeZones.txt
|
||||
%%DATADIR%%/httpdocs/other/trackers.txt
|
||||
%%DATADIR%%/httpdocs/ssl/README
|
||||
%%DATADIR%%/httpdocs/ssl/ntopng-cert.pem.dummy
|
||||
@ -218,6 +222,7 @@ man/man8/ntopng.8.gz
|
||||
%%DATADIR%%/scripts/callbacks/system/discover.lua
|
||||
%%DATADIR%%/scripts/callbacks/system/housekeeping.lua
|
||||
%%DATADIR%%/scripts/callbacks/system/minute.lua
|
||||
%%DATADIR%%/scripts/callbacks/system/pinger.lua
|
||||
%%DATADIR%%/scripts/callbacks/system/second.lua
|
||||
%%DATADIR%%/scripts/callbacks/system/shutdown.lua
|
||||
%%DATADIR%%/scripts/callbacks/system/startup.lua
|
||||
@ -225,7 +230,6 @@ man/man8/ntopng.8.gz
|
||||
%%DATADIR%%/scripts/callbacks/user_scripts/loader.lua
|
||||
%%DATADIR%%/scripts/callbacks/user_scripts/periodic/default.lua
|
||||
%%DATADIR%%/scripts/locales/en.lua
|
||||
%%DATADIR%%/scripts/locales/it.lua
|
||||
%%DATADIR%%/scripts/lua/API.lua
|
||||
%%DATADIR%%/scripts/lua/about.lua
|
||||
%%DATADIR%%/scripts/lua/admin/add_user.lua
|
||||
@ -247,6 +251,7 @@ man/man8/ntopng.8.gz
|
||||
%%DATADIR%%/scripts/lua/captive_portal.lua
|
||||
%%DATADIR%%/scripts/lua/change_password.lua
|
||||
%%DATADIR%%/scripts/lua/check_update.lua
|
||||
%%DATADIR%%/scripts/lua/country_details.lua
|
||||
%%DATADIR%%/scripts/lua/country_stats.lua
|
||||
%%DATADIR%%/scripts/lua/discover.lua
|
||||
%%DATADIR%%/scripts/lua/do_export_data.lua
|
||||
@ -257,6 +262,7 @@ man/man8/ntopng.8.gz
|
||||
%%DATADIR%%/scripts/lua/examples/sqlite.lua
|
||||
%%DATADIR%%/scripts/lua/export_data.lua
|
||||
%%DATADIR%%/scripts/lua/find_app.lua
|
||||
%%DATADIR%%/scripts/lua/find_category.lua
|
||||
%%DATADIR%%/scripts/lua/find_host.lua
|
||||
%%DATADIR%%/scripts/lua/find_member.lua
|
||||
%%DATADIR%%/scripts/lua/find_prefs.lua
|
||||
@ -291,6 +297,7 @@ man/man8/ntopng.8.gz
|
||||
%%DATADIR%%/scripts/lua/get_process_info.lua
|
||||
%%DATADIR%%/scripts/lua/get_processes_data.lua
|
||||
%%DATADIR%%/scripts/lua/get_system_hosts_interaction.lua
|
||||
%%DATADIR%%/scripts/lua/get_top_realtime.lua
|
||||
%%DATADIR%%/scripts/lua/get_top_talkers.lua
|
||||
%%DATADIR%%/scripts/lua/get_treemap.lua
|
||||
%%DATADIR%%/scripts/lua/get_unknown_devices_data.lua
|
||||
@ -343,19 +350,27 @@ man/man8/ntopng.8.gz
|
||||
%%DATADIR%%/scripts/lua/login.lua
|
||||
%%DATADIR%%/scripts/lua/logout.lua
|
||||
%%DATADIR%%/scripts/lua/mac_details.lua
|
||||
%%DATADIR%%/scripts/lua/mac_pkt_distro.lua
|
||||
%%DATADIR%%/scripts/lua/mac_stats.lua
|
||||
%%DATADIR%%/scripts/lua/macs_stats.lua
|
||||
%%DATADIR%%/scripts/lua/modules/alert_api.lua
|
||||
%%DATADIR%%/scripts/lua/metrics.lua
|
||||
%%DATADIR%%/scripts/lua/modules/alert_consts.lua
|
||||
%%DATADIR%%/scripts/lua/modules/alert_endpoints/email.lua
|
||||
%%DATADIR%%/scripts/lua/modules/alert_endpoints/nagios.lua
|
||||
%%DATADIR%%/scripts/lua/modules/alert_endpoints/slack.lua
|
||||
%%DATADIR%%/scripts/lua/modules/alert_state_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/alert_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/as_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/base64.lua
|
||||
%%DATADIR%%/scripts/lua/modules/blacklist_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/callback_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/db_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/discover_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/dkjson.lua
|
||||
%%DATADIR%%/scripts/lua/modules/doa_ox.lua
|
||||
%%DATADIR%%/scripts/lua/modules/flow_aggregation_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/flow_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/format_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/grafana/index.lua
|
||||
%%DATADIR%%/scripts/lua/modules/grafana/query.lua
|
||||
%%DATADIR%%/scripts/lua/modules/grafana/search.lua
|
||||
@ -387,17 +402,18 @@ man/man8/ntopng.8.gz
|
||||
%%DATADIR%%/scripts/lua/modules/rrd_5min_dump_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/rrd_min_dump_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/rrd_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/slack_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/sqlite_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/template.lua
|
||||
%%DATADIR%%/scripts/lua/modules/template_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/top_talkers_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/tz_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/vlan_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/voip_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/xmlSimple.lua
|
||||
%%DATADIR%%/scripts/lua/network_details.lua
|
||||
%%DATADIR%%/scripts/lua/network_load.lua
|
||||
%%DATADIR%%/scripts/lua/network_stats.lua
|
||||
%%DATADIR%%/scripts/lua/nindex.lua
|
||||
%%DATADIR%%/scripts/lua/os_stats.lua
|
||||
%%DATADIR%%/scripts/lua/page_not_found.lua
|
||||
%%DATADIR%%/scripts/lua/pid_stats.lua
|
||||
|
Loading…
Reference in New Issue
Block a user