- Convert to USES=python, limit to 2.x

- Drop leading "The" from COMMENT
- Use shebangfix instead of multiple patching
- Trim plist
This commit is contained in:
Jason E. Hale 2014-10-05 00:09:49 +00:00
parent 0ba06712dc
commit 41153673a2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=370028
3 changed files with 8 additions and 15 deletions

View File

@ -8,23 +8,25 @@ CATEGORIES= audio python
MASTER_SITES= BERLIOS
MAINTAINER= ports@FreeBSD.org
COMMENT= The sound conversion application for the GNOME environment
COMMENT= Sound conversion application for the GNOME environment
LICENSE= GPLv3
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gst-0.10/gst/__init__.py:${PORTSDIR}/multimedia/py-gstreamer
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gstreamer>=0.10:${PORTSDIR}/multimedia/py-gstreamer
USES= gettext gmake desktop-file-utils python:2 shebangfix
SHEBANG_FILES= src/soundconverter.py
python_OLD_CMD= /usr/bin/python -tt
USES= gettext gmake desktop-file-utils
GNU_CONFIGURE= yes
USE_PYTHON= yes
USE_GNOME= pygtk2 pygnome2
MAKE_ENV= MAKE=${LOCALBASE}/bin/gmake
MAKE_ENV= MAKE=${MAKE_CMD}
INSTALLS_ICONS= yes
post-patch:
@${REINPLACE_CMD} -e 's|@GMSGFMT@|${LOCALBASE}/bin/msgfmt|; \
s|itlocaledir = .*|itlocaledir = ${LOCALBASE}/share/locale|g' \
${WRKSRC}/po/Makefile.in.in
@${REINPLACE_CMD} -e 's|#!/usr/bin/python|#!/usr/bin/env python|' ${WRKSRC}/src/soundconverter.py
.include <bsd.port.mk>

View File

@ -1,8 +0,0 @@
--- src/soundconverter.py.orig 2009-02-25 16:08:50.000000000 +0800
+++ src/soundconverter.py 2009-02-25 16:10:30.000000000 +0800
@@ -1,4 +1,4 @@
-#!/usr/bin/python -tt
+#!/usr/bin/python
# -*- coding: utf-8 -*-
#
# SoundConverter - GNOME application for converting between audio formats.

View File

@ -46,4 +46,3 @@ share/locale/zh_CN/LC_MESSAGES/soundconverter.mo
share/applications/soundconverter.desktop
share/icons/hicolor/48x48/apps/soundconverter.png
share/icons/hicolor/scalable/apps/soundconverter.svg
@dirrm %%DATADIR%%