Anonymous peer-to-peer instant messenger working through the Tor network.
WWW: https://github.com/ricochet-im/ricochet PR: 200999 Submitted by: Yuri Victorovich <yuri@rawbw.com>
This commit is contained in:
parent
60751abe79
commit
411535c7cf
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=405695
@ -145,6 +145,7 @@
|
||||
SUBDIR += qwit-devel
|
||||
SUBDIR += qxmpp
|
||||
SUBDIR += ramblercontacts
|
||||
SUBDIR += ricochet
|
||||
SUBDIR += rubygem-earthquake
|
||||
SUBDIR += rubygem-hipchat
|
||||
SUBDIR += rubygem-lita
|
||||
|
33
net-im/ricochet/Makefile
Normal file
33
net-im/ricochet/Makefile
Normal file
@ -0,0 +1,33 @@
|
||||
# Created by: Yuri Victorovich <yuri@rawbw.com>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ricochet
|
||||
PORTVERSION= 0.150620
|
||||
CATEGORIES= net-im net-p2p
|
||||
|
||||
MAINTAINER= yuri@rawbw.com
|
||||
COMMENT= Anonymous peer-to-peer instant messenger
|
||||
|
||||
LICENSE= RICOCHET
|
||||
LICENSE_NAME= Ricochet
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
|
||||
|
||||
LIB_DEPENDS= libprotobuf.so:${PORTSDIR}/devel/protobuf
|
||||
RUN_DEPENDS= tor:${PORTSDIR}/security/tor
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= ricochet-im
|
||||
GH_TAGNAME= e31a0fb
|
||||
|
||||
USES= compiler:c++11-lib gmake pkgconfig qmake
|
||||
USE_OPENSSL= yes
|
||||
USE_QT5= core gui network quick quickcontrols widgets multimedia buildtools_build linguisttools_build
|
||||
QMAKE_ARGS+= DEFINES+=RICOCHET_NO_PORTABLE OPENSSLDIR=${LOCALBASE}
|
||||
|
||||
PLIST_FILES= bin/ricochet \
|
||||
share/applications/ricochet.desktop \
|
||||
share/icons/hicolor/48x48/apps/ricochet.png \
|
||||
share/icons/hicolor/scalable/apps/ricochet.svg
|
||||
|
||||
.include <bsd.port.mk>
|
2
net-im/ricochet/distinfo
Normal file
2
net-im/ricochet/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
SHA256 (ricochet-im-ricochet-0.150620-e31a0fb_GH0.tar.gz) = 41d2f1265094b00085250c934ae065b87893baa79ec348b7d1c729e424a9fccc
|
||||
SIZE (ricochet-im-ricochet-0.150620-e31a0fb_GH0.tar.gz) = 1197163
|
26
net-im/ricochet/files/patch-ricochet.pro
Normal file
26
net-im/ricochet/files/patch-ricochet.pro
Normal file
@ -0,0 +1,26 @@
|
||||
--- ricochet.pro.orig 2015-06-17 04:00:47 UTC
|
||||
+++ ricochet.pro
|
||||
@@ -46,18 +46,18 @@ CONFIG(release,debug|release):DEFINES +=
|
||||
|
||||
contains(DEFINES, RICOCHET_NO_PORTABLE) {
|
||||
unix:!macx {
|
||||
- target.path = /usr/bin
|
||||
- shortcut.path = /usr/share/applications
|
||||
+ target.path = $$PREFIX/bin
|
||||
+ shortcut.path = $$PREFIX/share/applications
|
||||
shortcut.files = src/ricochet.desktop
|
||||
- icon.path = /usr/share/icons/hicolor/48x48/apps/
|
||||
+ icon.path = $$PREFIX/share/icons/hicolor/48x48/apps/
|
||||
icon.files = icons/ricochet.png
|
||||
- scalable_icon.path = /usr/share/icons/hicolor/scalable/apps/
|
||||
+ scalable_icon.path = $$PREFIX/share/icons/hicolor/scalable/apps/
|
||||
scalable_icon.files = icons/ricochet.svg
|
||||
INSTALLS += target shortcut icon scalable_icon
|
||||
|
||||
exists(tor) {
|
||||
message(Adding bundled Tor to installations)
|
||||
- bundletor.path = /usr/lib/ricochet/tor/
|
||||
+ bundletor.path = $$PREFIX/lib/ricochet/tor/
|
||||
bundletor.files = tor/*
|
||||
INSTALLS += bundletor
|
||||
DEFINES += BUNDLED_TOR_PATH=\\\"/usr/lib/ricochet/tor/\\\"
|
3
net-im/ricochet/pkg-descr
Normal file
3
net-im/ricochet/pkg-descr
Normal file
@ -0,0 +1,3 @@
|
||||
Anonymous peer-to-peer instant messenger working through the Tor network.
|
||||
|
||||
WWW: https://github.com/ricochet-im/ricochet
|
Loading…
Reference in New Issue
Block a user