www/plasma5-plasma-browser-integration: fix chrome integration

The extension-file got installed into the wrong directory:
   etc/opt/chrome/
instead of
   etc/chrome/
and therefore was not found by chrome. Correct this.

PR:		241379
Reported by:	Patricio Villar <patovm04@gmail.com>
This commit is contained in:
Tobias C. Berner 2019-11-28 17:40:12 +00:00
parent 9b1632739d
commit 40d9fea810
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=518595
3 changed files with 13 additions and 1 deletions

View File

@ -2,6 +2,7 @@
PORTNAME= plasma-browser-integration
DISTVERSION= ${KDE_PLASMA_VERSION}
PORTREVISION= 1
CATEGORIES= www kde kde-plasma
MAINTAINER= kde@FreeBSD.org

View File

@ -0,0 +1,11 @@
--- CMakeLists.txt.orig 2019-11-28 17:30:00 UTC
+++ CMakeLists.txt
@@ -71,7 +71,7 @@ configure_file(org.kde.plasma.firefox_integration.json
# #chromium
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/org.kde.plasma.chrome_integration.json DESTINATION ${KDE_INSTALL_FULL_SYSCONFDIR}/chromium/native-messaging-hosts/ RENAME org.kde.plasma.browser_integration.json)
# #google-chrome
-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/org.kde.plasma.chrome_integration.json DESTINATION ${KDE_INSTALL_FULL_SYSCONFDIR}/opt/chrome/native-messaging-hosts/ RENAME org.kde.plasma.browser_integration.json)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/org.kde.plasma.chrome_integration.json DESTINATION ${KDE_INSTALL_FULL_SYSCONFDIR}/chrome/native-messaging-hosts/ RENAME org.kde.plasma.browser_integration.json)
# firefox
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/org.kde.plasma.firefox_integration.json DESTINATION ${MOZILLA_DIR}/native-messaging-hosts/ RENAME org.kde.plasma.browser_integration.json)

View File

@ -1,6 +1,6 @@
bin/plasma-browser-integration-host
etc/chrome/native-messaging-hosts/org.kde.plasma.browser_integration.json
etc/chromium/native-messaging-hosts/org.kde.plasma.browser_integration.json
etc/opt/chrome/native-messaging-hosts/org.kde.plasma.browser_integration.json
lib/mozilla/native-messaging-hosts/org.kde.plasma.browser_integration.json
%%QT_PLUGINDIR%%/kf5/kded/browserintegrationreminder.so
%%QT_PLUGINDIR%%/krunner_browsertabs.so