Add py-imageio24 2.4.1 (copied from py-imageio)

- Add PORTSCOUT
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2019-02-16 22:52:45 +00:00
parent c66014e46e
commit 4082614386
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=493107
5 changed files with 51 additions and 0 deletions

View File

@ -845,6 +845,7 @@
SUBDIR += py-gvgen
SUBDIR += py-imageio
SUBDIR += py-imageio-ffmpeg
SUBDIR += py-imageio24
SUBDIR += py-imagesize
SUBDIR += py-imgurpython
SUBDIR += py-leather

View File

@ -0,0 +1,31 @@
# $FreeBSD$
PORTNAME= imageio
DISTVERSION= 2.4.1
PORTREVISION= 2
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
PKGNAMESUFFIX= 24
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Python library for reading and writing image, video formats
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libfreeimage.so:graphics/freeimage
RUN_DEPENDS= ffmpeg:multimedia/ffmpeg \
${PY_ENUM34} \
${PY_FUTURES} \
${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
USES= python
USE_PYTHON= distutils concurrent autoplist
NO_ARCH= yes
PORTSCOUT= limit:^2\.4\.
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1536517550
SHA256 (imageio-2.4.1.tar.gz) = 16b8077bc8a5fa7a58b3e744f7ecbb156d8c088132df31e0f4f546c98de3514a
SIZE (imageio-2.4.1.tar.gz) = 3338313

View File

@ -0,0 +1,11 @@
--- imageio/core/util.py.orig 2018-09-04 12:21:12 UTC
+++ imageio/core/util.py
@@ -547,6 +547,8 @@ def get_platform():
plat = "win%i"
elif sys.platform.startswith("darwin"):
plat = "osx%i"
+ elif sys.platform.startswith("freebsd"):
+ plat = "freebsd%i"
else: # pragma: no cover
return None

View File

@ -0,0 +1,5 @@
Imageio is a Python library that provides an easy interface to read and
write a wide range of image data, including animated images, volumetric data,
and scientific formats.
WWW: https://imageio.github.io/