Import gnomegames, It's gnome game app.

PR:		ports/7656
Reviewed by:	vanilla
Submitted by:	Yukihiro Nakai <Nakai@technogilist.com>
This commit is contained in:
Vanilla I. Shu 1998-10-02 00:58:05 +00:00
parent 6124735b29
commit 407792171b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=13591
21 changed files with 804 additions and 0 deletions

View File

@ -0,0 +1,32 @@
# New ports collection makefile for: gnomegames
# Version required: 0.30
# Date created: 03 July 1998
# Whom: Yukihiro Nakai <Nakai@technologist.com>
#
# $Id$
#
DISTNAME= gnome-games-0.30
PKGNAME= gnomegames-0.30
CATEGORIES= games
MASTER_SITES= ftp://ftp.jimpick.com/pub/mirrors/gnome/sources/ \
ftp://ftp.gnome.org/pub/GNOME/sources/
MAINTAINER= Nakai@technologist.com
LIB_DEPENDS= gnome.0:${PORTSDIR}/x11/gnomecore
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
--datadir=${PREFIX}/share/gnome \
--with-gnome=${X11BASE}
CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include \
-I${X11BASE}/include" \
GTK_CONFIG="${X11BASE}/bin/gtk11-config" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
post-install:
@${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (gnome-games-0.30.tar.gz) = aadc04f2e54e00538eedad8f0be69d69

View File

@ -0,0 +1,123 @@
--- aisleriot/Makefile.in.orig Sun Sep 6 00:33:23 1998
+++ aisleriot/Makefile.in Sun Sep 6 00:33:57 1998
@@ -116,7 +116,7 @@
typesdir = $(datadir)/sol-games
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR)
--- freecell/src/Makefile.in.orig Sun Sep 6 00:34:28 1998
+++ freecell/src/Makefile.in Sun Sep 6 00:34:40 1998
@@ -115,7 +115,7 @@
Gamesdir = $(datadir)/apps/Games
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR) \
-I$(srcdir)/../gdk-card-image
--- gnobots/Makefile.in.orig Sun Sep 6 00:35:02 1998
+++ gnobots/Makefile.in Sun Sep 6 00:45:40 1998
@@ -116,10 +116,10 @@
pixmapdir=$(datadir)/pixmaps/gnobots
appicondir=$(datadir)/pixmaps
Gamesdir = $(datadir)/apps/Games
-helpdir = $(datadir)/gnome/help/gnobots/C
+helpdir = $(datadir)/help/gnobots/C
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR)
--- gnome-stones/Makefile.in.orig Fri Oct 2 07:01:39 1998
+++ gnome-stones/Makefile.in Fri Oct 2 07:01:59 1998
@@ -122,7 +122,7 @@
Cavesdir = $(datadir)/gnome-stones
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-DGNOMEPIXMAPDIR=\""$(datadir)/pixmaps"\" \
-DCAVESDIR=\""$(Cavesdir)"\" \
-I$(includedir) \
--- gnomine/Makefile.in.orig Sun Sep 6 00:35:31 1998
+++ gnomine/Makefile.in Sun Sep 6 00:35:41 1998
@@ -116,7 +116,7 @@
Gamesdir = $(datadir)/apps/Games
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR)
--- gnothello/Makefile.in.orig Sun Sep 6 00:35:54 1998
+++ gnothello/Makefile.in Sun Sep 6 00:46:34 1998
@@ -116,7 +116,7 @@
Gamesdir = $(datadir)/apps/Games
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR)
--- gturing/Makefile.in.orig Sun Sep 6 00:36:17 1998
+++ gturing/Makefile.in Sun Sep 6 00:36:31 1998
@@ -115,7 +115,7 @@
Gamesdir = $(datadir)/apps/Games
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR)
--- gyahtzee/Makefile.in.orig Sun Sep 6 00:36:39 1998
+++ gyahtzee/Makefile.in Sun Sep 6 00:42:46 1998
@@ -118,7 +118,7 @@
SUBDIRS = pix
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-DGNOMEPIXMAPDIR=\""$(datadir)/pixmaps"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR) \
@@ -126,7 +126,7 @@
@HAS_CURSES_TRUE@CYAHTZEE=cyahtzee
-bin_PROGRAMS = gyahtzee $(CYAHTZEE)
+bin_PROGRAMS = gyahtzee
gyahtzee_SOURCES = \
gyahtzee.c \
--- mahjongg/Makefile.in.orig Sun Sep 6 00:37:08 1998
+++ mahjongg/Makefile.in Sun Sep 6 00:37:20 1998
@@ -117,7 +117,7 @@
Gamesdir = $(datadir)/apps/Games
INCLUDES = -I.. -I$(srcdir)/.. \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR)
--- same-gnome/Makefile.in.orig Sun Sep 6 00:37:32 1998
+++ same-gnome/Makefile.in Sun Sep 6 00:47:03 1998
@@ -117,7 +117,7 @@
Gamesdir = $(datadir)/apps/Games
INCLUDES = -I.. -I$(srcdir)/.. \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR)

View File

@ -0,0 +1,11 @@
--- freecell/gdk-card-image/Makefile.in.orig Sun Sep 6 00:43:03 1998
+++ freecell/gdk-card-image/Makefile.in Sun Sep 6 00:43:17 1998
@@ -128,7 +128,7 @@
libgdkcardimage_la_SOURCES = gdk-card-image.c
libgdkcardimageincludedir = $(includedir)/gdkcardimage
libgdkcardimageinclude_HEADERS = gdk-card-image.h
-libgdkcardimage_la_LDFLAGS = -version-info 0:0:0 -rpath $(libdir) $(X_LIBS)
+libgdkcardimage_la_LDFLAGS = -version-info 0:30:0 -rpath $(libdir) $(X_LIBS)
libgdkcardimage_la_LIBADD = $(GTK_LIBS)
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = ../../config.h

View File

@ -0,0 +1 @@
the game applications package for the Gnome Desktop Environment

View File

@ -0,0 +1 @@
the game applications package for the Gnome Desktop Environment

View File

@ -0,0 +1,99 @@
bin/freecell
bin/gnobots
bin/gnome-stones
bin/gnomine
bin/gnothello
bin/gturing
bin/gyahtzee
bin/mahjongg
bin/same-gnome
include/gdkcardimage/gdk-card-image.h
lib/libgdkcardimage.a
lib/libgdkcardimage.la
lib/libgdkcardimage.so
lib/libgdkcardimage.so.0.30
share/gnome/apps/Games/freecell.desktop
share/gnome/apps/Games/gnobots.desktop
share/gnome/apps/Games/gnome-stones.desktop
share/gnome/apps/Games/gnomine.desktop
share/gnome/apps/Games/gnothello.desktop
share/gnome/apps/Games/gyahtzee.desktop
share/gnome/apps/Games/mahjongg.desktop
share/gnome/apps/Games/same-gnome.desktop
share/gnome/games/gnobots.safe.scores
share/gnome/games/gnobots.unsafe.scores
share/gnome/games/gnome-stones.scores
share/gnome/games/gnomine.Biiiig.scores
share/gnome/games/gnomine.Custom.scores
share/gnome/games/gnomine.Medium.scores
share/gnome/games/gnomine.Tiny.scores
share/gnome/games/gyahtzee.scores
share/gnome/games/mahjongg.scores
share/gnome/games/same-gnome.scores
share/gnome/gnome-stones/default.caves
share/gnome/gnome-stones/tutorial.caves
share/gnome/help/gnobots/C/index.html
share/gnome/help/gnobots/C/topic.dat
share/gnome/pixmaps/cards/Background.xpm
share/gnome/pixmaps/cards/Cardback1.xpm
share/gnome/pixmaps/cards/Cardback2.xpm
share/gnome/pixmaps/cards/Cardback3.xpm
share/gnome/pixmaps/cards/Cardback4.xpm
share/gnome/pixmaps/cards/Cardback5.xpm
share/gnome/pixmaps/cards/Pictures.xpm
share/gnome/pixmaps/cards/Ranks.xpm
share/gnome/pixmaps/cards/Suits.xpm
share/gnome/pixmaps/gnobots/aieee.png
share/gnome/pixmaps/gnobots/cows.png
share/gnome/pixmaps/gnobots/eggs.png
share/gnome/pixmaps/gnobots/gnomes.png
share/gnome/pixmaps/gnobots/mice.png
share/gnome/pixmaps/gnobots/robots.png
share/gnome/pixmaps/gnobots/windows.png
share/gnome/pixmaps/gnobots/yahoo.png
share/gnome/pixmaps/gnome-stones/amoeba.png
share/gnome/pixmaps/gnome-stones/boulder.png
share/gnome/pixmaps/gnome-stones/butterfly.png
share/gnome/pixmaps/gnome-stones/curtain.png
share/gnome/pixmaps/gnome-stones/diamond.png
share/gnome/pixmaps/gnome-stones/dirt.png
share/gnome/pixmaps/gnome-stones/door.png
share/gnome/pixmaps/gnome-stones/empty.png
share/gnome/pixmaps/gnome-stones/explosion.png
share/gnome/pixmaps/gnome-stones/firefly.png
share/gnome/pixmaps/gnome-stones/frame.png
share/gnome/pixmaps/gnome-stones/gnome.png
share/gnome/pixmaps/gnome-stones/title.png
share/gnome/pixmaps/gnome-stones/wall.png
share/gnome/pixmaps/gnothello/tiles.png
share/gnome/pixmaps/mahjongg/default.png
share/gnome/pixmaps/mahjongg/seta.png
share/gnome/pixmaps/same-gnome/blink-sync.png
share/gnome/pixmaps/same-gnome/marbles.png
share/gnome/pixmaps/same-gnome/planets.png
share/gnome/pixmaps/same-gnome/rotate.png
share/gnome/pixmaps/same-gnome/stones.png
share/gnome/pixmaps/gnome-gnobots.png
share/gnome/pixmaps/gnome-gyahtzee.png
share/gnome/pixmaps/gnome-stones.png
share/locale/cs/LC_MESSAGES/gnome-games.mo
share/locale/da/LC_MESSAGES/gnome-games.mo
share/locale/de/LC_MESSAGES/gnome-games.mo
share/locale/es/LC_MESSAGES/gnome-games.mo
share/locale/fr/LC_MESSAGES/gnome-games.mo
share/locale/ga/LC_MESSAGES/gnome-games.mo
share/locale/it/LC_MESSAGES/gnome-games.mo
share/locale/ja/LC_MESSAGES/gnome-games.mo
share/locale/ko/LC_MESSAGES/gnome-games.mo
share/locale/no/LC_MESSAGES/gnome-games.mo
share/locale/pt/LC_MESSAGES/gnome-games.mo
@dirrm include/gdkcardimage
@dirrm share/gnome/help/gnobots/C
@dirrm share/gnome/help/gnobots
@dirrm share/gnome/pixmaps/cards
@dirrm share/gnome/pixmaps/gnobots
@dirrm share/gnome/pixmaps/gnome-stones
@dirrm share/gnome/pixmaps/gnothello
@dirrm share/gnome/pixmaps/mahjongg
@dirrm share/gnome/pixmaps/same-gnome
@dirrm share/gnome/gnome-stones

32
games/gnomegames/Makefile Normal file
View File

@ -0,0 +1,32 @@
# New ports collection makefile for: gnomegames
# Version required: 0.30
# Date created: 03 July 1998
# Whom: Yukihiro Nakai <Nakai@technologist.com>
#
# $Id$
#
DISTNAME= gnome-games-0.30
PKGNAME= gnomegames-0.30
CATEGORIES= games
MASTER_SITES= ftp://ftp.jimpick.com/pub/mirrors/gnome/sources/ \
ftp://ftp.gnome.org/pub/GNOME/sources/
MAINTAINER= Nakai@technologist.com
LIB_DEPENDS= gnome.0:${PORTSDIR}/x11/gnomecore
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
--datadir=${PREFIX}/share/gnome \
--with-gnome=${X11BASE}
CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include \
-I${X11BASE}/include" \
GTK_CONFIG="${X11BASE}/bin/gtk11-config" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
post-install:
@${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (gnome-games-0.30.tar.gz) = aadc04f2e54e00538eedad8f0be69d69

View File

@ -0,0 +1,123 @@
--- aisleriot/Makefile.in.orig Sun Sep 6 00:33:23 1998
+++ aisleriot/Makefile.in Sun Sep 6 00:33:57 1998
@@ -116,7 +116,7 @@
typesdir = $(datadir)/sol-games
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR)
--- freecell/src/Makefile.in.orig Sun Sep 6 00:34:28 1998
+++ freecell/src/Makefile.in Sun Sep 6 00:34:40 1998
@@ -115,7 +115,7 @@
Gamesdir = $(datadir)/apps/Games
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR) \
-I$(srcdir)/../gdk-card-image
--- gnobots/Makefile.in.orig Sun Sep 6 00:35:02 1998
+++ gnobots/Makefile.in Sun Sep 6 00:45:40 1998
@@ -116,10 +116,10 @@
pixmapdir=$(datadir)/pixmaps/gnobots
appicondir=$(datadir)/pixmaps
Gamesdir = $(datadir)/apps/Games
-helpdir = $(datadir)/gnome/help/gnobots/C
+helpdir = $(datadir)/help/gnobots/C
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR)
--- gnome-stones/Makefile.in.orig Fri Oct 2 07:01:39 1998
+++ gnome-stones/Makefile.in Fri Oct 2 07:01:59 1998
@@ -122,7 +122,7 @@
Cavesdir = $(datadir)/gnome-stones
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-DGNOMEPIXMAPDIR=\""$(datadir)/pixmaps"\" \
-DCAVESDIR=\""$(Cavesdir)"\" \
-I$(includedir) \
--- gnomine/Makefile.in.orig Sun Sep 6 00:35:31 1998
+++ gnomine/Makefile.in Sun Sep 6 00:35:41 1998
@@ -116,7 +116,7 @@
Gamesdir = $(datadir)/apps/Games
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR)
--- gnothello/Makefile.in.orig Sun Sep 6 00:35:54 1998
+++ gnothello/Makefile.in Sun Sep 6 00:46:34 1998
@@ -116,7 +116,7 @@
Gamesdir = $(datadir)/apps/Games
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR)
--- gturing/Makefile.in.orig Sun Sep 6 00:36:17 1998
+++ gturing/Makefile.in Sun Sep 6 00:36:31 1998
@@ -115,7 +115,7 @@
Gamesdir = $(datadir)/apps/Games
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR)
--- gyahtzee/Makefile.in.orig Sun Sep 6 00:36:39 1998
+++ gyahtzee/Makefile.in Sun Sep 6 00:42:46 1998
@@ -118,7 +118,7 @@
SUBDIRS = pix
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-DGNOMEPIXMAPDIR=\""$(datadir)/pixmaps"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR) \
@@ -126,7 +126,7 @@
@HAS_CURSES_TRUE@CYAHTZEE=cyahtzee
-bin_PROGRAMS = gyahtzee $(CYAHTZEE)
+bin_PROGRAMS = gyahtzee
gyahtzee_SOURCES = \
gyahtzee.c \
--- mahjongg/Makefile.in.orig Sun Sep 6 00:37:08 1998
+++ mahjongg/Makefile.in Sun Sep 6 00:37:20 1998
@@ -117,7 +117,7 @@
Gamesdir = $(datadir)/apps/Games
INCLUDES = -I.. -I$(srcdir)/.. \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR)
--- same-gnome/Makefile.in.orig Sun Sep 6 00:37:32 1998
+++ same-gnome/Makefile.in Sun Sep 6 00:47:03 1998
@@ -117,7 +117,7 @@
Gamesdir = $(datadir)/apps/Games
INCLUDES = -I.. -I$(srcdir)/.. \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR)

View File

@ -0,0 +1,11 @@
--- freecell/gdk-card-image/Makefile.in.orig Sun Sep 6 00:43:03 1998
+++ freecell/gdk-card-image/Makefile.in Sun Sep 6 00:43:17 1998
@@ -128,7 +128,7 @@
libgdkcardimage_la_SOURCES = gdk-card-image.c
libgdkcardimageincludedir = $(includedir)/gdkcardimage
libgdkcardimageinclude_HEADERS = gdk-card-image.h
-libgdkcardimage_la_LDFLAGS = -version-info 0:0:0 -rpath $(libdir) $(X_LIBS)
+libgdkcardimage_la_LDFLAGS = -version-info 0:30:0 -rpath $(libdir) $(X_LIBS)
libgdkcardimage_la_LIBADD = $(GTK_LIBS)
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = ../../config.h

View File

@ -0,0 +1 @@
the game applications package for the Gnome Desktop Environment

View File

@ -0,0 +1 @@
the game applications package for the Gnome Desktop Environment

View File

@ -0,0 +1,99 @@
bin/freecell
bin/gnobots
bin/gnome-stones
bin/gnomine
bin/gnothello
bin/gturing
bin/gyahtzee
bin/mahjongg
bin/same-gnome
include/gdkcardimage/gdk-card-image.h
lib/libgdkcardimage.a
lib/libgdkcardimage.la
lib/libgdkcardimage.so
lib/libgdkcardimage.so.0.30
share/gnome/apps/Games/freecell.desktop
share/gnome/apps/Games/gnobots.desktop
share/gnome/apps/Games/gnome-stones.desktop
share/gnome/apps/Games/gnomine.desktop
share/gnome/apps/Games/gnothello.desktop
share/gnome/apps/Games/gyahtzee.desktop
share/gnome/apps/Games/mahjongg.desktop
share/gnome/apps/Games/same-gnome.desktop
share/gnome/games/gnobots.safe.scores
share/gnome/games/gnobots.unsafe.scores
share/gnome/games/gnome-stones.scores
share/gnome/games/gnomine.Biiiig.scores
share/gnome/games/gnomine.Custom.scores
share/gnome/games/gnomine.Medium.scores
share/gnome/games/gnomine.Tiny.scores
share/gnome/games/gyahtzee.scores
share/gnome/games/mahjongg.scores
share/gnome/games/same-gnome.scores
share/gnome/gnome-stones/default.caves
share/gnome/gnome-stones/tutorial.caves
share/gnome/help/gnobots/C/index.html
share/gnome/help/gnobots/C/topic.dat
share/gnome/pixmaps/cards/Background.xpm
share/gnome/pixmaps/cards/Cardback1.xpm
share/gnome/pixmaps/cards/Cardback2.xpm
share/gnome/pixmaps/cards/Cardback3.xpm
share/gnome/pixmaps/cards/Cardback4.xpm
share/gnome/pixmaps/cards/Cardback5.xpm
share/gnome/pixmaps/cards/Pictures.xpm
share/gnome/pixmaps/cards/Ranks.xpm
share/gnome/pixmaps/cards/Suits.xpm
share/gnome/pixmaps/gnobots/aieee.png
share/gnome/pixmaps/gnobots/cows.png
share/gnome/pixmaps/gnobots/eggs.png
share/gnome/pixmaps/gnobots/gnomes.png
share/gnome/pixmaps/gnobots/mice.png
share/gnome/pixmaps/gnobots/robots.png
share/gnome/pixmaps/gnobots/windows.png
share/gnome/pixmaps/gnobots/yahoo.png
share/gnome/pixmaps/gnome-stones/amoeba.png
share/gnome/pixmaps/gnome-stones/boulder.png
share/gnome/pixmaps/gnome-stones/butterfly.png
share/gnome/pixmaps/gnome-stones/curtain.png
share/gnome/pixmaps/gnome-stones/diamond.png
share/gnome/pixmaps/gnome-stones/dirt.png
share/gnome/pixmaps/gnome-stones/door.png
share/gnome/pixmaps/gnome-stones/empty.png
share/gnome/pixmaps/gnome-stones/explosion.png
share/gnome/pixmaps/gnome-stones/firefly.png
share/gnome/pixmaps/gnome-stones/frame.png
share/gnome/pixmaps/gnome-stones/gnome.png
share/gnome/pixmaps/gnome-stones/title.png
share/gnome/pixmaps/gnome-stones/wall.png
share/gnome/pixmaps/gnothello/tiles.png
share/gnome/pixmaps/mahjongg/default.png
share/gnome/pixmaps/mahjongg/seta.png
share/gnome/pixmaps/same-gnome/blink-sync.png
share/gnome/pixmaps/same-gnome/marbles.png
share/gnome/pixmaps/same-gnome/planets.png
share/gnome/pixmaps/same-gnome/rotate.png
share/gnome/pixmaps/same-gnome/stones.png
share/gnome/pixmaps/gnome-gnobots.png
share/gnome/pixmaps/gnome-gyahtzee.png
share/gnome/pixmaps/gnome-stones.png
share/locale/cs/LC_MESSAGES/gnome-games.mo
share/locale/da/LC_MESSAGES/gnome-games.mo
share/locale/de/LC_MESSAGES/gnome-games.mo
share/locale/es/LC_MESSAGES/gnome-games.mo
share/locale/fr/LC_MESSAGES/gnome-games.mo
share/locale/ga/LC_MESSAGES/gnome-games.mo
share/locale/it/LC_MESSAGES/gnome-games.mo
share/locale/ja/LC_MESSAGES/gnome-games.mo
share/locale/ko/LC_MESSAGES/gnome-games.mo
share/locale/no/LC_MESSAGES/gnome-games.mo
share/locale/pt/LC_MESSAGES/gnome-games.mo
@dirrm include/gdkcardimage
@dirrm share/gnome/help/gnobots/C
@dirrm share/gnome/help/gnobots
@dirrm share/gnome/pixmaps/cards
@dirrm share/gnome/pixmaps/gnobots
@dirrm share/gnome/pixmaps/gnome-stones
@dirrm share/gnome/pixmaps/gnothello
@dirrm share/gnome/pixmaps/mahjongg
@dirrm share/gnome/pixmaps/same-gnome
@dirrm share/gnome/gnome-stones

View File

@ -0,0 +1,32 @@
# New ports collection makefile for: gnomegames
# Version required: 0.30
# Date created: 03 July 1998
# Whom: Yukihiro Nakai <Nakai@technologist.com>
#
# $Id$
#
DISTNAME= gnome-games-0.30
PKGNAME= gnomegames-0.30
CATEGORIES= games
MASTER_SITES= ftp://ftp.jimpick.com/pub/mirrors/gnome/sources/ \
ftp://ftp.gnome.org/pub/GNOME/sources/
MAINTAINER= Nakai@technologist.com
LIB_DEPENDS= gnome.0:${PORTSDIR}/x11/gnomecore
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
--datadir=${PREFIX}/share/gnome \
--with-gnome=${X11BASE}
CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include \
-I${X11BASE}/include" \
GTK_CONFIG="${X11BASE}/bin/gtk11-config" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
post-install:
@${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (gnome-games-0.30.tar.gz) = aadc04f2e54e00538eedad8f0be69d69

View File

@ -0,0 +1,123 @@
--- aisleriot/Makefile.in.orig Sun Sep 6 00:33:23 1998
+++ aisleriot/Makefile.in Sun Sep 6 00:33:57 1998
@@ -116,7 +116,7 @@
typesdir = $(datadir)/sol-games
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR)
--- freecell/src/Makefile.in.orig Sun Sep 6 00:34:28 1998
+++ freecell/src/Makefile.in Sun Sep 6 00:34:40 1998
@@ -115,7 +115,7 @@
Gamesdir = $(datadir)/apps/Games
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR) \
-I$(srcdir)/../gdk-card-image
--- gnobots/Makefile.in.orig Sun Sep 6 00:35:02 1998
+++ gnobots/Makefile.in Sun Sep 6 00:45:40 1998
@@ -116,10 +116,10 @@
pixmapdir=$(datadir)/pixmaps/gnobots
appicondir=$(datadir)/pixmaps
Gamesdir = $(datadir)/apps/Games
-helpdir = $(datadir)/gnome/help/gnobots/C
+helpdir = $(datadir)/help/gnobots/C
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR)
--- gnome-stones/Makefile.in.orig Fri Oct 2 07:01:39 1998
+++ gnome-stones/Makefile.in Fri Oct 2 07:01:59 1998
@@ -122,7 +122,7 @@
Cavesdir = $(datadir)/gnome-stones
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-DGNOMEPIXMAPDIR=\""$(datadir)/pixmaps"\" \
-DCAVESDIR=\""$(Cavesdir)"\" \
-I$(includedir) \
--- gnomine/Makefile.in.orig Sun Sep 6 00:35:31 1998
+++ gnomine/Makefile.in Sun Sep 6 00:35:41 1998
@@ -116,7 +116,7 @@
Gamesdir = $(datadir)/apps/Games
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR)
--- gnothello/Makefile.in.orig Sun Sep 6 00:35:54 1998
+++ gnothello/Makefile.in Sun Sep 6 00:46:34 1998
@@ -116,7 +116,7 @@
Gamesdir = $(datadir)/apps/Games
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR)
--- gturing/Makefile.in.orig Sun Sep 6 00:36:17 1998
+++ gturing/Makefile.in Sun Sep 6 00:36:31 1998
@@ -115,7 +115,7 @@
Gamesdir = $(datadir)/apps/Games
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR)
--- gyahtzee/Makefile.in.orig Sun Sep 6 00:36:39 1998
+++ gyahtzee/Makefile.in Sun Sep 6 00:42:46 1998
@@ -118,7 +118,7 @@
SUBDIRS = pix
INCLUDES = \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-DGNOMEPIXMAPDIR=\""$(datadir)/pixmaps"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR) \
@@ -126,7 +126,7 @@
@HAS_CURSES_TRUE@CYAHTZEE=cyahtzee
-bin_PROGRAMS = gyahtzee $(CYAHTZEE)
+bin_PROGRAMS = gyahtzee
gyahtzee_SOURCES = \
gyahtzee.c \
--- mahjongg/Makefile.in.orig Sun Sep 6 00:37:08 1998
+++ mahjongg/Makefile.in Sun Sep 6 00:37:20 1998
@@ -117,7 +117,7 @@
Gamesdir = $(datadir)/apps/Games
INCLUDES = -I.. -I$(srcdir)/.. \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR)
--- same-gnome/Makefile.in.orig Sun Sep 6 00:37:32 1998
+++ same-gnome/Makefile.in Sun Sep 6 00:47:03 1998
@@ -117,7 +117,7 @@
Gamesdir = $(datadir)/apps/Games
INCLUDES = -I.. -I$(srcdir)/.. \
- -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" \
-I$(includedir) \
$(GNOME_INCLUDEDIR)

View File

@ -0,0 +1,11 @@
--- freecell/gdk-card-image/Makefile.in.orig Sun Sep 6 00:43:03 1998
+++ freecell/gdk-card-image/Makefile.in Sun Sep 6 00:43:17 1998
@@ -128,7 +128,7 @@
libgdkcardimage_la_SOURCES = gdk-card-image.c
libgdkcardimageincludedir = $(includedir)/gdkcardimage
libgdkcardimageinclude_HEADERS = gdk-card-image.h
-libgdkcardimage_la_LDFLAGS = -version-info 0:0:0 -rpath $(libdir) $(X_LIBS)
+libgdkcardimage_la_LDFLAGS = -version-info 0:30:0 -rpath $(libdir) $(X_LIBS)
libgdkcardimage_la_LIBADD = $(GTK_LIBS)
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = ../../config.h

View File

@ -0,0 +1 @@
the game applications package for the Gnome Desktop Environment

View File

@ -0,0 +1 @@
the game applications package for the Gnome Desktop Environment

View File

@ -0,0 +1,99 @@
bin/freecell
bin/gnobots
bin/gnome-stones
bin/gnomine
bin/gnothello
bin/gturing
bin/gyahtzee
bin/mahjongg
bin/same-gnome
include/gdkcardimage/gdk-card-image.h
lib/libgdkcardimage.a
lib/libgdkcardimage.la
lib/libgdkcardimage.so
lib/libgdkcardimage.so.0.30
share/gnome/apps/Games/freecell.desktop
share/gnome/apps/Games/gnobots.desktop
share/gnome/apps/Games/gnome-stones.desktop
share/gnome/apps/Games/gnomine.desktop
share/gnome/apps/Games/gnothello.desktop
share/gnome/apps/Games/gyahtzee.desktop
share/gnome/apps/Games/mahjongg.desktop
share/gnome/apps/Games/same-gnome.desktop
share/gnome/games/gnobots.safe.scores
share/gnome/games/gnobots.unsafe.scores
share/gnome/games/gnome-stones.scores
share/gnome/games/gnomine.Biiiig.scores
share/gnome/games/gnomine.Custom.scores
share/gnome/games/gnomine.Medium.scores
share/gnome/games/gnomine.Tiny.scores
share/gnome/games/gyahtzee.scores
share/gnome/games/mahjongg.scores
share/gnome/games/same-gnome.scores
share/gnome/gnome-stones/default.caves
share/gnome/gnome-stones/tutorial.caves
share/gnome/help/gnobots/C/index.html
share/gnome/help/gnobots/C/topic.dat
share/gnome/pixmaps/cards/Background.xpm
share/gnome/pixmaps/cards/Cardback1.xpm
share/gnome/pixmaps/cards/Cardback2.xpm
share/gnome/pixmaps/cards/Cardback3.xpm
share/gnome/pixmaps/cards/Cardback4.xpm
share/gnome/pixmaps/cards/Cardback5.xpm
share/gnome/pixmaps/cards/Pictures.xpm
share/gnome/pixmaps/cards/Ranks.xpm
share/gnome/pixmaps/cards/Suits.xpm
share/gnome/pixmaps/gnobots/aieee.png
share/gnome/pixmaps/gnobots/cows.png
share/gnome/pixmaps/gnobots/eggs.png
share/gnome/pixmaps/gnobots/gnomes.png
share/gnome/pixmaps/gnobots/mice.png
share/gnome/pixmaps/gnobots/robots.png
share/gnome/pixmaps/gnobots/windows.png
share/gnome/pixmaps/gnobots/yahoo.png
share/gnome/pixmaps/gnome-stones/amoeba.png
share/gnome/pixmaps/gnome-stones/boulder.png
share/gnome/pixmaps/gnome-stones/butterfly.png
share/gnome/pixmaps/gnome-stones/curtain.png
share/gnome/pixmaps/gnome-stones/diamond.png
share/gnome/pixmaps/gnome-stones/dirt.png
share/gnome/pixmaps/gnome-stones/door.png
share/gnome/pixmaps/gnome-stones/empty.png
share/gnome/pixmaps/gnome-stones/explosion.png
share/gnome/pixmaps/gnome-stones/firefly.png
share/gnome/pixmaps/gnome-stones/frame.png
share/gnome/pixmaps/gnome-stones/gnome.png
share/gnome/pixmaps/gnome-stones/title.png
share/gnome/pixmaps/gnome-stones/wall.png
share/gnome/pixmaps/gnothello/tiles.png
share/gnome/pixmaps/mahjongg/default.png
share/gnome/pixmaps/mahjongg/seta.png
share/gnome/pixmaps/same-gnome/blink-sync.png
share/gnome/pixmaps/same-gnome/marbles.png
share/gnome/pixmaps/same-gnome/planets.png
share/gnome/pixmaps/same-gnome/rotate.png
share/gnome/pixmaps/same-gnome/stones.png
share/gnome/pixmaps/gnome-gnobots.png
share/gnome/pixmaps/gnome-gyahtzee.png
share/gnome/pixmaps/gnome-stones.png
share/locale/cs/LC_MESSAGES/gnome-games.mo
share/locale/da/LC_MESSAGES/gnome-games.mo
share/locale/de/LC_MESSAGES/gnome-games.mo
share/locale/es/LC_MESSAGES/gnome-games.mo
share/locale/fr/LC_MESSAGES/gnome-games.mo
share/locale/ga/LC_MESSAGES/gnome-games.mo
share/locale/it/LC_MESSAGES/gnome-games.mo
share/locale/ja/LC_MESSAGES/gnome-games.mo
share/locale/ko/LC_MESSAGES/gnome-games.mo
share/locale/no/LC_MESSAGES/gnome-games.mo
share/locale/pt/LC_MESSAGES/gnome-games.mo
@dirrm include/gdkcardimage
@dirrm share/gnome/help/gnobots/C
@dirrm share/gnome/help/gnobots
@dirrm share/gnome/pixmaps/cards
@dirrm share/gnome/pixmaps/gnobots
@dirrm share/gnome/pixmaps/gnome-stones
@dirrm share/gnome/pixmaps/gnothello
@dirrm share/gnome/pixmaps/mahjongg
@dirrm share/gnome/pixmaps/same-gnome
@dirrm share/gnome/gnome-stones