- Unbreak dns/posadis build under 5.x and -CURRENT

by upgrading to the latest version (0.60.5)
- Update its dependency devel/poslib to 1.0.5 (prerequisite)

PR:		ports/72308
Submitted by:	sergei
Approved by:	portsmgr (will)
This commit is contained in:
Sergei Kolobov 2004-10-06 08:52:33 +00:00
parent ea52d5a8f9
commit 405c35e9a4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=118566
8 changed files with 48 additions and 31 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= poslib
PORTVERSION= 1.0.1
PORTREVISION= 2
PORTVERSION= 1.0.5
CATEGORIES= devel dns
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= posadis
@ -16,8 +15,9 @@ MAINTAINER= sergei@FreeBSD.org
COMMENT= Posadis C++ DNS library
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_LIBTOOL_VER= 13
USE_INC_LIBTOOL_VER= 15
INSTALLS_SHLIB= yes
PLIST_SUB= VERSION="${PORTVERSION}"

View File

@ -1,2 +1,2 @@
MD5 (poslib-1.0.1.tar.gz) = 7023b9142f89266762418283bac6df7b
SIZE (poslib-1.0.1.tar.gz) = 292970
MD5 (poslib-1.0.5.tar.gz) = 9470b991bcaace0b1c00f32cbeda0cff
SIZE (poslib-1.0.5.tar.gz) = 258380

View File

@ -21,7 +21,6 @@ include/poslib-%%VERSION%%/poslib/server/requestid.h
include/poslib-%%VERSION%%/poslib/server/server.h
include/poslib-%%VERSION%%/poslib/server/serverthread.h
include/poslib-%%VERSION%%/poslib/server/srvresolver.h
@dirrm include/poslib-%%VERSION%%/poslib/server
include/poslib-%%VERSION%%/poslib/socket.h
include/poslib-%%VERSION%%/poslib/syssocket.h
include/poslib-%%VERSION%%/poslib/sysstl.h
@ -29,8 +28,6 @@ include/poslib-%%VERSION%%/poslib/sysstring.h
include/poslib-%%VERSION%%/poslib/types.h
include/poslib-%%VERSION%%/poslib/vsnprintf.h
include/poslib-%%VERSION%%/poslib/w32poll.h
@dirrm include/poslib-%%VERSION%%/poslib
@dirrm include/poslib-%%VERSION%%
lib/libposlib.a
lib/libposlib.la
lib/libposlib.so
@ -40,8 +37,6 @@ lib/libposserver.la
lib/libposserver.so
lib/libposserver.so.0
lib/poslib-%%VERSION%%/include/poslib-config.h
@dirrm lib/poslib-%%VERSION%%/include
@dirrm lib/poslib-%%VERSION%%
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/NEWS
@ -52,3 +47,8 @@ lib/poslib-%%VERSION%%/include/poslib-config.h
%%EXAMPLESDIR%%/host.cpp
%%EXAMPLESDIR%%/server.cpp
@dirrm %%EXAMPLESDIR%%
@dirrm include/poslib-%%VERSION%%/poslib/server
@dirrm include/poslib-%%VERSION%%/poslib
@dirrm include/poslib-%%VERSION%%
@dirrm lib/poslib-%%VERSION%%/include
@dirrm lib/poslib-%%VERSION%%

View File

@ -6,18 +6,22 @@
#
PORTNAME= posadis
PORTVERSION= 0.60.1
PORTREVISION= 2
PORTVERSION= 0.60.5
CATEGORIES= dns
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= sergei@FreeBSD.org
COMMENT= "Domain Name Server (DNS) implementation"
COMMENT= Domain Name Server (DNS) implementation
LIB_DEPENDS= poslib.0:${PORTSDIR}/devel/poslib
USE_AUTOCONF_VER= 259
USE_INC_LIBTOOL_VER= 15
USE_LIBLTDL= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
.if defined(WITH_FAM) || exists(${LOCALBASE}/lib/libfam.so)
CONFIGURE_ARGS= --enable-fam
@ -29,27 +33,16 @@ CONFIGURE_ARGS= --disable-fam
PLIST_SUB= FAM="@comment "
.endif
USE_LIBTOOL_VER= 13
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
INSTALLS_SHLIB= yes
PLIST_SUB+= VERSION="${PORTVERSION}"
MAN1= getzone.1 posadis.1 posadis-getroots.1 posask.1 poshost.1
MAN5= posadisrc.5
DOCS= AUTHORS ChangeLog README TODO
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502126
BROKEN= "Does not compile on FreeBSD >= 5.x"
.endif
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
MD5 (posadis-0.60.1.tar.gz) = feccf256162504785e994e5394594615
SIZE (posadis-0.60.1.tar.gz) = 489050
MD5 (posadis-0.60.5.tar.gz) = 8b13be1332a67f74b1ae36b3ab5dc80a
SIZE (posadis-0.60.5.tar.gz) = 438025

View File

@ -0,0 +1,11 @@
--- Makefile.in.orig Mon Oct 4 13:52:11 2004
+++ Makefile.in Mon Oct 4 13:52:19 2004
@@ -89,7 +89,7 @@ poslib_srvcxxflags = @poslib_srvcxxflags
poslib_srvldflags = @poslib_srvldflags@
poslib_version = @poslib_version@
-SUBDIRS = libltdl pos6 tools
+SUBDIRS = pos6 tools
EXTRA_DIST = pos6.kdevprj AUTHORS COPYING ChangeLog INSTALL README TODO posadis-config.in posadis.1 posadisrc.5 posadisrc zn.acdam.com.example db.acdam.net.example

View File

@ -0,0 +1,11 @@
--- configure.in.orig Mon Oct 4 12:52:42 2004
+++ configure.in Mon Oct 4 12:52:54 2004
@@ -27,8 +27,6 @@ AC_ENABLE_STATIC(no)
AC_LIBLTDL_INSTALLABLE
-AC_CONFIG_SUBDIRS(libltdl)
-
AC_SUBST(LTDLINCL)
AC_SUBST(LIBLTDL)

View File

@ -1,3 +1,4 @@
@comment $FreeBSD$
bin/getzone
bin/posadis
bin/posadis-config
@ -12,6 +13,7 @@ include/posadis-%%VERSION%%/hashvector.h
include/posadis-%%VERSION%%/lib.h
include/posadis-%%VERSION%%/masterfile.h
include/posadis-%%VERSION%%/pbl.h
include/posadis-%%VERSION%%/posadisrc.h
include/posadis-%%VERSION%%/query.h
include/posadis-%%VERSION%%/recursive.h
include/posadis-%%VERSION%%/resolver.h
@ -21,7 +23,6 @@ include/posadis-%%VERSION%%/updates.h
include/posadis-%%VERSION%%/vector.h
include/posadis-%%VERSION%%/zones.h
include/posadis-%%VERSION%%/zonetransfer.h
@dirrm include/posadis-%%VERSION%%
%%FAM%%lib/posadis/fam.la
%%FAM%%lib/posadis/fam.so
%%FAM%%lib/posadis/fam.so.0
@ -31,12 +32,13 @@ lib/posadis/localhost.so.0
lib/posadis/revmap.la
lib/posadis/revmap.so
lib/posadis/revmap.so.0
@dirrm lib/posadis
lib/posadis-%%VERSION%%/include/posadis-config.h
@dirrm lib/posadis-%%VERSION%%/include
@dirrm lib/posadis-%%VERSION%%
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/posadis-%%VERSION%%
@dirrm lib/posadis-%%VERSION%%/include
@dirrm lib/posadis-%%VERSION%%
@dirrm lib/posadis