- Update to 2.57
- Give maintainership to submitter PR: ports/59738 Submitted by: Clement Laforet <sheepkiller@cultdeadsheep.org> Approved by: adamw (mentor)
This commit is contained in:
parent
bad129d485
commit
4057dd908a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=94931
@ -6,29 +6,32 @@
|
||||
#
|
||||
|
||||
PORTNAME= siege
|
||||
PORTVERSION= 2.56
|
||||
PORTVERSION= 2.57
|
||||
CATEGORIES= benchmarks
|
||||
MASTER_SITES= ftp://sid.joedog.org/pub/siege/ \
|
||||
http://www.cus.org.uk/~dom/distfiles/siege/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= sheepkiller@cultdeadsheep.org
|
||||
COMMENT= A http regression testing and benchmarking utility
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-ssl=/usr --disable-shared
|
||||
MAN1= siege.1 siege.config.1 layingsiege.1 urls_txt.1 bombardment.1 \
|
||||
siege2csv.1
|
||||
USE_OPENSSL= YES
|
||||
|
||||
CONFIGURE_ARGS= --with-ssl=${OPENSSLBASE} --disable-shared
|
||||
|
||||
MAN1= siege.1 siege.config.1 layingsiege.1 urls_txt.1 bombardment.1 \
|
||||
siege2csv.1
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/siege ${PREFIX}/bin
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/utils/bombardment ${PREFIX}/bin
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/utils/siege.config ${PREFIX}/bin
|
||||
@${MV} ${WRKSRC}/utils/siege2csv.pl ${WRKSRC}/utils/siege2csv
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/utils/siege2csv ${PREFIX}/bin
|
||||
.for F in bombardment.1 layingsiege.1 siege.1 siege.config.1 \
|
||||
siege2csv.1 urls_txt.1
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/${F} ${PREFIX}/man/man1
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/src/siege ${PREFIX}/bin
|
||||
@${INSTALL_SCRIPT} ${WRKSRC}/utils/bombardment ${PREFIX}/bin
|
||||
@${INSTALL_SCRIPT} ${WRKSRC}/utils/siege2csv.pl ${PREFIX}/bin/siege2csv
|
||||
.for F in ${MAN1}
|
||||
@${INSTALL_MAN} ${WRKSRC}/doc/${F} ${PREFIX}/man/man1
|
||||
.endfor
|
||||
@${MKDIR} ${DATADIR}
|
||||
@${INSTALL_DATA} ${WRKSRC}/doc/siegerc ${DATADIR}
|
||||
@${SED} -e "s,%%DATADIR%%,${DATADIR}," ${FILESDIR}/siege.config.in > ${PREFIX}/bin/siege.config
|
||||
@${CHMOD} 555 ${PREFIX}/bin/siege.config
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (siege-2.56.tar.gz) = 65b309582e95f334be70b62705135457
|
||||
MD5 (siege-2.57.tar.gz) = c197450e97405bae3b1592979cb493ba
|
||||
|
10
benchmarks/siege/files/patch-src::hash.h
Normal file
10
benchmarks/siege/files/patch-src::hash.h
Normal file
@ -0,0 +1,10 @@
|
||||
--- src/hash.h.orig Thu Nov 27 00:33:32 2003
|
||||
+++ src/hash.h Thu Nov 27 00:35:25 2003
|
||||
@@ -23,6 +23,7 @@
|
||||
#define HASH_H
|
||||
|
||||
#include <stdio.h>
|
||||
+#include <unistd.h>
|
||||
|
||||
typedef struct HASH_T *HASH;
|
||||
|
15
benchmarks/siege/files/patch-src::main.c
Normal file
15
benchmarks/siege/files/patch-src::main.c
Normal file
@ -0,0 +1,15 @@
|
||||
--- src/main.c.orig Thu Jul 17 21:50:43 2003
|
||||
+++ src/main.c Thu Nov 27 01:27:55 2003
|
||||
@@ -301,6 +301,12 @@
|
||||
*/
|
||||
fprintf( stderr, "** " );
|
||||
display_version( FALSE );
|
||||
+ /* prevents from segfaulting */
|
||||
+ if ( my.cusers == 0) {
|
||||
+ fprintf(stderr, "\nERROR: concurrent users is not set or set to 0.\n");
|
||||
+ display_help();
|
||||
+ exit (EXIT_FAILURE);
|
||||
+ };
|
||||
fprintf( stderr, "** Preparing %d concurrent users for battle.\n", my.cusers );
|
||||
fprintf( stderr, "The server is now under siege..." );
|
||||
if( my.verbose ){ fprintf( stderr, "\n" ); }
|
27
benchmarks/siege/files/siege.config.in
Normal file
27
benchmarks/siege/files/siege.config.in
Normal file
@ -0,0 +1,27 @@
|
||||
#!/bin/sh
|
||||
# SCRIPT: siege.config
|
||||
# AUTHOR: Jeffrey Fulmer <jdfulmer@armstrong.com>
|
||||
# DATE: Mon May 28 11:40:28 EDT 2001
|
||||
# SYNOP: This script generates an $HOME/.siegerc
|
||||
# file from the doc/siegerc.in template.
|
||||
# Its contents are added to this script by
|
||||
# configure. The siegerc file template is
|
||||
# maintained once in $(top_srcdir)/doc.
|
||||
|
||||
rcfile="$HOME/.siegerc"
|
||||
|
||||
if test -f $rcfile; then
|
||||
echo "siege.config"
|
||||
echo "usage: siege.config [no arguments]"
|
||||
echo "----------------------------------"
|
||||
echo "Resource file already install as $rcfile"
|
||||
echo "Use your favorite editor to change your configuration by"
|
||||
echo "editing the values in that file."
|
||||
echo ""
|
||||
exit
|
||||
fi
|
||||
cp %%DATADIR%%/siegerc ${rcfile}
|
||||
echo "New configuration template added to $rcfile"
|
||||
echo "Run siege -C to view the current settings in that file"
|
||||
exit
|
||||
|
@ -2,3 +2,5 @@ bin/siege
|
||||
bin/bombardment
|
||||
bin/siege2csv
|
||||
bin/siege.config
|
||||
%%DATADIR%%/siegerc
|
||||
@dirrm %%DATADIR%%
|
||||
|
Loading…
Reference in New Issue
Block a user