unbreak by fixing lib-depends

add more master sites
remove some unnecessary depends
This commit is contained in:
Ying-Chieh Liao 2004-02-20 09:57:20 +00:00
parent 1f5a12229e
commit 40243c4bf7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=101480
5 changed files with 37 additions and 15 deletions

View File

@ -9,29 +9,25 @@ PORTNAME= ccscript
PORTVERSION= 2.5.6
PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ccscript
MASTER_SITES= ${MASTER_SITE_GNU:S/$/:gnu/} \
${MASTER_SITE_SOURCEFORGE:S/$/:sf/}
MASTER_SITE_SUBDIR= ccaudio/:gnu \
bayonne/:sf
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:gnu \
${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:sf
MAINTAINER= ports@FreeBSD.org
COMMENT= State-event driven class extendible C++ script interpreter
LIB_DEPENDS= ccgnu2-1.0.0:${PORTSDIR}/devel/commoncpp
LIB_DEPENDS= ccgnu2-1.1.0:${PORTSDIR}/devel/commoncpp
BROKEN= "Broken dependency"
USE_GMAKE= yes
USE_LIBTOOL= yes
USE_AUTOCONF= yes
WANT_AUTOCONF_VER= 257
USE_GNOME= gnometarget
GNU_CONFIGURE= yes
INSTALL_TARGET= install man
INSTALLS_SHLIB= yes
CONFIGURE_TARGET=
MAN3= ScriptCommand.3cc ScriptImage.3cc ScriptInterp.3cc \
ScriptModule.3cc ScriptSymbol.3cc Script_Locks.3cc \
Script_Package.3cc Script_Property.3cc Script_Session.3cc
post-install:
(cd ${WRKSRC} ; ${MAKE} man)
.include <bsd.port.mk>

View File

@ -1 +1,2 @@
MD5 (ccscript-2.5.6.tar.gz) = c0e664ab13e054b37e0f7da40a7b488e
SIZE (ccscript-2.5.6.tar.gz) = 375473

View File

@ -0,0 +1,15 @@
--- config/ltmain.sh.orig Fri Feb 20 17:50:28 2004
+++ config/ltmain.sh Fri Feb 20 17:50:39 2004
@@ -5428,10 +5428,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false ; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View File

@ -0,0 +1,11 @@
--- src/script.cpp.orig Fri Feb 20 17:51:13 2004
+++ src/script.cpp Fri Feb 20 17:52:01 2004
@@ -1209,7 +1209,7 @@
#endif
for(;;)
{
- scrname = dir.getName();
+ scrname = (char*)dir.getName();
if(!scrname)
break;
ext = strchr(scrname, '.');

View File

@ -1,7 +1,6 @@
bin/ccscript
include/cc++2/cc++/script.h
lib/libccscript2.a
lib/libccscript2.la
lib/libccscript2.so
lib/libccscript2-0.5.so
lib/libccscript2-0.5.so.3