- Update to 0.1.8

PR:		ports/83772
Submitted by:	chinsan <chinsan.tw@gmail.com> (maintainer)
This commit is contained in:
Pav Lucistnik 2005-07-20 11:45:22 +00:00
parent ddef71acca
commit 401791425b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=139683
6 changed files with 46 additions and 6 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= pcmanx
PORTVERSION= 0.1.7
PORTVERSION= 0.1.8
CATEGORIES= chinese net
MASTER_SITES= http://pcmanx.csie.net/release/ \
http://bbs.ilc.edu.tw/~chinsan/pcmanx/
@ -32,9 +32,7 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
.include <bsd.port.pre.mk>
post-patch:
@${REINPLACE_CMD} -e 's|--tag=CXX||g' ${WRKSRC}/src/Makefile.in
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
MD5 (pcmanx-pure-gtk2-0.1.7.tar.gz) = b39d8254598a665b49e743200763fd96
SIZE (pcmanx-pure-gtk2-0.1.7.tar.gz) = 502471
MD5 (pcmanx-pure-gtk2-0.1.8.tar.gz) = 8b101c9bc3c8b761e6503dafcf8fab0f
SIZE (pcmanx-pure-gtk2-0.1.8.tar.gz) = 503749

View File

@ -0,0 +1,10 @@
--- src/stringutil.cpp.orig Thu Jul 7 14:08:01 2005
+++ src/stringutil.cpp Wed Jul 20 13:32:46 2005
@@ -11,6 +11,7 @@
#include "stringutil.h"
#include <ctype.h>
+#include <stdio.h>
int strncmpi(const char* str1, const char* str2, size_t len)
{

View File

@ -0,0 +1,10 @@
--- src/telnetcon.h.orig Tue Jul 19 21:30:01 2005
+++ src/telnetcon.h Wed Jul 20 13:36:06 2005
@@ -25,6 +25,7 @@
#include <string>
#include <vector>
+#include <sys/types.h>
#include <netinet/in.h>
using namespace std;

View File

@ -0,0 +1,11 @@
--- src/telnetview.cpp.orig Wed Jul 20 07:07:54 2005
+++ src/telnetview.cpp Wed Jul 20 13:39:22 2005
@@ -178,7 +178,7 @@
"utf-8", m_pTermData->m_Encoding.c_str(), "?", NULL, &wl, NULL);
if(purl)
{
- m_s_ANSIColorStr.clear();
+ m_s_ANSIColorStr = "";
GtkClipboard* clipboard = gtk_clipboard_get( GDK_NONE );
gtk_clipboard_set_text(clipboard, purl, wl );
clipboard = gtk_clipboard_get( GDK_SELECTION_PRIMARY);

View File

@ -0,0 +1,11 @@
--- src/termview.cpp.orig Tue Jul 19 19:37:38 2005
+++ src/termview.cpp Wed Jul 20 13:27:05 2005
@@ -728,7 +728,7 @@
m_s_ANSIColorStr = m_pTermData->GetSelectedTextWithColor(trim);
else
{
- m_s_ANSIColorStr.clear();
+ m_s_ANSIColorStr = "";
string text = m_pTermData->GetSelectedText(trim);
gsize wl = 0;