Remove expired port:
2017-04-30 astro/gmapcatcher: Unfetchable for more than six months (google code has gone away)
This commit is contained in:
parent
5fdfb14626
commit
400ce66436
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=454054
1
MOVED
1
MOVED
@ -9627,3 +9627,4 @@ devel/oniguruma6|devel/oniguruma|2017-11-12|Rename devel/oniguruma6 to oniguruma
|
||||
multimedia/plexhometheater||2017-11-12|Has expired: Broken for more than 6 months
|
||||
databases/cassandra2||2017-11-12|Has expired: Broken for more than 6 months
|
||||
graphics/geos35|graphics/geos|2017-11-12|Has expired: legacy version, no longer needed
|
||||
astro/gmapcatcher||2017-11-12|Has expired: Unfetchable for more than six months (google code has gone away)
|
||||
|
@ -17,7 +17,6 @@
|
||||
SUBDIR += garmindev
|
||||
SUBDIR += geographiclib
|
||||
SUBDIR += gkrellmoon2
|
||||
SUBDIR += gmapcatcher
|
||||
SUBDIR += google-earth
|
||||
SUBDIR += gpsbabel
|
||||
SUBDIR += gpsbabel14
|
||||
|
@ -1,38 +0,0 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= gmapcatcher
|
||||
PORTVERSION= 0.8.0.4
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= astro geography
|
||||
MASTER_SITES= http://gmapcatcher.googlecode.com/files/
|
||||
DISTNAME= mapcatcher_${PORTVERSION}
|
||||
|
||||
MAINTAINER= kevlo@FreeBSD.org
|
||||
COMMENT= Offline map viewer
|
||||
|
||||
BROKEN= Unfetchable (google code has gone away)
|
||||
DEPRECATED= Unfetchable for more than six months (google code has gone away)
|
||||
EXPIRATION_DATE= 2017-04-30
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow \
|
||||
${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/g}
|
||||
USES= python
|
||||
USE_GNOME= pygtk2
|
||||
USE_PYTHON= autoplist distutils
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's,/usr/share/pixmaps,${PREFIX}/share/pixmaps,g' \
|
||||
${WRKSRC}/gmapcatcher/widgets/mapPixbuf.py
|
||||
|
||||
post-install:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/mapcatcher ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/mapdownloader ${STAGEDIR}${PREFIX}/bin
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_MAN} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_MAN} ${WRKSRC}/changelog ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1,2 +0,0 @@
|
||||
SHA256 (mapcatcher_0.8.0.4.tar.gz) = 9cc969e9c4fb7fe42e7afb33b5bf60a868c626e2ec957d3003daeecdaa1dae76
|
||||
SIZE (mapcatcher_0.8.0.4.tar.gz) = 441925
|
@ -1,26 +0,0 @@
|
||||
--- gmapcatcher/mapArgs.py.orig 2013-07-19 08:20:47 UTC
|
||||
+++ gmapcatcher/mapArgs.py
|
||||
@@ -46,10 +46,10 @@ class MapArgs():
|
||||
print ' very useful to download maps of entire world'
|
||||
print ' '
|
||||
print 'SAMPLE USAGE'
|
||||
- print ' download --location="Paris, France"'
|
||||
- print ' download --min-zoom=13 --full-range'
|
||||
- print ' download --latitude=37.979180 --longitude=23.716647'
|
||||
- print ' download --gpx=myfile.gpx --width=2'
|
||||
+ print ' mapdownloader --location="Paris, France"'
|
||||
+ print ' mapdownloader --min-zoom=13 --full-range'
|
||||
+ print ' mapdownloader --latitude=37.979180 --longitude=23.716647'
|
||||
+ print ' mapdownloader --gpx=myfile.gpx --width=2'
|
||||
|
||||
def __init__(self, arrArgs=()):
|
||||
if len(arrArgs) > 1:
|
||||
@@ -99,7 +99,7 @@ class MapArgs():
|
||||
self.lng_range = 179
|
||||
|
||||
def __str__(self):
|
||||
- return ("download.py --max-zoom=%s --min-zoom=%s" +
|
||||
+ return ("mapdownloader --max-zoom=%s --min-zoom=%s" +
|
||||
" --latitude=%s --longitude=%s" +
|
||||
" --width=%s --height=%s") % \
|
||||
(self.max_zl, self.min_zl,
|
@ -1,20 +0,0 @@
|
||||
--- setup.py.orig 2013-07-19 08:20:47 UTC
|
||||
+++ setup.py
|
||||
@@ -13,15 +13,13 @@ if os.name == "posix":
|
||||
description = 'Offline Map Viewer',
|
||||
version = VERSION,
|
||||
url = WEB_ADDRESS,
|
||||
- data_files = [('share/doc/mapcatcher', ['README', 'changelog']),
|
||||
- ('share/applications', ['gmapcatcher.desktop']),
|
||||
- ('share/man/man1',
|
||||
+ data_files = [('share/applications', ['gmapcatcher.desktop']),
|
||||
+ ('man/man1',
|
||||
['man/mapcatcher.1.gz', 'man/mapdownloader.1.gz']),
|
||||
('share/pixmaps', ['images/mapcatcher.png']),
|
||||
('share/pixmaps/gmapcatcher',
|
||||
map(lambda(thestr): "images/" + thestr, os.listdir('images')))
|
||||
],
|
||||
- scripts = ['mapcatcher', 'mapdownloader'],
|
||||
packages = ['gmapcatcher', 'gmapcatcher.mapServers',
|
||||
'gmapcatcher.tilesRepo', 'gmapcatcher.widgets',
|
||||
'gmapcatcher.gpxpy', 'gmapcatcher.gps']
|
@ -1,5 +0,0 @@
|
||||
GMapCatcher is an offline maps viewer. It downloads CloudMade,
|
||||
OpenStreetMap or Yahoo Maps tiles automatically, display them
|
||||
using a specific GUI. User can view the maps while offline.
|
||||
|
||||
WWW: http://code.google.com/p/gmapcatcher/
|
@ -1,4 +0,0 @@
|
||||
bin/mapcatcher
|
||||
bin/mapdownloader
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/changelog
|
Loading…
Reference in New Issue
Block a user