Update to GCC 3.0.0.

This commit is contained in:
David E. O'Brien 2001-08-30 19:06:54 +00:00
parent 23a999b22b
commit 3f4fe1d4a0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=47170
8 changed files with 93 additions and 67 deletions

View File

@ -6,30 +6,28 @@
# $FreeBSD$
#
SNAPDATE= 2001-04-30
SNAPVER= ${SNAPDATE:S/-//g}
PORTNAME= gcc-30snap
PORTVERSION= ${SNAPVER}
PORTNAME= gcc30
PORTVERSION= 3.0.0
CATEGORIES= lang java
MASTER_SITES= ftp://egcs.cygnus.com/pub/egcs/snapshots/${SNAPDATE}/ \
MASTER_SITES= ftp://egcs.cygnus.com/pub/egcs/releases/gcc-${GCC_REV}/ \
${MASTER_SITE_SOURCEWARE}
MASTER_SITE_SUBDIR= gcc/snapshots/${SNAPDATE}
DISTFILES= gcc-core-${SNAPVER}${EXTRACT_SUFX} \
gcc-g++-${SNAPVER}${EXTRACT_SUFX} \
gcc-g77-${SNAPVER}${EXTRACT_SUFX} \
gcc-java-${SNAPVER}${EXTRACT_SUFX} \
gcc-objc-${SNAPVER}${EXTRACT_SUFX}
MASTER_SITE_SUBDIR= gcc/releases/gcc-${GCC_REV}
DISTFILES= gcc-core-${GCC_REV}${EXTRACT_SUFX} \
gcc-g++-${GCC_REV}${EXTRACT_SUFX} \
gcc-g77-${GCC_REV}${EXTRACT_SUFX} \
gcc-java-${GCC_REV}${EXTRACT_SUFX} \
gcc-objc-${GCC_REV}${EXTRACT_SUFX}
MAINTAINER= obrien@FreeBSD.org
NO_CDROM= 'dated material'
USE_BZIP2= yes
PATCH_ARGS= -d ${SRCDIR} -E ${PATCH_STRIP}
.if !defined(PATCH_DEBUG)
PATCH_ARGS+= --forward --quiet
.endif
CONFIGURE_SCRIPT= ../gcc-${SNAPVER}/configure
GCC_REV= ${PORTVERSION:C/\.0$//}
CONFIGURE_SCRIPT= ../gcc-${GCC_REV}/configure
.include <bsd.port.pre.mk>
@ -39,12 +37,10 @@ CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_TARGET= ${ARCH}-portbld-freebsdaout${OSREL}
.endif
EGCS_REV= 3.0
SRCDIR= ${WRKDIR}/gcc-${SNAPVER}
SRCDIR= ${WRKDIR}/gcc-${GCC_REV}
WRKSRC= ${WRKDIR}/build
TARGLIB= ${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/${EGCS_REV}
PLIST_SUB= EGCS_REV=${EGCS_REV} GNU_HOST=${CONFIGURE_TARGET} \
SNAPVER=${SNAPVER}
TARGLIB= ${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/${GCC_REV}
PLIST_SUB= GCC_REV=${GCC_REV} GNU_HOST=${CONFIGURE_TARGET}
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_BISON= yes
@ -85,12 +81,12 @@ post-install:
@(for prog in ${PREFIX}/bin/gcc ${PREFIX}/bin/g++ \
${PREFIX}/bin/g++filt ${PREFIX}/bin/g77 ${PREFIX}/bin/gcov \
${PREFIX}/bin/${CONFIGURE_TARGET}-gcc \
${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/${EGCS_REV}/cc1 \
${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/${EGCS_REV}/cc1obj \
${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/${EGCS_REV}/cc1plus \
${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/${EGCS_REV}/cpp0 \
${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/${EGCS_REV}/collect2 \
${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/${EGCS_REV}/f771 ; \
${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/${GCC_REV}/cc1 \
${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/${GCC_REV}/cc1obj \
${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/${GCC_REV}/cc1plus \
${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/${GCC_REV}/cpp0 \
${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/${GCC_REV}/collect2 \
${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/${GCC_REV}/f771 ; \
do \
strip $$prog ; \
done )
@ -104,7 +100,7 @@ post-install:
${MV} -f ${PREFIX}/bin/${file} ${PREFIX}/bin/${file}-30
${MV} -f ${PREFIX}/man/man1/${file}.1 ${PREFIX}/man/man1/${file}-30.1
.endfor
${MV} -f ${PREFIX}/bin/gccbug ${PREFIX}/bin/gccbug-${SNAPVER}
${MV} -f ${PREFIX}/bin/gccbug ${PREFIX}/bin/gccbug-${PORTVERSION:C/\.0$//}
# These 3 libraries are moved from PREFIX/lib to avoid conflicts
# with the stock compiler.
${MV} -f ${PREFIX}/lib/libiberty.a ${TARGLIB}

View File

@ -1,5 +1,5 @@
MD5 (gcc-core-20010430.tar.gz) = 2f4f1744b8aba33a1700e0be0b58f264
MD5 (gcc-g++-20010430.tar.gz) = 75bb2329937caa975a541ba493f87198
MD5 (gcc-g77-20010430.tar.gz) = 592086ce2864559df2608efb831c4ed1
MD5 (gcc-java-20010430.tar.gz) = 63cee3b2ed763a8eb31501b2fad26fcf
MD5 (gcc-objc-20010430.tar.gz) = 6616e23d3ee6efb1a124870e30841cf6
MD5 (gcc-core-3.0.tar.bz2) = fea2b6b4958ef5a94a63177d3dbbc03b
MD5 (gcc-g++-3.0.tar.bz2) = 4b71b49f846fd984a6868ca3a226a637
MD5 (gcc-g77-3.0.tar.bz2) = 252c7d2a84fe4f8ceceab8b63146ed15
MD5 (gcc-java-3.0.tar.bz2) = 8781294bab5a40ce438448b0a0ee93c2
MD5 (gcc-objc-3.0.tar.bz2) = e220bf55fe570dd6cf0d71f39336885a

View File

@ -1,5 +1,5 @@
--- gcc/cpp.texi.orig Mon Aug 11 08:57:05 1997
+++ gcc/cpp.texi Sat Jan 10 11:59:15 1998
--- gcc/doc/cpp.texi.orig Mon Aug 11 08:57:05 1997
+++ gcc/doc/cpp.texi Sat Jan 10 11:59:15 1998
@@ -1,5 +1,9 @@
\input texinfo
@setfilename cpp.info

View File

@ -1,5 +1,5 @@
--- gcc/gcc.texi.orig Fri Jan 2 15:38:11 1998
+++ gcc/gcc.texi Sat Jan 10 11:56:49 1998
--- gcc/doc/gcc.texi.orig Fri Jan 2 15:38:11 1998
+++ gcc/doc/gcc.texi Sat Jan 10 11:56:49 1998
@@ -1,6 +1,10 @@
>\input texinfo @c -*-texinfo-*-
@c %**start of header

View File

@ -1,14 +1,10 @@
--- gcc/config/i386/freebsd.h.orig Thu Nov 2 15:29:09 2000
+++ gcc/config/i386/freebsd.h Mon Nov 27 01:52:39 2000
@@ -76,11 +76,15 @@
--- gcc/config/i386/freebsd.h.orig Wed May 30 16:05:31 2001
+++ gcc/config/i386/freebsd.h Mon Jun 18 17:47:30 2001
@@ -76,6 +76,14 @@
#undef WCHAR_TYPE_SIZE
#define WCHAR_TYPE_SIZE BITS_PER_WORD
-
-#undef CPP_PREDEFINES
-#define CPP_PREDEFINES "-Dunix -D__ELF__ -D__FreeBSD__\
- -Asystem=unix -Asystem=bsd -Asystem=FreeBSD"
+
+#undef CC1_SPEC
+#define CC1_SPEC "\
+ %{gline:%{!g:%{!g0:%{!g1:%{!g2: -g1}}}}} \
@ -16,11 +12,10 @@
+
+#undef ASM_SPEC
+#define ASM_SPEC "%{v*: -v} %{maout: %{fpic:-k} %{fPIC:-k}}"
+
/* Provide a STARTFILE_SPEC appropriate for FreeBSD. Here we add
the magical crtbegin.o file (see crtstuff.c) which provides part
of the support for getting C++ file-scope static object constructed
@@ -88,11 +92,11 @@
@@ -84,11 +92,18 @@
#undef STARTFILE_SPEC
#define STARTFILE_SPEC \
@ -31,13 +26,20 @@
- crti.o%s %{!shared:crtbegin.o%s} %{shared:crtbeginS.o%s}"
+ "%{maout: %{shared:c++rt0.o%s} \
+ %{!shared:%{pg:gcrt0.o%s}%{!pg:%{static:scrt0.o%s}%{!static:crt0.o%s}}}} \
+ %{!maout: %{!shared: \
+ %{pg:gcrt1.o%s} %{!pg:%{p:gcrt1.o%s} %{!p:crt1.o%s}}} \
+ crti.o%s %{!shared:crtbegin.o%s} %{shared:crtbeginS.o%s}}"
+ %{!maout: \
+ %{!shared: \
+ %{pg:gcrt1.o%s} \
+ %{!pg:%{p:gcrt1.o%s} \
+ %{!p:%{profile:gcrt1.o%s} \
+ %{!profile:crt1.o%s}}}} \
+ crti.o%s \
+ %{!shared:crtbegin.o%s} \
+ %{shared:crtbeginS.o%s} \
+ }"
/* Provide a ENDFILE_SPEC appropriate for FreeBSD. Here we tack on
the magical crtend.o file (see crtstuff.c) which provides part of
@@ -102,7 +106,7 @@
@@ -98,7 +113,7 @@
#undef ENDFILE_SPEC
#define ENDFILE_SPEC \

View File

@ -1,16 +1,44 @@
--- gcc/config/freebsd.h.orig Mon Nov 22 22:17:32 1999
+++ gcc/config/freebsd.h Fri Feb 4 05:29:31 2000
@@ -48,13 +48,26 @@
--- gcc/config/freebsd.h.orig Wed May 30 16:05:30 2001
+++ gcc/config/freebsd.h Mon Jun 18 18:46:50 2001
@@ -50,29 +50,32 @@
#undef WORD_SWITCH_TAKES_ARG
#define WORD_SWITCH_TAKES_ARG(STR) (FBSD_WORD_SWITCH_TAKES_ARG(STR))
+/* Place spaces around this string. We depend on string splicing to produce
+ the final CPP_PREDEFINES value. */
+#define FBSD_CPP_PREDEFINES " -Dunix -D__FreeBSD__ -Asystem(unix) -Asystem(bsd) -Asystem(FreeBSD) "
+
+#undef CPP_PREDEFINES
+#define CPP_PREDEFINES FBSD_CPP_PREDEFINES
+
#if FBSD_MAJOR == 6
#define FBSD_CPP_PREDEFINES \
- "-D__FreeBSD__=6 -Dunix -D__ELF__ -Asystem=unix -Asystem=bsd -Asystem=FreeBSD"
+ " -D__FreeBSD__=6 -Dunix -Asystem=unix -Asystem=bsd -Asystem=FreeBSD "
#endif
#if FBSD_MAJOR == 5
#define FBSD_CPP_PREDEFINES \
- "-D__FreeBSD__=5 -Dunix -D__ELF__ -Asystem=unix -Asystem=bsd -Asystem=FreeBSD"
+ " -D__FreeBSD__=5 -Dunix -Asystem=unix -Asystem=bsd -Asystem=FreeBSD "
#endif
#if FBSD_MAJOR == 4
#define FBSD_CPP_PREDEFINES \
- "-D__FreeBSD__=4 -Dunix -D__ELF__ -Asystem=unix -Asystem=bsd -Asystem=FreeBSD"
+ " -D__FreeBSD__=4 -Dunix -Asystem=unix -Asystem=bsd -Asystem=FreeBSD "
#endif
#if FBSD_MAJOR == 3
#define FBSD_CPP_PREDEFINES \
- "-D__FreeBSD__=3 -Dunix -D__ELF__ -Asystem=unix -Asystem=bsd -Asystem=FreeBSD"
+ " -D__FreeBSD__=3 -Dunix -Asystem=unix -Asystem=bsd -Asystem=FreeBSD "
#endif
#ifndef FBSD_CPP_PREDEFINES
#define FBSD_CPP_PREDEFINES \
- "-D__FreeBSD__ -Dunix -D__ELF__ -Asystem=unix -Asystem=bsd -Asystem=FreeBSD"
+ " -D__FreeBSD__ -Dunix -Asystem=unix -Asystem=bsd -Asystem=FreeBSD "
#endif
#undef CPP_PREDEFINES
@@ -81,10 +84,16 @@
/* Provide a CPP_SPEC appropriate for FreeBSD. We just deal with the GCC
option `-posix', and PIC issues. */
@ -28,5 +56,5 @@
+#undef CPP_SPEC
+#define CPP_SPEC FBSD_CPP_SPEC
/* Provide a LIB_SPEC appropriate for FreeBSD. Just select the appropriate
libc, depending on whether we're doing profiling or need threads support.
/* Provide a LIB_SPEC appropriate for FreeBSD as configured and as
required by the user-land thread model. Before __FreeBSD_version

View File

@ -13,11 +13,11 @@
@@ -1064,6 +1067,8 @@
"Do the full regmove optimization pass"},
{"pack-struct", &flag_pack_struct, 1,
"Pack structure members together without holes" },
N_("Pack structure members together without holes") },
+ {"format-extensions", &flag_format_extensions, 1,
+ "-Wformat accepts certain FreeBSD system-dependent formats" },
+ N_("-Wformat accepts certain FreeBSD system-dependent formats") },
{"stack-check", &flag_stack_check, 1,
"Insert stack checking code into the program" },
N_("Insert stack checking code into the program") },
{"argument-alias", &flag_argument_noalias, 0,
@@ -4484,6 +4489,19 @@
if (optimize_val != -1)

View File

@ -17,14 +17,14 @@ bin/jcf-dump
@comment Insert PLIST.gcc-lib here
@comment -=[ begin PLIST.gcc-lib ]=-
@comment -=[ end PLIST.gcc-lib ]=-
@unexec install-info --delete %D/info/c-tree.info %D/info/dir
@comment unexec install-info --delete %D/info/c-tree.info %D/info/dir
@unexec install-info --delete %D/info/cppinternals.info %D/info/dir
@unexec install-info --delete %D/info/gcc.info %D/info/dir
@unexec install-info --delete %D/info/g77.info %D/info/dir
info/c-tree.info
info/c-tree.info-1
info/c-tree.info-2
info/c-tree.info-3
@comment info/c-tree.info
@comment info/c-tree.info-1
@comment info/c-tree.info-2
@comment info/c-tree.info-3
info/cpp.info
info/cpp.info-1
info/cpp.info-2