Upgrade to 1.3.33.

Submitted by:	hrs
This commit is contained in:
Munechika SUMIKAWA 2004-11-05 18:21:25 +00:00
parent ac18060927
commit 3f46d5eea9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=120899
5 changed files with 71 additions and 46 deletions

View File

@ -6,55 +6,57 @@
#
PORTNAME= apache+ipv6
PORTVERSION= 1.3.29
PORTREVISION= 2
PORTVERSION= 1.3.33
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
DISTNAME= apache_${PORTVERSION}
PATCH_SITES= http://www.tendra.org/~asmodai/ipv6/
PATCHFILES= apache-1.3.29-v6-20031112.diff.gz
#PATCH_SITES= ${MASTER_SITE_APACHE_HTTPD}
#PATCH_SITE_SUBDIR= patches/apply_to_1.3.33/
#PATCHFILES=
#PATCH_DIST_ARGS= -d ${WRKSRC}/src --forward --quiet -E ${PATCH_DIST_STRIP}
PATCH_SITES= ${MASTER_SITE_LOCAL}
PATCH_SITE_SUBDIR= hrs
PATCHFILES= apache-1.3.33-v6-20041106.diff.gz
MAINTAINER= sumikawa@FreeBSD.org
COMMENT= The extremely popular Apache http server. Very fast, very clean
BROKEN= Vulnerability is found and no IPv6 patch for latest version is available. \
Recommend to use apache2 instead of this port
CONFLICTS= apache+mod_ssl-1.* apache+mod_ssl+ipv6-1.* apache+mod_ssl+modsnmp-1.* \
apache+mod_ssl+mod_snmp+ipv6-1.* apache+mod_ssl+mod_accel-1.* \
apache+mod_ssl+mod_snmp+mod_accel-1.* \
apache+ssl-1.* apache-1.* apache-2.* apache_fp-1.* \
caudium-devel-1.* caudium10-1.* caudium12-* \
ru-apache+mod_ssl-1.* ru-apache-1.* thttpd-2.*
USE_PERL5= yes
USE_PERL5= yes
USE_RC_SUBR= yes
.if defined(APACHE_DATADIR)
DATADIR= ${APACHE_DATADIR}
DATADIR=${APACHE_DATADIR}
.else
DATADIR= ${PREFIX}/www
DATADIR=${PREFIX}/www
.endif
.if defined(APACHE_DOCUMENT_ROOT)
DOCUMENT_ROOT= ${APACHE_DOCUMENT_ROOT}
DOCUMENT_ROOT=${APACHE_DOCUMENT_ROOT}
.else
DOCUMENT_ROOT= ${DATADIR}/data
DOCUMENT_ROOT=${DATADIR}/data
.endif
.if defined(APACHE_CGIBIN_ROOT)
CGIBIN_ROOT= ${APACHE_CGIBIN_ROOT}
CGIBIN_ROOT=${APACHE_CGIBIN_ROOT}
.else
CGIBIN_ROOT= ${DATADIR}/cgi-bin
CGIBIN_ROOT=${DATADIR}/cgi-bin
.endif
DEFAULT_PATH=/bin:/usr/bin:${PREFIX}/bin
RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
RC_SCRIPTS_SUB=PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
.if defined(WITHOUT_APACHE_EXPAT) && ${WITHOUT_APACHE_EXPAT} == yes
EXPAT_CONF+= --disable-rule=EXPAT
EXPAT_CONF+= --disable-rule=EXPAT
.else
.if !defined(WITH_APACHE_INTERNAL_EXPAT) || ${WITH_APACHE_INTERNAL_EXPAT} != yes
LIB_DEPENDS+= expat.5:${PORTSDIR}/textproc/expat2
LIB_DEPENDS+= expat.5:${PORTSDIR}/textproc/expat2
.endif
EXPAT_CONF+= --enable-rule=EXPAT
EXPAT_CONF+= --enable-rule=EXPAT
.endif
.if defined(WITH_APACHE_SUEXEC) && ${WITH_APACHE_SUEXEC} == yes
@ -66,7 +68,7 @@ APACHE_SUEXEC_UIDMIN?=1000
APACHE_SUEXEC_GIDMIN?=1000
APACHE_SUEXEC_CALLER?=www
SUEXEC_CONF= \
SUEXEC_CONF= \
--enable-suexec \
--suexec-docroot=${APACHE_SUEXEC_DOCROOT} \
--suexec-caller=${APACHE_SUEXEC_CALLER} \
@ -77,22 +79,22 @@ SUEXEC_CONF= \
--suexec-safepath=${DEFAULT_PATH}
.if defined(APACHE_SUEXEC_UMASK)
SUEXEC_CONF+= \
SUEXEC_CONF+= \
--suexec-umask=${APACHE_SUEXEC_UMASK}
.endif
PLIST_SUB+= SUB_SUEXEC=""
SUEXEC_MAN= suexec.8
PLIST_SUB+= SUB_SUEXEC=""
SUEXEC_MAN= suexec.8
.else # !SUEXEC
SUEXEC_CONF=
PLIST_SUB+= SUB_SUEXEC="@comment "
PLIST_SUB+= SUB_SUEXEC="@comment "
SUEXEC_MAN=
.endif # !SUEXEC
HAS_CONFIGURE= yes
HAS_CONFIGURE= yes
# += for child ports
CONFIGURE_ARGS+= \
--prefix=${PREFIX} \
@ -134,17 +136,17 @@ CFLAGS+=-DBUFFERED_LOGS
CFLAGS+=-O6 -fomit-frame-pointer
.endif
CONFIGURE_ENV= OPTIM='${OPTIM}' LD_SHLIB='${CC}' LIBS='${LIBS}'
CONFIGURE_ENV= OPTIM='${OPTIM}' LD_SHLIB='${CC}' LIBS='${LIBS}'
.if (!defined(WITHOUT_APACHE_EXPAT) || ${WITHOUT_APACHE_EXPAT} != yes) && \
(!defined(WITH_APACHE_INTERNAL_EXPAT) || ${WITH_APACHE_INTERNAL_EXPAT} != yes)
CONFIGURE_ENV+= \
CONFIGURE_ENV+= \
INCLUDES=-I${LOCALBASE}/include \
LDFLAGS=-L${LOCALBASE}/lib
.endif
MAN1= dbmmanage.1 htdigest.1 htpasswd.1
MAN8= ab.8 apachectl.8 apxs.8 httpd.8 logresolve.8 rotatelogs.8 \
MAN8= ab.8 apachectl.8 apxs.8 httpd.8 logresolve.8 rotatelogs.8 \
${SUEXEC_MAN}
post-extract:
@ -152,12 +154,14 @@ post-extract:
${FILESDIR}/apache.sh > ${WRKSRC}/apache.sh
pre-install:
-@${CHMOD} u+w ${DOCUMENT_ROOT}-dist ${CGIBIN_ROOT}-dist
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/apache.sh ${PREFIX}/etc/rc.d/apache.sh
@${TOUCH} ${DOCUMENT_ROOT}-dist/EXAMPLE_DIRECTORY-DONT_ADD_OR_TOUCH_ANYTHING
@${TOUCH} ${CGIBIN_ROOT}-dist/EXAMPLE_DIRECTORY-DONT_ADD_OR_TOUCH_ANYTHING
@${CHMOD} a-w ${DOCUMENT_ROOT}-dist ${CGIBIN_ROOT}-dist
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View File

@ -1,4 +1,4 @@
MD5 (apache_1.3.29.tar.gz) = e97fe9bf51dc2c9c233d53f63b1347e3
SIZE (apache_1.3.29.tar.gz) = 2435809
MD5 (apache-1.3.29-v6-20031112.diff.gz) = f00f41fd04250125dd35d585ad489dd7
SIZE (apache-1.3.29-v6-20031112.diff.gz) = 37452
MD5 (apache_1.3.33.tar.gz) = 3dfd2c3778f37a2dfc22b97417a61407
SIZE (apache_1.3.33.tar.gz) = 2468567
MD5 (apache-1.3.33-v6-20041106.diff.gz) = a8d940d2624ba563da9dc812c243e4e2
SIZE (apache-1.3.33-v6-20041106.diff.gz) = 37909

View File

@ -13,9 +13,9 @@
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
apache_enable="NO"
apache_flags=""
apache_pidfile="/var/run/httpd.pid"
apache_enable=${apache_enable-"NO"}
apache_flags=${apache_flags-""}
apache_pidfile=${apache_pidfile-"/var/run/httpd.pid"}
. %%RC_SUBR%%
@ -27,6 +27,6 @@ load_rc_config $name
pidfile="${apache_pidfile}"
start_precmd="`/usr/bin/limits -e -U www`"
start_cmd="echo \"Starting ${name}.\"; /usr/bin/limits -U www ${command} ${apache_flags} ${command_args}"
run_rc_command "$1"

View File

@ -0,0 +1,11 @@
--- src/Configure.bak Thu Sep 16 03:45:17 2004
+++ src/Configure Mon Oct 25 17:59:48 2004
@@ -456,7 +456,7 @@
PLATOSVERS=`echo $PLAT | sed 's/^.*freebsd//'`
OS="FreeBSD $PLATOSVERS"
case "$PLATOSVERS" in
- [2345]*)
+ [2-9]*)
DEF_WANTHSREGEX=no
CFLAGS="$CFLAGS -funsigned-char"
;;

View File

@ -1,4 +1,4 @@
@comment $FreeBSD: /tmp/pcvs/ports/www/apache13+ipv6/Attic/pkg-plist,v 1.20 2004-06-09 17:04:00 sumikawa Exp $
@comment $FreeBSD: /tmp/pcvs/ports/www/apache13+ipv6/Attic/pkg-plist,v 1.21 2004-11-05 18:21:25 sumikawa Exp $
bin/checkgid
bin/dbmmanage
bin/htdigest
@ -87,6 +87,7 @@ libexec/apache/mod_imap.so
libexec/apache/mod_include.so
libexec/apache/mod_info.so
libexec/apache/mod_log_config.so
libexec/apache/mod_log_forensic.so
libexec/apache/mod_mime.so
libexec/apache/mod_mime_magic.so
libexec/apache/mod_mmap_static.so
@ -106,6 +107,8 @@ sbin/httpd
sbin/logresolve
sbin/rotatelogs
%%SUB_SUEXEC%%sbin/suexec
@exec mkdir -p -m 755 www/data-dist
@unexec chmod u+w www/data-dist
www/data-dist/EXAMPLE_DIRECTORY-DONT_ADD_OR_TOUCH_ANYTHING
@exec [ -d %D/www/data/ ] || ln -fs %B %D/www/data
www/data-dist/apache_pb.gif
@ -119,6 +122,7 @@ www/data-dist/index.html.en
www/data-dist/index.html.es
www/data-dist/index.html.fr
www/data-dist/index.html.he.iso8859-8
www/data-dist/index.html.hu
www/data-dist/index.html.it
www/data-dist/index.html.ja.jis
www/data-dist/index.html.kr.iso-kr
@ -138,16 +142,12 @@ www/data-dist/index.html.ru.ucs4
www/data-dist/index.html.ru.utf8
www/data-dist/index.html.se
www/data-dist/index.html.zh-tw.big5
share/doc/apache/FAQ.html
@exec chmod a-w www/data-dist
share/doc/apache/LICENSE
share/doc/apache/bind.html.en
share/doc/apache/bind.html.fr
share/doc/apache/bind.html.html
share/doc/apache/bind.html.ja.jis
share/doc/apache/cgi_path.html.en
share/doc/apache/cgi_path.html.fr
share/doc/apache/cgi_path.html.html
share/doc/apache/cgi_path.html.ja.jis
share/doc/apache/configuring.html.en
share/doc/apache/configuring.html.fr
share/doc/apache/configuring.html.html
@ -163,6 +163,7 @@ share/doc/apache/cygwin.html
share/doc/apache/dns-caveats.html.en
share/doc/apache/dns-caveats.html.fr
share/doc/apache/dns-caveats.html.html
share/doc/apache/dns-caveats.html.ja.jis
share/doc/apache/dso.html
share/doc/apache/ebcdic.html
share/doc/apache/env.html.en
@ -206,10 +207,13 @@ share/doc/apache/install.html.ja.jis
share/doc/apache/invoking.html.en
share/doc/apache/invoking.html.fr
share/doc/apache/invoking.html.html
share/doc/apache/invoking.html.ja.jis
share/doc/apache/keepalive.html.en
share/doc/apache/keepalive.html.html
share/doc/apache/keepalive.html.ja.jis
share/doc/apache/location.html
share/doc/apache/location.html.en
share/doc/apache/location.html.html
share/doc/apache/location.html.ja.jis
share/doc/apache/logs.html
share/doc/apache/man-template.html
share/doc/apache/misc/API.html
@ -278,7 +282,9 @@ share/doc/apache/mod/mod_auth_anon.html
share/doc/apache/mod/mod_auth_db.html
share/doc/apache/mod/mod_auth_dbm.html
share/doc/apache/mod/mod_auth_digest.html
share/doc/apache/mod/mod_autoindex.html
share/doc/apache/mod/mod_autoindex.html.en
share/doc/apache/mod/mod_autoindex.html.html
share/doc/apache/mod/mod_autoindex.html.ja.jis
share/doc/apache/mod/mod_browser.html
share/doc/apache/mod/mod_cern_meta.html
share/doc/apache/mod/mod_cgi.html.en
@ -307,6 +313,8 @@ share/doc/apache/mod/mod_log_common.html
share/doc/apache/mod/mod_log_config.html.en
share/doc/apache/mod/mod_log_config.html.html
share/doc/apache/mod/mod_log_config.html.ja.jis
share/doc/apache/mod/mod_log_forensic.html.en
share/doc/apache/mod/mod_log_forensic.html.html
share/doc/apache/mod/mod_log_referer.html
share/doc/apache/mod/mod_mime.html.en
share/doc/apache/mod/mod_mime.html.html
@ -350,7 +358,6 @@ share/doc/apache/new_features_1_2.html
share/doc/apache/new_features_1_3.html.en
share/doc/apache/new_features_1_3.html.html
share/doc/apache/new_features_1_3.html.ja.jis
share/doc/apache/new_features_2_0.html
share/doc/apache/process-model.html.en
share/doc/apache/process-model.html.html
share/doc/apache/process-model.html.ja.jis
@ -379,7 +386,6 @@ share/doc/apache/programs/suexec.html.en
share/doc/apache/programs/suexec.html.html
share/doc/apache/programs/suexec.html.ja.jis
share/doc/apache/readme-tpf.html
share/doc/apache/search/manual-index.cgi
share/doc/apache/sections.html.en
share/doc/apache/sections.html.html
share/doc/apache/sections.html.ja.jis
@ -425,11 +431,15 @@ share/doc/apache/win_service.html.en
share/doc/apache/win_service.html.html
share/doc/apache/win_service.html.ja.jis
share/doc/apache/windows.html.en
share/doc/apache/windows.html.html
share/doc/apache/windows.html.ja.jis
@exec mkdir -p -m 755 www/cgi-bin-dist
@unexec chmod u+w www/cgi-bin-dist
www/cgi-bin-dist/EXAMPLE_DIRECTORY-DONT_ADD_OR_TOUCH_ANYTHING
@exec [ -d %D/www/cgi-bin/ ] || ln -fs %B %D/www/cgi-bin
www/cgi-bin-dist/printenv
www/cgi-bin-dist/test-cgi
@exec chmod a-w www/cgi-bin-dist
www/icons/README
www/icons/a.gif
www/icons/a.png