Attempt to fix build on powerpc.

Idea from:	bf@
Feature safe:	yes
This commit is contained in:
Rene Ladan 2011-12-05 23:56:02 +00:00
parent ed79347f53
commit 3f45396d9c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=286950
2 changed files with 16 additions and 1 deletions

View File

@ -60,10 +60,14 @@ PLIST_SUB+= X11="@comment "
CFLAGS+= -mtune=native
.endif
.if !empty(MACHINE_CPU:Maltivec)
CONFIGURE_ARGS+= --enable-altivec
.endif
CONFIGURE_ENV+= BOINCDIR="${NONEXISTENT}"
CONFIGURE_ARGS+= --disable-static-client --disable-server \
--disable-altivec --disable-tests \
--disable-tests \
--with-boinc-platform=${ARCH}-portbld-freebsd
SETI_SITE= setiathome.berkeley.edu

View File

@ -0,0 +1,11 @@
--- client/Makefile.am.orig 2009-09-23 01:50:50.000000000 +0200
+++ client/Makefile.am 2011-12-04 17:19:18.000000000 +0100
@@ -165,7 +165,7 @@
seti_boinc-analyzeFuncs_altivec.o: vector/analyzeFuncs_altivec.cpp
if $(CXX) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
$(CPPFLAGS) $(seti_boinc_CXXFLAGS) $(CXXFLAGS) -DUSE_ALTIVEC \
- -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" -faltivec \
+ -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" -maltivec -mabi=altivec \
-c -o $@ $<; then mv -f "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Po"; \
else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; fi
seti_boinc-analyzeFuncs_vector.o: vector/analyzeFuncs_vector.cpp