- Update to 1.8.5.

- Trim Makefile header.
- Remove shared lib version from LIB_DEPENDS.
This commit is contained in:
MANTANI Nobutaka 2013-05-14 16:51:16 +00:00
parent 4e0bf4d379
commit 3efa67895e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=318178
15 changed files with 35 additions and 80 deletions

View File

@ -1,9 +1,5 @@
# New ports collection makefile for: ja-uim-anthy
# Date created: 31 August 2003
# Whom: MANTANI Nobutaka <nobutaka@FreeBSD.org>
#
# Created by: MANTANI Nobutaka <nobutaka@FreeBSD.org>
# $FreeBSD$
#
CATEGORIES= japanese
.if defined(WITHOUT_X11)
@ -18,8 +14,8 @@ COMMENT= Uim plugin using Anthy input method
USE_GNOME= gtk20
.endif
LIB_DEPENDS= anthy.1:${PORTSDIR}/japanese/anthy \
uim.8:${PORTSDIR}/textproc/uim
LIB_DEPENDS= anthy:${PORTSDIR}/japanese/anthy \
uim:${PORTSDIR}/textproc/uim
MASTERDIR= ${.CURDIR}/../../textproc/uim
PKGDIR= ${.CURDIR}

View File

@ -1,13 +1,8 @@
# New ports collection makefile for: uim-el
# Date created: 24 December 2005
# Whom: MANTANI Nobutaka <nobutaka@freebsd.org>
#
# Created by: MANTANI Nobutaka <nobutaka@freebsd.org>
# $FreeBSD$
#
PORTNAME= uim-el
PORTVERSION= 1.8.2
PORTREVISION= 2
PORTVERSION= 1.8.5
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PKGNAMESUFFIX= -${EMACS_PORT_NAME}

View File

@ -1,2 +1,2 @@
SHA256 (uim-1.8.2.tar.bz2) = 44c2003179291b3279dae7f911d638418a54910f2b99e58418acc88e10067835
SIZE (uim-1.8.2.tar.bz2) = 6480613
SHA256 (uim-1.8.5.tar.bz2) = f74550b42d22a1e2bbc581039585541f7784eb6652a06ec17aa88bcf5f0f3d58
SIZE (uim-1.8.5.tar.bz2) = 6497675

View File

@ -1,16 +1,12 @@
# New ports collection makefile for: uim-gnome
# Date created: 31 August 2003
# Whom: MANTANI Nobutaka <nobutaka@FreeBSD.org>
#
# Created by: MANTANI Nobutaka <nobutaka@FreeBSD.org>
# $FreeBSD$
#
PKGNAMESUFFIX= -gnome
COMMENT= GNOME applets of uim input method
USE_GNOME= gtk20 gnomepanel libgnomeui
LIB_DEPENDS= uim.8:${PORTSDIR}/textproc/uim
LIB_DEPENDS= uim:${PORTSDIR}/textproc/uim
RUN_DEPENDS= uim-pref-gtk:${PORTSDIR}/textproc/uim-gtk
MASTERDIR= ${.CURDIR}/../../textproc/uim

View File

@ -1,16 +1,12 @@
# New ports collection makefile for: uim-gtk
# Date created: 31 August 2003
# Whom: MANTANI Nobutaka <nobutaka@FreeBSD.org>
#
# Created by: MANTANI Nobutaka <nobutaka@FreeBSD.org>
# $FreeBSD$
#
PKGNAMESUFFIX= -gtk
COMMENT= GTK+ modules of uim input method
USE_GNOME= gtk20
LIB_DEPENDS= uim.8:${PORTSDIR}/textproc/uim
LIB_DEPENDS= uim:${PORTSDIR}/textproc/uim
MASTERDIR= ${.CURDIR}/../../textproc/uim
PKGDIR= ${.CURDIR}

View File

@ -1,16 +1,12 @@
# New ports collection makefile for: uim-gtk3
# Date created: 6 August 2011
# Whom: MANTANI Nobutaka <nobutaka@FreeBSD.org>
#
# Created by: MANTANI Nobutaka <nobutaka@FreeBSD.org>
# $FreeBSD$
#
PKGNAMESUFFIX= -gtk3
COMMENT= GTK+ 3.x modules of uim input method
USE_GNOME= gtk30
LIB_DEPENDS= uim.8:${PORTSDIR}/textproc/uim
LIB_DEPENDS= uim:${PORTSDIR}/textproc/uim
MASTERDIR= ${.CURDIR}/../../textproc/uim
PKGDIR= ${.CURDIR}

View File

@ -1,15 +1,11 @@
# New ports collection makefile for: uim-kde
# Date created: 10 March 2007
# Whom: MANTANI Nobutaka <nobutaka@FreeBSD.org>
#
# Created by: MANTANI Nobutaka <nobutaka@FreeBSD.org>
# $FreeBSD$
#
PKGNAMESUFFIX= -kde
COMMENT= KDE panel applet of uim input method
LIB_DEPENDS= uim.8:${PORTSDIR}/textproc/uim
LIB_DEPENDS= uim:${PORTSDIR}/textproc/uim
RUN_DEPENDS= uim-pref-qt:${PORTSDIR}/textproc/uim-qt
USE_GCC= 4.2+

View File

@ -1,16 +1,12 @@
# New ports collection makefile for: uim-kde4
# Date created: 26 November 2010
# Whom: MANTANI Nobutaka <nobutaka@FreeBSD.org>
#
# Created by: MANTANI Nobutaka <nobutaka@FreeBSD.org>
# $FreeBSD$
#
PKGNAMESUFFIX= -kde4
COMMENT= KDE4 panel applet of uim input method
BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
LIB_DEPENDS= uim.8:${PORTSDIR}/textproc/uim
LIB_DEPENDS= uim:${PORTSDIR}/textproc/uim
RUN_DEPENDS= uim-pref-qt4:${PORTSDIR}/textproc/uim-qt4
USE_GCC= 4.2+

View File

@ -1,9 +1,5 @@
# New ports collection makefile for: uim-m17nlib
# Date created: 31 August 2003
# Whom: MANTANI Nobutaka <nobutaka@FreeBSD.org>
#
# Created by: MANTANI Nobutaka <nobutaka@FreeBSD.org>
# $FreeBSD$
#
.if defined(WITHOUT_X11)
PKGNAMESUFFIX= -m17nlib-nox11
@ -14,8 +10,8 @@ PKGNAMESUFFIX= -m17nlib
COMMENT= Uim plugin using m17n library input method
BUILD_DEPENDS= m17n-db:${PORTSDIR}/devel/m17n-db
LIB_DEPENDS= m17n.4:${PORTSDIR}/devel/m17n-lib \
uim.8:${PORTSDIR}/textproc/uim
LIB_DEPENDS= m17n:${PORTSDIR}/devel/m17n-lib \
uim:${PORTSDIR}/textproc/uim
RUN_DEPENDS= m17n-db:${PORTSDIR}/devel/m17n-db
.if !defined(WITHOUT_M17NCONTRIB)

View File

@ -1,9 +1,5 @@
# New ports collection makefile for: uim-qt
# Date created: 31 August 2003
# Whom: MANTANI Nobutaka <nobutaka@FreeBSD.org>
#
# Created by: MANTANI Nobutaka <nobutaka@FreeBSD.org>
# $FreeBSD$
#
PKGNAMESUFFIX= -qt
@ -12,7 +8,7 @@ COMMENT= QT modules of uim input method
USE_QT_VER= 3
USE_AUTOTOOLS= libtool
LIB_DEPENDS= uim.8:${PORTSDIR}/textproc/uim
LIB_DEPENDS= uim:${PORTSDIR}/textproc/uim
MASTERDIR= ${.CURDIR}/../../textproc/uim
PKGDIR= ${.CURDIR}

View File

@ -1,15 +1,11 @@
# New ports collection makefile for: uim-qt4
# Date created: 2008-21-08
# Whom: Yamashiro Jun <yamajun@ofug.net>
#
# Created by: Yamashiro Jun <yamajun@ofug.net>
# $FreeBSD$
#
PKGNAMESUFFIX= -qt4
COMMENT= Qt4 modules of uim input method
LIB_DEPENDS= uim.8:${PORTSDIR}/textproc/uim
LIB_DEPENDS= uim:${PORTSDIR}/textproc/uim
USE_QT4= qmake_build moc_build qt3support uic
USE_AUTOTOOLS= libtool

View File

@ -1,12 +1,8 @@
# New ports collection makefile for: uim
# Date created: 31 August 2003
# Whom: MANTANI Nobutaka <nobutaka@FreeBSD.org>
#
# Created by: MANTANI Nobutaka <nobutaka@FreeBSD.org>
# $FreeBSD$
#
PORTNAME= uim
PORTVERSION= 1.8.2
PORTVERSION= 1.8.5
CATEGORIES?= textproc
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
.if !defined(UIM_SLAVE) && defined(WITHOUT_X11)

View File

@ -1,2 +1,2 @@
SHA256 (uim-1.8.2.tar.bz2) = 44c2003179291b3279dae7f911d638418a54910f2b99e58418acc88e10067835
SIZE (uim-1.8.2.tar.bz2) = 6480613
SHA256 (uim-1.8.5.tar.bz2) = f74550b42d22a1e2bbc581039585541f7784eb6652a06ec17aa88bcf5f0f3d58
SIZE (uim-1.8.5.tar.bz2) = 6497675

View File

@ -1,13 +1,16 @@
--- emacs/Makefile.in.orig 2010-08-11 16:30:55.000000000 +0900
+++ emacs/Makefile.in 2010-10-16 19:53:21.000000000 +0900
@@ -846,18 +846,6 @@
--- emacs/Makefile.in.orig 2013-03-31 19:14:02.000000000 +0900
+++ emacs/Makefile.in 2013-05-13 22:11:19.000000000 +0900
@@ -872,21 +872,6 @@
clean-libtool:
-rm -rf .libs _libs
-install-dist_uimel_lispDATA: $(dist_uimel_lisp_DATA)
- @$(NORMAL_INSTALL)
- test -z "$(uimel_lispdir)" || $(MKDIR_P) "$(DESTDIR)$(uimel_lispdir)"
- @list='$(dist_uimel_lisp_DATA)'; test -n "$(uimel_lispdir)" || list=; \
- if test -n "$$list"; then \
- echo " $(MKDIR_P) '$(DESTDIR)$(uimel_lispdir)'"; \
- $(MKDIR_P) "$(DESTDIR)$(uimel_lispdir)" || exit 1; \
- fi; \
- for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
- echo "$$d$$p"; \

View File

@ -400,14 +400,11 @@ share/locale/ko/LC_MESSAGES/uim.mo
%%DATADIR%%/yahoo-jp-key-custom.scm
%%DATADIR%%/yahoo-jp.scm
%%DATADIR%%/zaurus.scm
@dirrm include/libgcroots
@dirrm include/sigscheme
@dirrm include/uim
@dirrm lib/uim/plugin
@dirrm lib/uim
@dirrmtry share/applications
%%PORTDOCS%%@dirrm %%DOCSDIR_JA%%
@dirrm %%DOCSDIR_SIGSCHEME%%
@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/helperdata
@dirrm %%DATADIR%%/lib