patch-aa (Makefile): optionally compile in Kerberos support if MAKE_EBONES

is set in make.conf.
patch-ac (several files): comment out bogus #include <mit-copyright.h> which
doesn't work in our version of Kerberos.
This commit is contained in:
Garrett Wollman 1997-06-17 20:47:15 +00:00
parent e1dc0ffb1e
commit 3ef89b4b4f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=6985
2 changed files with 81 additions and 7 deletions

View File

@ -1,5 +1,6 @@
--- Makefile.ORG Sun Sep 22 20:00:16 1996
+++ Makefile Wed Nov 20 23:03:00 1996
diff -ru orig/Makefile ./Makefile
--- orig/Makefile Sun Sep 22 14:00:16 1996
+++ Makefile Tue Jun 17 16:36:26 1997
@@ -51,11 +51,11 @@
# Where the configuration files live.
RADDB = ./raddb
@ -26,7 +27,32 @@
# Define SRV to hold any combination of server names you'd like to override:
#SRV3 = -DDEFAULT_TACACS_SERVER=\"vms.dns.name\"
@@ -219,12 +219,12 @@
@@ -110,17 +110,21 @@
# radiusd -- the default
#
#--------------------------------------------------------------------------
+.if !defined(MAKE_EBONES)
DEFS = -DHAVE_SETVBUF -DNOSHADOW $(MERIT) $(STUFF)
RADLIBS =
INCS =
+.endif
#
# mkerb
#
#--------------------------------------------------------------------------
-#DEFS = -DHAVE_SETVBUF -DM_KERB -DNOSHADOW $(MERIT) $(STUFF)
-#RADLIBS = /usr/kerberos/lib/libkrb.a /usr/kerberos/lib/libdes.a
-#INCS = -I/usr/kerberos/include
+.if defined(MAKE_EBONES)
+DEFS = -DHAVE_SETVBUF -DM_KERB -DNOSHADOW $(MERIT) $(STUFF)
+RADLIBS = -lkrb -ldes
+INCS = -I/usr/include/kerberosIV
+.endif
#
# akerb
@@ -219,12 +223,12 @@
#
#--------------------------------------------------------------------------
@ -45,7 +71,7 @@
#
# Solaris 2.x
@@ -304,14 +304,17 @@
@@ -304,14 +308,17 @@
#
#--------------------------------------------------------------------------
@ -61,7 +87,7 @@
+CFLAGS += -DRADIUS_DIR=\"${PREFIX}/lib/radius/db\" \
+ -DRADACCT_DIR=\"${PREFIX}/lib/radius/acct\" \
+ -DRADIUS_COMPRESS=\"/usr/bin/gzip\" \
+ $(DEFS)
+ $(DEFS) $(INCS)
+LDFLAGS =
+LIBS = -lcrypt -lcompat
+MOSTUTIL = $(RADCHECK) $(RADPWTST) $(RADPASS) $(DNSCHECK)
@ -71,7 +97,7 @@
#
# AIX 3.2.5 (if using xlc(1) add -D_ALL_SOURCE to CFLAGS below)
#
@@ -604,8 +607,6 @@
@@ -604,8 +611,6 @@
$(MAN_INSDIR)/man5/clients.5
$(INSTALL) $(M) 644 $(O) $(RADOWN) $(G) $(RADGRP) $(MAN)/dictionary.5 \
$(MAN_INSDIR)/man5/dictionary.5
@ -80,7 +106,7 @@
$(INSTALL) $(M) 644 $(O) $(RADOWN) $(G) $(RADGRP) $(MAN)/radius.fsm.5 \
$(MAN_INSDIR)/man5/radius.fsm.5
$(INSTALL) $(M) 644 $(O) $(RADOWN) $(G) $(RADGRP) $(MAN)/users.5 \
@@ -625,17 +626,17 @@
@@ -625,17 +630,17 @@
/bin/mkdir -p $(RADDB_INSDIR) ;\
fi
$(INSTALL) $(M) 660 $(O) $(RADOWN) $(G) $(RADGRP) $(RADDB)/authfile \

48
net/radius/files/patch-ac Normal file
View File

@ -0,0 +1,48 @@
diff -ru orig/src/krb_conf.h ./src/krb_conf.h
--- orig/src/krb_conf.h Tue Jul 18 15:00:20 1995
+++ src/krb_conf.h Tue Jun 17 16:09:47 1997
@@ -22,7 +22,7 @@
#ifndef KRB_CONF_DEFS
#define KRB_CONF_DEFS
-#include <mit-copyright.h>
+/* #include <mit-copyright.h> */
/* Byte ordering */
extern int krbONE;
diff -ru orig/src/krb_get_in_tkt.c ./src/krb_get_in_tkt.c
--- orig/src/krb_get_in_tkt.c Tue Jul 18 15:01:05 1995
+++ src/krb_get_in_tkt.c Tue Jun 17 16:09:47 1997
@@ -16,7 +16,7 @@
#endif /* lint */
-#include <mit-copyright.h>
+/* #include <mit-copyright.h> */
#include <krb.h>
#include <des.h>
diff -ru orig/src/mit_stringtokey.c ./src/mit_stringtokey.c
--- orig/src/mit_stringtokey.c Tue Jul 18 15:01:02 1995
+++ src/mit_stringtokey.c Tue Jun 17 16:10:20 1997
@@ -30,7 +30,7 @@
#endif /* lint */
-#include <mit-copyright.h>
+/* #include <mit-copyright.h> */
#include <stdio.h>
#include <des.h>
/*#include "des_internal.h"*/
diff -ru orig/src/prot.h ./src/prot.h
--- orig/src/prot.h Wed May 22 09:53:11 1996
+++ src/prot.h Tue Jun 17 16:09:47 1997
@@ -13,7 +13,7 @@
* Include file with authentication protocol information.
*/
-#include <mit-copyright.h>
+/* #include <mit-copyright.h> */
#include "krb_conf.h"