- Update to 0.3.2
- Fix missing symbols/libraries at runtime PRs: ports/74878 (TAOKA Fumiyoshi) ports/80624 (Gregory Crosswhite)
This commit is contained in:
parent
b4c2a25f6f
commit
3ed171fe20
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=135554
@ -7,7 +7,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= scipy
|
||||
PORTVERSION= 0.3
|
||||
PORTVERSION= 0.3.2
|
||||
CATEGORIES= science python
|
||||
MASTER_SITES= http://www.scipy.org/download/scipy/src/
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
@ -34,6 +34,7 @@ post-patch:
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-install:
|
||||
@${RMDIR} ${PYTHON_SITELIBDIR}/weave/swig # empty
|
||||
.for dir in ${PYTHON_SITELIBDIR}/gui_thread ${PYTHON_SITELIBDIR}/scipy \
|
||||
${PYTHON_SITELIBDIR}/scipy_base ${PYTHON_SITELIBDIR}/scipy_distutils \
|
||||
${PYTHON_SITELIBDIR}/scipy_test ${PYTHON_SITELIBDIR}/weave
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (SciPy_complete-0.3.tar.gz) = ae6578810bce6d3841919b691e607812
|
||||
SIZE (SciPy_complete-0.3.tar.gz) = 3510718
|
||||
MD5 (SciPy_complete-0.3.2.tar.gz) = 5ae2280ab2c4c653cb0ff8479e81284a
|
||||
SIZE (SciPy_complete-0.3.2.tar.gz) = 3368595
|
||||
|
@ -0,0 +1,15 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- scipy_core/scipy_base/fastumathmodule.c.orig
|
||||
+++ scipy_core/scipy_base/fastumathmodule.c
|
||||
@@ -1,8 +1,8 @@
|
||||
+#include <math.h>
|
||||
#include "Python.h"
|
||||
#include "Numeric/arrayobject.h"
|
||||
#include "Numeric/ufuncobject.h"
|
||||
#include "abstract.h"
|
||||
-#include <math.h>
|
||||
#include "mconf_lite.h"
|
||||
|
||||
/* Fast umath module whose functions do not check for range and domain
|
@ -0,0 +1,16 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- scipy_core/scipy_distutils/system_info.py.orig
|
||||
+++ scipy_core/scipy_distutils/system_info.py
|
||||
@@ -548,8 +548,8 @@
|
||||
lib_dirs = self.get_lib_dirs()
|
||||
info = {}
|
||||
atlas_libs = self.get_libs('atlas_libs',
|
||||
- self._lib_names + ['atlas'])
|
||||
- lapack_libs = self.get_libs('lapack_libs',['lapack'])
|
||||
+ self._lib_names + ['atlas_r'])
|
||||
+ lapack_libs = self.get_libs('lapack_libs',['alapack_r'])
|
||||
atlas = None
|
||||
lapack = None
|
||||
atlas_1 = None
|
@ -7,7 +7,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= scipy
|
||||
PORTVERSION= 0.3
|
||||
PORTVERSION= 0.3.2
|
||||
CATEGORIES= science python
|
||||
MASTER_SITES= http://www.scipy.org/download/scipy/src/
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
@ -34,6 +34,7 @@ post-patch:
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-install:
|
||||
@${RMDIR} ${PYTHON_SITELIBDIR}/weave/swig # empty
|
||||
.for dir in ${PYTHON_SITELIBDIR}/gui_thread ${PYTHON_SITELIBDIR}/scipy \
|
||||
${PYTHON_SITELIBDIR}/scipy_base ${PYTHON_SITELIBDIR}/scipy_distutils \
|
||||
${PYTHON_SITELIBDIR}/scipy_test ${PYTHON_SITELIBDIR}/weave
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (SciPy_complete-0.3.tar.gz) = ae6578810bce6d3841919b691e607812
|
||||
SIZE (SciPy_complete-0.3.tar.gz) = 3510718
|
||||
MD5 (SciPy_complete-0.3.2.tar.gz) = 5ae2280ab2c4c653cb0ff8479e81284a
|
||||
SIZE (SciPy_complete-0.3.2.tar.gz) = 3368595
|
||||
|
@ -0,0 +1,15 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- scipy_core/scipy_base/fastumathmodule.c.orig
|
||||
+++ scipy_core/scipy_base/fastumathmodule.c
|
||||
@@ -1,8 +1,8 @@
|
||||
+#include <math.h>
|
||||
#include "Python.h"
|
||||
#include "Numeric/arrayobject.h"
|
||||
#include "Numeric/ufuncobject.h"
|
||||
#include "abstract.h"
|
||||
-#include <math.h>
|
||||
#include "mconf_lite.h"
|
||||
|
||||
/* Fast umath module whose functions do not check for range and domain
|
@ -0,0 +1,16 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- scipy_core/scipy_distutils/system_info.py.orig
|
||||
+++ scipy_core/scipy_distutils/system_info.py
|
||||
@@ -548,8 +548,8 @@
|
||||
lib_dirs = self.get_lib_dirs()
|
||||
info = {}
|
||||
atlas_libs = self.get_libs('atlas_libs',
|
||||
- self._lib_names + ['atlas'])
|
||||
- lapack_libs = self.get_libs('lapack_libs',['lapack'])
|
||||
+ self._lib_names + ['atlas_r'])
|
||||
+ lapack_libs = self.get_libs('lapack_libs',['alapack_r'])
|
||||
atlas = None
|
||||
lapack = None
|
||||
atlas_1 = None
|
Loading…
Reference in New Issue
Block a user