x11-wm/cage: update to 0.1.1.77
Changes: https://github.com/Hjdskes/cage/compare/v0.1.1...bd961db
This commit is contained in:
parent
56ea0c3808
commit
3ec0eed0a0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=540550
@ -2,10 +2,13 @@
|
||||
|
||||
PORTNAME= cage
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.1.1
|
||||
PORTREVISION= 9
|
||||
DISTVERSION= 0.1.1-77
|
||||
DISTVERSIONSUFFIX= -gbd961db
|
||||
CATEGORIES= x11-wm
|
||||
|
||||
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
|
||||
PATCHFILES+= 70ecdcb02ea0.patch:-p1 # https://github.com/Hjdskes/cage/pull/148
|
||||
|
||||
MAINTAINER= jbeich@FreeBSD.org
|
||||
COMMENT= Wayland kiosk
|
||||
|
||||
@ -14,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
|
||||
wayland-protocols>=1.14:graphics/wayland-protocols \
|
||||
wlroots>=0.6.0:x11-toolkits/wlroots
|
||||
wlroots>=0.9.1:x11-toolkits/wlroots
|
||||
LIB_DEPENDS= libwayland-server.so:graphics/wayland \
|
||||
libwlroots.so:x11-toolkits/wlroots \
|
||||
libxkbcommon.so:x11/libxkbcommon
|
||||
@ -25,12 +28,22 @@ USE_XORG= pixman
|
||||
GH_ACCOUNT= Hjdskes
|
||||
PLIST_FILES= "${MAYBE_SUID}bin/${PORTNAME}"
|
||||
|
||||
OPTIONS_DEFINE= SUID X11
|
||||
OPTIONS_DEFAULT=SUID X11
|
||||
OPTIONS_DEFINE= MANPAGES SUID X11
|
||||
OPTIONS_DEFAULT=MANPAGES SUID X11
|
||||
|
||||
MANPAGES_BUILD_DEPENDS= scdoc>=1.9.2:textproc/scdoc
|
||||
MANPAGES_MESON_ENABLED= man-pages
|
||||
MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz
|
||||
|
||||
SUID_DESC= setuid bit on "${PORTNAME}" binary (required for DRM session)
|
||||
SUID_VARS= MAYBE_SUID="@(,,4755) "
|
||||
|
||||
X11_MESON_TRUE= xwayland
|
||||
|
||||
post-patch:
|
||||
# Extract (snapshot) version from the port instead of meson.build
|
||||
@${REINPLACE_CMD} -i .nogit -e 's/git.found()/false/' \
|
||||
-e '/project_version/s/@0@/${DISTVERSIONFULL}/' \
|
||||
${WRKSRC}/meson.build
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,5 @@
|
||||
TIMESTAMP = 1559584552
|
||||
SHA256 (Hjdskes-cage-v0.1.1_GH0.tar.gz) = 63efbe96cf307381f2bedf9b80153343e255970a70d612515da7dc325dd49478
|
||||
SIZE (Hjdskes-cage-v0.1.1_GH0.tar.gz) = 19947
|
||||
TIMESTAMP = 1593197771
|
||||
SHA256 (Hjdskes-cage-v0.1.1-77-gbd961db_GH0.tar.gz) = 743b9df84289c8bb4405c9d92398927d8f60ce87c75dcd47c543cbee20a7f293
|
||||
SIZE (Hjdskes-cage-v0.1.1-77-gbd961db_GH0.tar.gz) = 24446
|
||||
SHA256 (70ecdcb02ea0.patch) = 2dd0e99d181986c6b2d5e04e89f692e3d77b8bd2a3a08f94cf8a27b38489eb3c
|
||||
SIZE (70ecdcb02ea0.patch) = 2137
|
||||
|
@ -1,41 +0,0 @@
|
||||
https://github.com/Hjdskes/cage/commit/33bb3c818c59
|
||||
https://github.com/Hjdskes/cage/commit/51e6c760da51
|
||||
|
||||
--- cage.c.orig 2019-06-03 17:55:52 UTC
|
||||
+++ cage.c
|
||||
@@ -374,15 +374,6 @@ end:
|
||||
wl_event_source_remove(sigint_source);
|
||||
wl_event_source_remove(sigterm_source);
|
||||
seat_destroy(server.seat);
|
||||
- wlr_server_decoration_manager_destroy(server_decoration_manager);
|
||||
- wlr_xdg_decoration_manager_v1_destroy(xdg_decoration_manager);
|
||||
- wlr_xdg_shell_destroy(xdg_shell);
|
||||
- wlr_idle_inhibit_v1_destroy(server.idle_inhibit_v1);
|
||||
- if (server.idle) {
|
||||
- wlr_idle_destroy(server.idle);
|
||||
- }
|
||||
- wlr_data_device_manager_destroy(data_device_mgr);
|
||||
- wlr_compositor_destroy(compositor);
|
||||
wlr_output_layout_destroy(server.output_layout);
|
||||
/* This function is not null-safe, but we only ever get here
|
||||
with a proper wl_display. */
|
||||
--- output.c.orig 2019-06-03 17:55:52 UTC
|
||||
+++ output.c
|
||||
@@ -207,6 +207,7 @@ handle_output_damage_frame(struct wl_listener *listene
|
||||
}
|
||||
|
||||
if (!needs_frame) {
|
||||
+ wlr_output_rollback(output->wlr_output);
|
||||
wlr_log(WLR_DEBUG, "Output doesn't need frame and isn't damaged");
|
||||
goto buffer_damage_finish;
|
||||
}
|
||||
@@ -386,6 +387,9 @@ handle_new_output(struct wl_listener *listener, void *
|
||||
/* Place the cursor in the center of the screen. */
|
||||
wlr_cursor_warp(server->seat->cursor, NULL, wlr_output->width / 2, wlr_output->height / 2);
|
||||
wlr_output_damage_add_whole(server->output->damage);
|
||||
+
|
||||
+ wlr_output_enable(wlr_output, true);
|
||||
+ wlr_output_commit(wlr_output);
|
||||
}
|
||||
|
||||
void
|
Loading…
Reference in New Issue
Block a user