Add a port of OpenBSD's fsck_ext2fs. This is pseudo-version 2.8, which
means, it is obtained from OpenBSD 2.8. Submitted by: Roman Shterenzon <roman@xpert.com>
This commit is contained in:
parent
b69a21f09e
commit
3eb2c4063c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=35730
@ -35,6 +35,7 @@
|
||||
SUBDIR += flexbackup
|
||||
SUBDIR += fontedit
|
||||
SUBDIR += fortunelock
|
||||
SUBDIR += fsck_ext2fs
|
||||
SUBDIR += gcombust
|
||||
SUBDIR += gkrellm
|
||||
SUBDIR += glload
|
||||
|
25
sysutils/fsck_ext2fs/Makefile
Normal file
25
sysutils/fsck_ext2fs/Makefile
Normal file
@ -0,0 +1,25 @@
|
||||
# New ports collection makefile for: fsck_ext2fs
|
||||
# Date Created: 16 Jul 2000
|
||||
# Whom: Roman Shterenzon <roman@xpert.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= fsck_ext2fs
|
||||
PORTVERSION= 2.8
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ${MASTER_SITE_LOCAL}
|
||||
MASTER_SITE_SUBDIR= alex
|
||||
|
||||
MAINTAINER= roman@xpert.com
|
||||
|
||||
MAN8= fsck_ext2fs.8
|
||||
|
||||
do-build:
|
||||
@cd ${WRKSRC}/fsck_ext2fs && ${SETENV} ${MAKE_ENV} ${MAKE}
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/fsck_ext2fs/fsck_ext2fs ${PREFIX}/sbin
|
||||
${INSTALL_MAN} ${WRKSRC}/fsck_ext2fs/fsck_ext2fs.8 ${PREFIX}/man/man8
|
||||
|
||||
.include <bsd.port.mk>
|
1
sysutils/fsck_ext2fs/distinfo
Normal file
1
sysutils/fsck_ext2fs/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (fsck_ext2fs-2.8.tar.gz) = 2f636589cfbaafd98db90db798eb032b
|
19
sysutils/fsck_ext2fs/files/patch-aa
Normal file
19
sysutils/fsck_ext2fs/files/patch-aa
Normal file
@ -0,0 +1,19 @@
|
||||
--- fsck_ext2fs/main.c.orig Thu Apr 27 02:26:06 2000
|
||||
+++ fsck_ext2fs/main.c Sat Jul 15 11:05:32 2000
|
||||
@@ -56,6 +56,7 @@
|
||||
#include <sys/param.h>
|
||||
#include <sys/time.h>
|
||||
#include <sys/mount.h>
|
||||
+#include <ufs/ufs/ufsmount.h>
|
||||
#include <ufs/ext2fs/ext2fs_dinode.h>
|
||||
#include <ufs/ext2fs/ext2fs.h>
|
||||
#include <fstab.h>
|
||||
@@ -69,6 +70,8 @@
|
||||
#include "fsck.h"
|
||||
#include "extern.h"
|
||||
#include "fsutil.h"
|
||||
+
|
||||
+#define MOUNT_EXT2FS "/sbin/mount_ext2fs"
|
||||
|
||||
int returntosingle;
|
||||
|
10
sysutils/fsck_ext2fs/files/patch-ab
Normal file
10
sysutils/fsck_ext2fs/files/patch-ab
Normal file
@ -0,0 +1,10 @@
|
||||
--- fsck_ext2fs/setup.c.orig Thu Apr 27 02:26:06 2000
|
||||
+++ fsck_ext2fs/setup.c Sat Jul 15 11:06:00 2000
|
||||
@@ -69,6 +69,7 @@
|
||||
#include "fsutil.h"
|
||||
|
||||
#define POWEROF2(num) (((num) & ((num) - 1)) == 0)
|
||||
+#define FS_EXT2FS 17 /* ext2fs */
|
||||
|
||||
void badsb __P((int, char *));
|
||||
int calcsb __P((char *, int, struct m_ext2fs *));
|
16
sysutils/fsck_ext2fs/files/patch-ac
Normal file
16
sysutils/fsck_ext2fs/files/patch-ac
Normal file
@ -0,0 +1,16 @@
|
||||
--- fsck_ext2fs/Makefile.orig Sun Sep 21 13:36:34 1997
|
||||
+++ fsck_ext2fs/Makefile Tue Dec 5 00:49:35 2000
|
||||
@@ -1,11 +1,10 @@
|
||||
# $OpenBSD: Makefile,v 1.6 1997/09/21 11:36:34 deraadt Exp $
|
||||
|
||||
PROG= fsck_ext2fs
|
||||
-MAN= fsck_ext2fs.8
|
||||
+MAN8=
|
||||
SRCS= dir.c inode.c main.c pass1.c pass1b.c pass2.c pass3.c pass4.c \
|
||||
pass5.c fsutil.c setup.c utilities.c# ext2fs_subr.c
|
||||
.PATH: ${.CURDIR}/../../sys/ufs/ext2fs ${.CURDIR}/../fsck
|
||||
-#CFLAGS= -g -I${.CURDIR}/../fsck
|
||||
-CFLAGS+= -I${.CURDIR}/../fsck
|
||||
+CFLAGS+= -I../include -I${.CURDIR}/../fsck
|
||||
|
||||
.include <bsd.prog.mk>
|
1
sysutils/fsck_ext2fs/pkg-comment
Normal file
1
sysutils/fsck_ext2fs/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
Ext2fs filesystem consistency check and interactive repair
|
10
sysutils/fsck_ext2fs/pkg-descr
Normal file
10
sysutils/fsck_ext2fs/pkg-descr
Normal file
@ -0,0 +1,10 @@
|
||||
Second Extended File System consistency check and interactive repair
|
||||
|
||||
Performs interactive filesystem consistency checks and repair for each of
|
||||
the filesystems specified on the command line.
|
||||
|
||||
Ported from OpenBSD 2.8
|
||||
|
||||
WWW: http://www.openbsd.org/
|
||||
|
||||
- Roman Shterenzon <roman@xpert.com>
|
1
sysutils/fsck_ext2fs/pkg-plist
Normal file
1
sysutils/fsck_ext2fs/pkg-plist
Normal file
@ -0,0 +1 @@
|
||||
sbin/fsck_ext2fs
|
Loading…
Reference in New Issue
Block a user