Link to OpenGL libraries earlier to avoid crash with Nvidia's libGL

PR:		215803
Submitted by:	Christian Zigotzky <chzigotzky@xenosoft.de>
This commit is contained in:
Ganael LAPLANCHE 2017-01-16 21:11:08 +00:00
parent 82eaa2decc
commit 3ea4191a36
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=431702
2 changed files with 14 additions and 1 deletions

View File

@ -3,7 +3,7 @@
PORTNAME= dolphin-emu
PORTVERSION= 5.0
PORTREVISION= 3
PORTREVISION= 4
CATEGORIES= emulators
MAINTAINER= martymac@FreeBSD.org

View File

@ -0,0 +1,13 @@
Link to OpenGL libraries earlier to avoid crash with Nvidia's libGL
--- Source/Core/Common/CMakeLists.txt.orig 2016-06-24 08:09:07.000000000 +0000
+++ Source/Core/Common/CMakeLists.txt 2017-01-12 20:59:59.578506000 +0000
@@ -88,7 +88,7 @@
set(SRCS ${SRCS} GL/GLInterface/GLX.cpp)
# GLX has a hard dependency on libGL.
# Make sure to link to it if using GLX.
- set(LIBS ${LIBS} ${OPENGL_LIBRARIES})
+ set(LIBS ${OPENGL_LIBRARIES} ${LIBS})
endif()
set(SRCS ${SRCS} GL/GLInterface/X11_Util.cpp)
set(LIBS ${LIBS} ${XRANDR_LIBRARIES})