- Update gxine to 0.5.8.

- Add LIRC option (default off).

PR:		ports/105201
Submitted by:	Max Brazhnikov <makc@issp.ac.ru> (maintainer)
This commit is contained in:
Alejandro Pulver 2006-11-06 19:26:14 +00:00
parent 3be0486ea7
commit 3e84676b52
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=176638
10 changed files with 76 additions and 46 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= gxine
PORTVERSION= 0.5.7
PORTREVISION= 1
PORTVERSION= 0.5.8
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= xine
@ -15,7 +14,8 @@ MASTER_SITE_SUBDIR= xine
MAINTAINER= makc@issp.ac.ru
COMMENT= An alternative GUI for the Xine media player
LIB_DEPENDS= xine.15:${PORTSDIR}/multimedia/libxine
LIB_DEPENDS= xine.15:${PORTSDIR}/multimedia/libxine \
dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
USE_BZIP2= yes
USE_AUTOTOOLS= libtool:15
@ -23,7 +23,7 @@ USE_GNOME= gtk20 gnomehier
USE_GMAKE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -I${X11BASE}/lib"
CONFIGURE_ARGS= --mandir=${PREFIX}/man
CONFIGURE_ARGS+=--mandir=${PREFIX}/man --with-dbus
CFLAGS= -O2 -fno-strict-aliasing -pipe
INSTALLS_ICONS= yes
@ -31,7 +31,8 @@ MANLANG= "" de
MAN1= gxine.1 gxine_client.1
MANCOMPRESSED= no
OPTIONS= MOZILLA_PLUGIN "Install Mozilla plugin" on
OPTIONS= MOZILLA_PLUGIN "Install Mozilla plugin" on \
LIRC "Enable lirc support" off
.include <bsd.port.pre.mk>
.if defined(WITHOUT_NLS)
@ -42,17 +43,30 @@ USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif
.if defined(WITH_LIRC)
LIB_DEPENDS+= lirc_client.0:${PORTSDIR}/comms/lirc
CONFIGURE_ARGS+= --enable-lirc
.else
CONFIGURE_ARGS+= --disable-lirc
.endif
.if defined(WITHOUT_MOZILLA_PLUGIN)
LIB_DEPENDS+= js.1:${PORTSDIR}/lang/spidermonkey
CONFIGURE_ARGS+=--without-browser-plugin
PLIST_SUB+= MOZILLA_PLUGIN="@comment "
.else
USE_GECKO= firefox mozilla seamonkey xulrunner firefox-devel
USE_GECKO= firefox mozilla xulrunner firefox15
.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
LIB_DEPENDS+= nspr4.1:${PORTSDIR}/devel/nspr
CONFIGURE_ARGS+=--disable-libjs
CFLAGS+= -I${LOCALBASE}/include/nspr
PLIST_SUB+= MOZILLA_PLUGIN=""
.endif
post-patch:
@${REINPLACE_CMD} -e "s|firefox/nspr/||g" \
${WRKSRC}/configure
post-install:
.if !defined(WITHOUT_MOZILLA_PLUGIN)
@${MKDIR} ${PREFIX}/lib/browser_plugins

View File

@ -1,3 +1,3 @@
MD5 (gxine-0.5.7.tar.bz2) = 61585b08f699a33528749be101fe8a87
SHA256 (gxine-0.5.7.tar.bz2) = 08f9da823bf87ce9a7beae6938ab2e5405004bb85f97ba49e3a2a1738ec0520c
SIZE (gxine-0.5.7.tar.bz2) = 964963
MD5 (gxine-0.5.8.tar.bz2) = e6bc2be9c6b3a13a101d462b2034b035
SHA256 (gxine-0.5.8.tar.bz2) = ee62e0934bf63a2ed22dc2059ae73aadb192b14307ecf69cb9b49d329c4fe271
SIZE (gxine-0.5.8.tar.bz2) = 1014295

View File

@ -1,11 +0,0 @@
--- src/engine.c.orig Fri Jun 30 18:56:00 2006
+++ src/engine.c Tue Jul 11 01:36:59 2006
@@ -36,7 +36,7 @@
se_t *gse; /* global script engine */
xine_t *xine; /* global xine instance */
-pthread_mutex_t engine_lock = PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP;
+pthread_mutex_t engine_lock = PTHREAD_MUTEX_INITIALIZER;
gboolean initialised = FALSE;

View File

@ -1,12 +0,0 @@
--- src/http.c.orig Thu Jun 29 04:35:39 2006
+++ src/http.c Tue Jul 11 00:54:35 2006
@@ -35,6 +35,9 @@
#include <ctype.h>
#include <errno.h>
+#include <netinet/in.h>
+#include <arpa/inet.h>
+#define IPPROTO_TCP 6
#include "http.h"
#include "utils.h"

View File

@ -1,11 +0,0 @@
--- src/script_engine.c.orig Thu Jun 15 17:13:25 2006
+++ src/script_engine.c Tue Jul 11 00:38:49 2006
@@ -1554,7 +1554,7 @@
pthread_mutexattr_t attr;
pthread_mutexattr_init (&attr);
- pthread_mutexattr_settype (&attr, PTHREAD_MUTEX_RECURSIVE_NP);
+ pthread_mutexattr_settype (&attr, PTHREAD_MUTEX_RECURSIVE);
pthread_mutex_init (&se->lock, &attr);
pthread_mutexattr_destroy (&attr);

View File

@ -1,5 +1,5 @@
--- src/desktop_integration.c.orig Thu Jun 8 18:15:59 2006
+++ src/desktop_integration.c Tue Jul 11 00:35:11 2006
--- src/desktop_integration.c.orig
+++ src/desktop_integration.c
@@ -31,7 +31,6 @@
#include <stdlib.h>
#include <stdio.h>

View File

@ -0,0 +1,10 @@
--- src/engine.c.orig
+++ src/engine.c
@@ -33,6 +33,7 @@
#include "engine.h"
#include "ui.h"
#include "utils.h"
+#define PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP PTHREAD_MUTEX_INITIALIZER
se_t *gse; /* global script engine */
xine_t *xine; /* global xine instance */

View File

@ -0,0 +1,13 @@
--- src/http.c.orig
+++ src/http.c
@@ -38,6 +38,10 @@
#include "http.h"
#include "utils.h"
+#include <netinet/in.h>
+#include <arpa/inet.h>
+#define IPPROTO_TCP 6
+
/*
#define LOG
*/

View File

@ -0,0 +1,10 @@
--- src/script_engine.c.orig
+++ src/script_engine.c
@@ -54,6 +54,7 @@
#include "snapshot.h"
#include "engine.h"
#include "history.h"
+#define PTHREAD_MUTEX_RECURSIVE_NP PTHREAD_MUTEX_RECURSIVE
/*
#define LOG
*/

View File

@ -20,7 +20,7 @@ share/applications/gxine.desktop
%%DATADIR%%/pixmaps/set-volume.svg
%%DATADIR%%/pixmaps/speaker.png
%%DATADIR%%/pixmaps/splash.png
share/icons/hicolor/48x48/apps/gxine.png
share/icons/hicolor/64x64/apps/gxine.png
%%NLS%%share/locale/cs/LC_MESSAGES/gxine.mo
%%NLS%%share/locale/cs/LC_MESSAGES/gxine.theme.mo
%%NLS%%share/locale/de/LC_MESSAGES/gxine.mo
@ -29,6 +29,8 @@ share/icons/hicolor/48x48/apps/gxine.png
%%NLS%%share/locale/fr/LC_MESSAGES/gxine.theme.mo
%%NLS%%share/locale/it/LC_MESSAGES/gxine.mo
%%NLS%%share/locale/it/LC_MESSAGES/gxine.theme.mo
%%NLS%%share/locale/ja/LC_MESSAGES/gxine.mo
%%NLS%%share/locale/ja/LC_MESSAGES/gxine.theme.mo
%%NLS%%share/locale/pl/LC_MESSAGES/gxine.mo
%%NLS%%share/locale/pl/LC_MESSAGES/gxine.theme.mo
%%NLS%%share/locale/ru/LC_MESSAGES/gxine.mo
@ -40,6 +42,21 @@ share/icons/hicolor/48x48/apps/gxine.png
%%NLS%%share/locale/zh_CN/LC_MESSAGES/gxine.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/gxine.theme.mo
share/pixmaps/gxine.png
@dirrmtry share/pixmaps
%%NLS%%@dirrmtry share/locale/zh_CN/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/zh_CN
%%NLS%%@dirrmtry share/locale/uk/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/uk
%%NLS%%@dirrmtry share/locale/sq/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/sq
%%NLS%%@dirrmtry share/locale/pl/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/pl
%%NLS%%@dirrmtry share/locale/cs/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/cs
@dirrmtry share/icons/hicolor/64x64/apps
@dirrmtry share/icons/hicolor/64x64
@dirrmtry share/icons/hicolor
@dirrmtry share/icons
@dirrm %%DATADIR%%/pixmaps
@dirrm %%DATADIR%%
@dirrmtry share/applications