o Drop PERL in favor of REINPLACE_CMD

o Turn patch into a Makefile regexp
o CC/CFLAGS safeness fixes
o libjpeg is not needed as dependency

Submitted by:	maintainer
This commit is contained in:
Mario Sergio Fujikawa Ferreira 2002-09-03 04:01:28 +00:00
parent 8668e16e82
commit 3e5ddbe2f3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=65527
2 changed files with 11 additions and 19 deletions

View File

@ -12,22 +12,26 @@ MASTER_SITES= http://www-2.cs.cmu.edu/~spot/cache/
MAINTAINER= dyeske@yahoo.com
LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
RUN_DEPENDS= xloadimage:${PORTSDIR}/x11/xloadimage \
xsetbg:${PORTSDIR}/graphics/xli \
curl:${PORTSDIR}/ftp/curl
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
pre-patch:
@${PERL} -pi -e 's|/usr/include/X11|${X11BASE}/include|g; \
s|/usr/lib/libjpeg.so.62|${LOCALBASE}/lib/libjpeg.so|g;' \
${WRKSRC}/video_out/Makefile
USE_REINPLACE= yes
post-patch:
@${PERL} -pi -e 's|/usr/local/share|${PREFIX}/share/electricsheep|g;' \
@${REINPLACE_CMD} -e 's|/usr/local/share|${PREFIX}/share/electricsheep|g; \
s|setpgrp()|setpgrp(getpid(), getpid())|g' \
${WRKSRC}/electricsheep.c
@${REINPLACE_CMD} -e 's|/usr/include/X11|${X11BASE}/include|g; \
s|-I/usr/include||g; \
s|gcc|${CC}|g; \
s|^CC|#CC|g; \
s|/usr/lib/libjpeg.so.62||g' \
${WRKSRC}/video_out/Makefile
@${REINPLACE_CMD} -e 's|^CFLAGS =|CFLAGS +=|g' \
${WRKSRC}/flame/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/electricsheep ${PREFIX}/bin

View File

@ -1,12 +0,0 @@
$FreeBSD$
--- electricsheep.c.orig Tue Jul 3 14:55:00 2001
+++ electricsheep.c Tue Feb 12 12:58:42 2002
@@ -1223,7 +1223,7 @@
/* create our own group so all workers/children may be killed together
without hassle */
- if (-1 == setpgrp())
+ if (-1 == setpgrp(getpid(), getpid()))
perror("setpgrp");
signal(SIGTERM, handle_sig_term);
signal(SIGINT, handle_sig_term);