Support stage

Bump portrevision, own of installed files as changed
This commit is contained in:
Baptiste Daroussin 2014-03-30 14:44:32 +00:00
parent 5198159578
commit 3e47031cc3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=349626
3 changed files with 24 additions and 42 deletions

View File

@ -3,6 +3,7 @@
PORTNAME= afm
PORTVERSION= 1.0
PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= ftp://ftp.sgi.com/sgi/fax/source/
DISTNAME= afm
@ -11,12 +12,8 @@ EXTRACT_SUFX= -tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= Adobe Font Metrics
NO_STAGE= yes
NO_BUILD= yes
pre-patch:
@${RM} -rf ${WRKSRC}/RCS
do-build:
@${TRUE}
.include <bsd.port.mk>

View File

@ -0,0 +1,22 @@
--- ./Makefile.orig 1993-04-19 01:07:07.000000000 +0200
+++ ./Makefile 2014-03-30 16:43:16.320680044 +0200
@@ -36,8 +36,8 @@
# lptops program expects them to reside in files without a ".afm"
# suffix.
#
-DEPTH=..
-include ${DEPTH}/defs
+AFMDIR=${PREFIX}/lib/afm
+INSTALL=install
AFMFILES=\
AvantGarde-Book.afm \
@@ -80,6 +80,7 @@
${NULL}
install: ${AFMFILES}
+ [ -d ${DESTDIR}${AFMDIR} ] || mkdir ${DESTDIR}${AFMDIR}
for i in ${AFMFILES}; do \
- ${INSTALL} -F ${AFMDIR} -m 444 -src $$i -O `basename $$i .afm`; \
+ ${INSTALL} -c -m 444 $$i ${DESTDIR}${AFMDIR}/`basename $$i .afm`; \
done

View File

@ -1,37 +0,0 @@
*** Makefile Sun Apr 18 16:07:07 1993
--- ../../Makefile.new Wed Nov 23 06:42:43 1994
***************
*** 36,43 ****
# lptops program expects them to reside in files without a ".afm"
# suffix.
#
! DEPTH=..
! include ${DEPTH}/defs
AFMFILES=\
AvantGarde-Book.afm \
--- 36,43 ----
# lptops program expects them to reside in files without a ".afm"
# suffix.
#
! AFMDIR=${PREFIX}/lib/afm
! INSTALL=install
AFMFILES=\
AvantGarde-Book.afm \
***************
*** 80,85 ****
${NULL}
install: ${AFMFILES}
for i in ${AFMFILES}; do \
! ${INSTALL} -F ${AFMDIR} -m 444 -src $$i -O `basename $$i .afm`; \
done
--- 80,86 ----
${NULL}
install: ${AFMFILES}
+ [ -d ${AFMDIR} ] || mkdir ${AFMDIR}
for i in ${AFMFILES}; do \
! ${INSTALL} -c -o bin -g bin -m 444 $$i ${AFMDIR}/`basename $$i .afm`; \
done