add wget+ipv6, a bit old wget but capable to speak IPv6.

Due to radical development of wget, KAME patch would always not be released
in short. This port will happily retire when wget aquires ability to speak
IPv6 itself.
This commit is contained in:
FUJISHIMA Satsuki 2001-12-17 05:15:58 +00:00
parent a2c3ef380a
commit 3e081cd251
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=51647
9 changed files with 136 additions and 0 deletions

View File

@ -58,6 +58,7 @@
SUBDIR += vcheck
SUBDIR += vsftpd
SUBDIR += wget
SUBDIR += wget+ipv6
SUBDIR += wu-ftpd
SUBDIR += xrmftp
SUBDIR += yafc

60
ftp/wget+ipv6/Makefile Normal file
View File

@ -0,0 +1,60 @@
# Ports collection makefile for: wget+ipv6
# Date created: 17 Dec 2001
# Whom: FUJISHIMA Satsuki <sf@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= wget
PORTVERSION= 1.7
CATEGORIES= ftp www ipv6
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.dl.ac.uk/ccp14/ftp-mirror/wget/pub/unix/util/wget/ \
ftp://ftp.informatik.hu-berlin.de/gnu/wget/ \
ftp://ftp.uni-mainz.de/pub/gnu/wget/ \
ftp://ftp.max.irk.ru/unix/net/www/wget/
MASTER_SITE_SUBDIR= wget
PKGNAMESUFFIX= +ipv6
PATCH_SITES= ftp://ftp.kame.net/pub/kame/misc/ \
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/kame/misc/&,}
PATCHFILES= wget-17-v6-20010716a.diff.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= sf@FreeBSD.org
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
BUILD_DEPENDS= giconv:${PORTSDIR}/converters/libiconv
.if !defined(WITHOUT_SSL)
USE_OPENSSL= yes
CONFIGURE_ARGS= --with-ssl=${OPENSSLBASE}
.endif
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
LIBS=-L${LOCALBASE}/lib
MAN1= wget.1
post-patch:
# made by broken KAME patch. Already contacted.
@${RM} -f ${WRKSRC}/po/zh.po*
# we don't need to run autoconf.
${TOUCH} ${WRKSRC}/configure
# convert utf-8 to Big5 for FreeBSD's default old fashioned gettext.
(cd ${WRKSRC}; \
${MV} po/zh_TW.po po/zh_TW.po.utf-8; \
${LOCALBASE}/bin/giconv -f UTF-8 -t BIG5 po/zh_TW.po.utf-8 |\
${SED} -e 's/utf-8/big5/' |\
${PERL} -p -e 's{([\x81-\xfe])\\}{$$1\\\\}g' |\
${PERL} -p -e 's,\\\\([nt\"]),\\$$1,g' \
> po/zh_TW.po)
pre-build:
@${RM} -f ${WRKSRC}/doc/wget.info*
post-install:
install-info ${PREFIX}/info/wget.info ${PREFIX}/info/dir
.include <bsd.port.mk>

2
ftp/wget+ipv6/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (wget-1.7.tar.gz) = c911a6b937c0a18757d3211fb62831de
MD5 (wget-17-v6-20010716a.diff.gz) = 95664b130be966834f7770d66d03654b

View File

@ -0,0 +1,11 @@
--- doc/Makefile.in.orig Sun Dec 31 14:07:09 2000
+++ doc/Makefile.in Mon Jan 15 04:52:47 2001
@@ -22,7 +22,7 @@
SHELL = /bin/sh
# Program to format Texinfo source into Info files.
-MAKEINFO = @MAKEINFO@
+MAKEINFO = @MAKEINFO@ --no-split
# Program to format Texinfo source into DVI files.
TEXI2DVI = texi2dvi
# Program to convert DVI files to PostScript

View File

@ -0,0 +1,11 @@
--- src/host.c.orig Thu Aug 9 10:11:56 2001
+++ src/host.c Thu Aug 9 10:12:27 2001
@@ -106,7 +106,7 @@
hp = gethostbyname2(name, af);
if (!hp) {
- if (inet_pton(af, name, addr) != -1) {
+ if (inet_pton(af, name, addr) == 1) {
switch (af) {
case AF_INET:
socksize = sizeof (struct sockaddr_in);

View File

@ -0,0 +1,21 @@
--- src/retr.c.orig Wed Feb 9 00:18:45 2000
+++ src/retr.c Wed Feb 9 00:18:51 2000
@@ -445,7 +445,7 @@
recursive_reset ();
for (cur_url = url_list; cur_url; cur_url = cur_url->next, ++*count)
{
- char *filename, *new_file;
+ char *filename, *new_file, *referer;
int dt;
if (opt.quota && opt.downloaded > opt.quota)
@@ -453,7 +453,8 @@
status = QUOTEXC;
break;
}
- status = retrieve_url (cur_url->url, &filename, &new_file, NULL, &dt);
+ referer = getenv("referer");
+ status = retrieve_url (cur_url->url, &filename, &new_file, referer, &dt);
if (opt.recursive && status == RETROK && (dt & TEXTHTML))
status = recursive_retrieve (filename, new_file ? new_file : cur_url->url);

View File

@ -0,0 +1 @@
Retrieve files from the 'net via HTTP and FTP with IPv6 capability

3
ftp/wget+ipv6/pkg-descr Normal file
View File

@ -0,0 +1,3 @@
wget+ipv6 is wget with IPv6 capability by KAME patch.
WWW: http://sunsite.auc.dk/wget/

26
ftp/wget+ipv6/pkg-plist Normal file
View File

@ -0,0 +1,26 @@
bin/wget
etc/wgetrc
@unexec install-info --delete %D/info/wget.info %D/info/dir
info/wget.info
@exec install-info %D/info/wget.info %D/info/dir
share/locale/cs/LC_MESSAGES/wget.mo
share/locale/da/LC_MESSAGES/wget.mo
share/locale/de/LC_MESSAGES/wget.mo
share/locale/el/LC_MESSAGES/wget.mo
share/locale/es/LC_MESSAGES/wget.mo
share/locale/et/LC_MESSAGES/wget.mo
share/locale/fr/LC_MESSAGES/wget.mo
share/locale/gl/LC_MESSAGES/wget.mo
share/locale/hr/LC_MESSAGES/wget.mo
share/locale/it/LC_MESSAGES/wget.mo
share/locale/ja/LC_MESSAGES/wget.mo
share/locale/nl/LC_MESSAGES/wget.mo
share/locale/no/LC_MESSAGES/wget.mo
share/locale/pl/LC_MESSAGES/wget.mo
share/locale/pt_BR/LC_MESSAGES/wget.mo
share/locale/ru/LC_MESSAGES/wget.mo
share/locale/sk/LC_MESSAGES/wget.mo
share/locale/sl/LC_MESSAGES/wget.mo
share/locale/sv/LC_MESSAGES/wget.mo
share/locale/tr/LC_MESSAGES/wget.mo
share/locale/zh_TW/LC_MESSAGES/wget.mo