add nic 0.0.2.011230
Nic is a set of small web-based network applications PR: 33359 Submitted by: Thierry Thomas <thierry@thomas.as>
This commit is contained in:
parent
f59cb6af19
commit
3e05a4d231
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=61808
@ -289,6 +289,7 @@
|
||||
SUBDIR += nettest
|
||||
SUBDIR += ngrep
|
||||
SUBDIR += ngrep-lib
|
||||
SUBDIR += nic
|
||||
SUBDIR += nocol
|
||||
SUBDIR += ns
|
||||
SUBDIR += nsc
|
||||
|
66
net/nic/Makefile
Normal file
66
net/nic/Makefile
Normal file
@ -0,0 +1,66 @@
|
||||
# Ports collection makefile for: Nic
|
||||
# Date created: Sun Dec 30, 2001
|
||||
# Whom: Thierry Thomas (<thierry@pompo.net>)
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= nic
|
||||
PORTVERSION= 0.0.2.011230
|
||||
CATEGORIES= net www
|
||||
MASTER_SITES= http://pompo.net/horde/nic/
|
||||
|
||||
MAINTAINER= thierry@pompo.net
|
||||
|
||||
RUN_DEPENDS= ${LOCALBASE}/www/horde/index.php:${PORTSDIR}/www/horde2
|
||||
|
||||
NO_BUILD= yes
|
||||
|
||||
USE_REINPLACE= yes
|
||||
|
||||
DOCS= LICENSE README docs/CHANGES docs/CREDITS docs/INSTALL
|
||||
CONFFILE= conf.php html.php menu.php
|
||||
|
||||
LHORDEDIR?= www/horde
|
||||
LNICDIR?= ${LHORDEDIR}/nic
|
||||
|
||||
PLIST_SUB= HORDEDIR=${LHORDEDIR} NICDIR=${LNICDIR}
|
||||
|
||||
HORDEDIR= ${PREFIX}/${LHORDEDIR}
|
||||
NICDIR= ${PREFIX}/${LNICDIR}
|
||||
CONFDIR= ${NICDIR}/config
|
||||
|
||||
HORDE_INC= ${LOCALBASE}/etc/horde
|
||||
|
||||
do-install:
|
||||
@${MKDIR} ${NICDIR}
|
||||
@${CP} -Rp ${WRKSRC}/config ${WRKSRC}/graphics ${WRKSRC}/lib ${NICDIR}
|
||||
@${CP} -Rp ${WRKSRC}/templates ${NICDIR}
|
||||
@${CP} -p ${WRKSRC}/*.php ${NICDIR}
|
||||
.for FILE in ${CONFFILE}
|
||||
@if [ ! -f ${CONFDIR}/${FILE} ]; then \
|
||||
${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
|
||||
fi
|
||||
.endfor
|
||||
@${CHOWN} -R www:www ${NICDIR}
|
||||
@${CHMOD} -R o-rwx ${CONFDIR}
|
||||
@${CP} -p ${FILESDIR}/httpd.conf.nic ${HORDE_INC}
|
||||
@${REINPLACE_CMD} -e "s:/home/httpd/html/horde/nic:${NICDIR}:g" \
|
||||
${HORDE_INC}/httpd.conf.nic
|
||||
@${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTNIC::" \
|
||||
${HORDEDIR}/config/registry.php
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
.for FILE in ${DOCS}
|
||||
@${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
|
||||
.endfor
|
||||
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
@${ECHO_MSG}
|
||||
@${CAT} ${PKGMESSAGE} | \
|
||||
${SED} -e "s:%%NICDIR%%:${NICDIR}:g;s:%%CONFDIR%%:${CONFDIR}:g"
|
||||
@${ECHO_MSG}
|
||||
|
||||
.include <bsd.port.mk>
|
1
net/nic/distinfo
Normal file
1
net/nic/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (nic-0.0.2.011230.tar.gz) = ce4fa57fedf482dc020308d0730952f6
|
19
net/nic/files/httpd.conf.nic
Normal file
19
net/nic/files/httpd.conf.nic
Normal file
@ -0,0 +1,19 @@
|
||||
# This is included in Apache's httpd.conf for Nic
|
||||
#
|
||||
# For security, don't serve pages from the Nic configuration and
|
||||
# library directories.
|
||||
#
|
||||
<Directory "/home/httpd/html/horde/nic/config">
|
||||
order deny,allow
|
||||
deny from all
|
||||
</Directory>
|
||||
<Directory "/home/httpd/html/horde/nic/lib">
|
||||
order deny,allow
|
||||
deny from all
|
||||
</Directory>
|
||||
<Directory "/home/httpd/html/horde/nic/templates">
|
||||
order deny,allow
|
||||
deny from all
|
||||
</Directory>
|
||||
# End of Nic configuration ================
|
||||
|
36
net/nic/files/patch-icq.php
Normal file
36
net/nic/files/patch-icq.php
Normal file
@ -0,0 +1,36 @@
|
||||
--- icq.php.orig Mon Oct 15 23:12:21 2001
|
||||
+++ icq.php Mon Dec 31 00:37:35 2001
|
||||
@@ -17,10 +17,10 @@
|
||||
|
||||
$uin = Horde::getFormData('uin');
|
||||
$results="";
|
||||
+$email_next=false;
|
||||
if (!empty($uin)) {
|
||||
- $fd = fopen("http://wwp.icq.com/$uin", 'r');
|
||||
+ $fd = fopen("http://web.icq.com/wwp?Uin=" . $uin, 'r');
|
||||
while ($buffer = fgetss($fd, 4096)) {
|
||||
-
|
||||
if (ereg('Handle/Nickname:', $buffer)) {
|
||||
// echo ereg_replace('Handle/Nickname:', 'NickName: ', $buffer);
|
||||
// echo "<br>";
|
||||
@@ -34,6 +34,20 @@
|
||||
$results .= ereg_replace('E-Mail', 'Email: ', $buffer);
|
||||
$results .="<br>";
|
||||
}
|
||||
+
|
||||
+ if (ereg('Hello my name is', $buffer)) {
|
||||
+ $results .= ereg_replace('Hello my name is', 'Name:', $buffer);
|
||||
+ $results .="<br>";
|
||||
+ }
|
||||
+
|
||||
+ if ($email_next) {
|
||||
+ $results .= 'Email: ' . $buffer;
|
||||
+ $email_next = false;
|
||||
+ }
|
||||
+ if (ereg('Send me an Email message', $buffer)) {
|
||||
+ $email_next = true;
|
||||
+ }
|
||||
+
|
||||
}
|
||||
fclose($fd);
|
||||
|
11
net/nic/files/patch-ping.php
Normal file
11
net/nic/files/patch-ping.php
Normal file
@ -0,0 +1,11 @@
|
||||
--- ping.php.orig Wed Nov 21 23:17:27 2001
|
||||
+++ ping.php Sun Dec 30 22:05:49 2001
|
||||
@@ -26,7 +26,7 @@
|
||||
$results .= "<br />$ping[$i]\n";
|
||||
}
|
||||
} else {
|
||||
- exec("/bin/ping -c 5 \"$addr\"", $ping);
|
||||
+ exec("/sbin/ping -c 5 \"$addr\"", $ping);
|
||||
|
||||
for ($i = 0; $i < count($ping); $i++) {
|
||||
$results .= "<br />$ping[$i]\n";
|
1
net/nic/pkg-comment
Normal file
1
net/nic/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
Nic is a set of small web-based network applications
|
14
net/nic/pkg-descr
Normal file
14
net/nic/pkg-descr
Normal file
@ -0,0 +1,14 @@
|
||||
NIC is the Horde's suite of simple network utilities.
|
||||
The list of tools includes:
|
||||
|
||||
. Finger
|
||||
. ICQ lookup
|
||||
. DNS lookup
|
||||
. Email address verification
|
||||
. Ping
|
||||
. SMTP open relay checking
|
||||
. Service status
|
||||
. Traceroute
|
||||
. Whois
|
||||
|
||||
WWW: http://horde.org/nic/
|
10
net/nic/pkg-message
Normal file
10
net/nic/pkg-message
Normal file
@ -0,0 +1,10 @@
|
||||
************************************************************************
|
||||
Nic has been installed in %%NICDIR%% with your blank
|
||||
configuration files. It should be available from
|
||||
<URL:http://localhost/horde/>.
|
||||
|
||||
You may tune the configuration files located in
|
||||
%%CONFDIR%%/, specially the files conf.php.
|
||||
|
||||
To protect your configuration files, you have to restart Apache.
|
||||
************************************************************************
|
73
net/nic/pkg-plist
Normal file
73
net/nic/pkg-plist
Normal file
@ -0,0 +1,73 @@
|
||||
%%PORTDOCS%%share/doc/nic/CHANGES
|
||||
%%PORTDOCS%%share/doc/nic/CREDITS
|
||||
%%PORTDOCS%%share/doc/nic/INSTALL
|
||||
%%PORTDOCS%%share/doc/nic/LICENSE
|
||||
%%PORTDOCS%%share/doc/nic/README
|
||||
%%NICDIR%%/config/conf.php
|
||||
%%NICDIR%%/config/conf.php.dist
|
||||
%%NICDIR%%/config/html.php
|
||||
%%NICDIR%%/config/html.php.dist
|
||||
%%NICDIR%%/config/menu.php
|
||||
%%NICDIR%%/config/menu.php.dist
|
||||
%%NICDIR%%/finger.php
|
||||
%%NICDIR%%/graphics/finger.gif
|
||||
%%NICDIR%%/graphics/icq_disabled.gif
|
||||
%%NICDIR%%/graphics/icq_offline.gif
|
||||
%%NICDIR%%/graphics/icq_online.gif
|
||||
%%NICDIR%%/graphics/mailaddrcheck.gif
|
||||
%%NICDIR%%/graphics/nic.gif
|
||||
%%NICDIR%%/graphics/ping.gif
|
||||
%%NICDIR%%/graphics/relay.gif
|
||||
%%NICDIR%%/graphics/services.gif
|
||||
%%NICDIR%%/graphics/whois.gif
|
||||
%%NICDIR%%/icq.php
|
||||
%%NICDIR%%/index.php
|
||||
%%NICDIR%%/lib/Finger.php
|
||||
%%NICDIR%%/lib/NIC.php
|
||||
%%NICDIR%%/lib/base.php
|
||||
%%NICDIR%%/lib/version.php
|
||||
%%NICDIR%%/lookup.php
|
||||
%%NICDIR%%/mailaddrcheck.php
|
||||
%%NICDIR%%/menu.php
|
||||
%%NICDIR%%/nic.php
|
||||
%%NICDIR%%/ping.php
|
||||
%%NICDIR%%/relay.php
|
||||
%%NICDIR%%/services.php
|
||||
%%NICDIR%%/status.php
|
||||
%%NICDIR%%/templates/common-footer.inc
|
||||
%%NICDIR%%/templates/common-header.inc
|
||||
%%NICDIR%%/templates/finger/finger.inc
|
||||
%%NICDIR%%/templates/footer.inc
|
||||
%%NICDIR%%/templates/icq/icq.inc
|
||||
%%NICDIR%%/templates/index/css.inc
|
||||
%%NICDIR%%/templates/index/notconfigured.inc
|
||||
%%NICDIR%%/templates/lookup/lookup.inc
|
||||
%%NICDIR%%/templates/mailaddrcheck/mailaddrcheck.inc
|
||||
%%NICDIR%%/templates/menu/menu.inc
|
||||
%%NICDIR%%/templates/nic_footer.html
|
||||
%%NICDIR%%/templates/nic_frame.html
|
||||
%%NICDIR%%/templates/ping/ping.inc
|
||||
%%NICDIR%%/templates/relay/relay.inc
|
||||
%%NICDIR%%/templates/services/services.inc
|
||||
%%NICDIR%%/templates/traceroute/traceroute.inc
|
||||
%%NICDIR%%/templates/whois/whois.inc
|
||||
%%NICDIR%%/traceroute.php
|
||||
%%NICDIR%%/whois.php
|
||||
etc/horde/httpd.conf.nic
|
||||
@dirrm %%NICDIR%%/config
|
||||
@dirrm %%NICDIR%%/graphics
|
||||
@dirrm %%NICDIR%%/lib
|
||||
@dirrm %%NICDIR%%/templates/finger
|
||||
@dirrm %%NICDIR%%/templates/icq
|
||||
@dirrm %%NICDIR%%/templates/index
|
||||
@dirrm %%NICDIR%%/templates/lookup
|
||||
@dirrm %%NICDIR%%/templates/mailaddrcheck
|
||||
@dirrm %%NICDIR%%/templates/menu
|
||||
@dirrm %%NICDIR%%/templates/ping
|
||||
@dirrm %%NICDIR%%/templates/relay
|
||||
@dirrm %%NICDIR%%/templates/services
|
||||
@dirrm %%NICDIR%%/templates/traceroute
|
||||
@dirrm %%NICDIR%%/templates/whois
|
||||
@dirrm %%NICDIR%%/templates
|
||||
@dirrm %%NICDIR%%
|
||||
%%PORTDOCS%%@dirrm share/doc/nic
|
Loading…
Reference in New Issue
Block a user