- Update to 0.4.0 [1]

- Respect ${CC}, ${CFLAGS}, ${CXX} and ${CXXFLAGS}
- Fix the packing list when ${CXX} != g++
- Use ${PREFIX} rather than /usr/local in pkg-message, and reword it
- Refactor patches as ${REINPLACE_CMD} invocations

[1]:
PR:		ports/84285
Submitted by:	Daniel Blankensteiner <db@trunet.dk>
This commit is contained in:
Jean-Yves Lefort 2005-07-29 16:47:31 +00:00
parent 12b59934e5
commit 3dae5ab198
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=140412
8 changed files with 24 additions and 147 deletions

View File

@ -6,29 +6,34 @@
#
PORTNAME= ccmalloc
PORTVERSION= 0.3.9
PORTREVISION= 2
PORTVERSION= 0.4.0
CATEGORIES= devel
MASTER_SITES= http://www2.inf.ethz.ch/personal/biere/projects/ccmalloc/
MASTER_SITES= http://www.inf.ethz.ch/personal/biere/projects/ccmalloc/
MAINTAINER= ports@FreeBSD.org
COMMENT= C/C++ memory profiler and memory leak tracer
USE_PERL5= yes
USE_REINPLACE= yes
USE_GMAKE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
CC= gcc -g -Wall
CXX= g++
SUB_FILES= pkg-message
PLIST_SUB= CXX="${CXX}"
.include <bsd.port.pre.mk>
.if ${OSVERSION} > 500000
EXTRA_PATCHES= ${FILESDIR}/patch5-configure
post-patch:
@${REINPLACE_CMD} -e 's|CFLAGS=".*"|CFLAGS="${CFLAGS}"|; \
s|CXXFLAGS=".*"|CXXFLAGS="${CXXFLAGS}"|' ${WRKSRC}/configure
.if ${OSVERSION} >= 500000
@${REINPLACE_CMD} -e '/prefix=/ s|expr $$1|expr -- $$1|' \
${WRKSRC}/configure
.endif
@${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/src/ccmalloc.in
post-install:
@${CAT} pkg-message
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

View File

@ -1,2 +1,2 @@
MD5 (ccmalloc-0.3.9.tar.gz) = 9ba598edf3b21acc6a7a6196944f5af7
SIZE (ccmalloc-0.3.9.tar.gz) = 57501
MD5 (ccmalloc-0.4.0.tar.gz) = b90d955149569bbc6e801739f099db3d
SIZE (ccmalloc-0.4.0.tar.gz) = 57917

View File

@ -1,18 +0,0 @@
--- Makefile.in.orig Wed Jan 30 15:27:10 2002
+++ Makefile.in Mon Mar 18 17:39:49 2002
@@ -3,6 +3,7 @@
COMPILERS=@COMPILERS@
TARGETS=lib/libccmalloc.a @TARGETS@ bin/ccmalloc
PREFIX=@PREFIX@
+OPSYS=@OPSYS@
#--------------------------------------------------------------------------#
@@ -43,6 +44,7 @@
-e 's,@''PREFIX@,$(PREFIX),g' \
-e 's,@''COMPILERS@,"$(COMPILERS)",g' \
-e 's,@''VERSION@,@VERSION@,g' \
+ -e 's,@''OPSYS@,@OPSYS@,g' \
src/ccmalloc.in > $@
chmod 755 $@

View File

@ -1,29 +0,0 @@
--- src/ccmalloc.in.orig Wed Jan 30 06:23:55 2002
+++ src/ccmalloc.in Sat Apr 5 02:05:19 2003
@@ -9,6 +9,13 @@
#
COMPILERS=@COMPILERS@
PREFIX=@PREFIX@
+OPSYS=@OPSYS@
+
+case $OPSYS in
+ linux | solaris) COMP_ARGS='-lccmalloc -ldl';;
+ freebsd ) COMP_ARGS='-lccmalloc';;
+ *) COMP_ARGS='-lccmalloc -ldl';;
+esac
usage () {
echo \
@@ -104,10 +111,10 @@
then
wrapper="$PREFIX/lib/ccmalloc-$CC.o"
echo "ccmalloc: using '$wrapper' as C++ wrapper"
- cmd="$args $wrapper -L$PREFIX/lib -lccmalloc -ldl"
+ cmd="$args $wrapper -L$PREFIX/lib $COMP_ARGS"
else
echo "ccmalloc: no C++ wrapper for '$base' installed"
- cmd="$args -L$PREFIX/lib -lccmalloc -ldl"
+ cmd="$args -L$PREFIX/lib $COMP_ARGS"
fi
echo $cmd

View File

@ -1,82 +0,0 @@
--- configure.orig Wed Feb 6 01:20:53 2002
+++ configure Sat Apr 5 04:43:02 2003
@@ -27,7 +27,8 @@
fmt="%-26s ..."
debug=no
prefix=/usr/local
-os=unsupported
+
+OPSYS=unsupported
#--------------------------------------------------------------------------#
# process command line options
@@ -40,7 +41,7 @@
exit 0
;;
--prefix=*)
- prefix=`expr $1 : '--prefix=\(.*\)'`
+ prefix=`expr -- $1 : '--prefix=\(.*\)'`
;;
--debug)
debug=yes
@@ -70,26 +71,26 @@
SunOS )
case `uname -r` in
5.* )
- os=solaris
+ OPSYS=solaris
;;
esac
;;
Linux )
- os=linux
+ OPSYS=linux
;;
FreeBSD )
- os=freebsd
+ OPSYS=freebsd
;;
esac
-if [ $os = unsupported ]
+if [ $OPSYS = unsupported ]
then
echo
echo "*** configure: unsupported operating system" 1>&2
exit 1
fi
-echo " $os"
+echo " $OPSYS"
#--------------------------------------------------------------------------#
# search for C compilers
@@ -205,7 +206,7 @@
}
EOF
-case $os in
+case $OPSYS in
freebsd )
LIB=""
;;
@@ -285,8 +286,9 @@
(
echo "#ifndef _config_h_INCLUDED"
[ $debug = no ] && echo "#define NDEBUG"
-[ $os = solaris ] && echo "#define OS_IS_SOLARIS"
-[ $os = linux ] && echo "#define OS_IS_LINUX"
+[ $OPSYS = solaris ] && echo "#define OS_IS_SOLARIS"
+[ $OPSYS = linux ] && echo "#define OS_IS_LINUX"
+[ $OPSYS = freebsd ] && echo "#define OS_IS_FREEBSD"
[ $atexit = yes ] && echo "#define HAVE_ATEXIT"
cat<<-EOF
#define VERSION "$version"
@@ -319,6 +321,7 @@
-e "s,@COMPILERS@,$COMPILERS,g" \
-e "s,@VERSION@,$version,g" \
-e "s,@TARGETS@,$TARGETS,g" \
+-e "s,@OPSYS@,$OPSYS,g" \
Makefile.in > $dst
echo >> $dst

View File

@ -0,0 +1,7 @@
===============================================================================
You should now copy the sample configuration file
%%DATADIR%%/ccmalloc.cfg
to ~/.ccmalloc and edit it as appropriate.
===============================================================================

View File

@ -1,6 +0,0 @@
Please take a look at sample configuration file:
/usr/local/share/ccmalloc/ccmalloc.cfg
You should edit it and copy it to: ~/.ccmalloc

View File

@ -1,5 +1,5 @@
bin/ccmalloc
lib/libccmalloc.a
lib/ccmalloc-g++.o
lib/ccmalloc-%%CXX%%.o
share/ccmalloc/ccmalloc.cfg
@dirrm share/ccmalloc