Add ruby-libgtop, a Ruby interface to libgtop.
This commit is contained in:
parent
cd086cfba5
commit
3da122d1e9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=41345
@ -390,6 +390,7 @@
|
||||
SUBDIR += ruby-intl
|
||||
SUBDIR += ruby-lapidary
|
||||
SUBDIR += ruby-libglade
|
||||
SUBDIR += ruby-libgtop
|
||||
SUBDIR += ruby-locale
|
||||
SUBDIR += ruby-metaruby
|
||||
SUBDIR += ruby-mmap
|
||||
|
41
devel/ruby-libgtop/Makefile
Normal file
41
devel/ruby-libgtop/Makefile
Normal file
@ -0,0 +1,41 @@
|
||||
# New ports collection makefile for: Ruby_libgtop
|
||||
# Date created: 13 Apr 2001
|
||||
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libgtop
|
||||
PORTVERSION= 0.1.0
|
||||
CATEGORIES= devel ruby
|
||||
MASTER_SITES= http://www.colinsteele.org/
|
||||
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
|
||||
DISTNAME= ruby_${PORTNAME}-${PORTVERSION}
|
||||
EXTRACT_SUFX= .tgz
|
||||
DIST_SUBDIR= ruby
|
||||
|
||||
MAINTAINER= knu@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= gtop.1:${PORTSDIR}/devel/libgtop
|
||||
|
||||
USE_RUBY= yes
|
||||
USE_RUBY_EXTCONF= yes
|
||||
|
||||
INSTALL_TARGET= site-install
|
||||
|
||||
DOCS= ChangeLog README
|
||||
EXAMPLES= test.rb
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
|
||||
.for f in ${EXAMPLES}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
|
||||
.endfor
|
||||
${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
|
||||
.for f in ${DOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
devel/ruby-libgtop/distinfo
Normal file
1
devel/ruby-libgtop/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (ruby/ruby_libgtop-0.1.0.tgz) = f50df5d99fa6a2dc0389ee6296ba645d
|
19
devel/ruby-libgtop/files/patch-extconf.rb
Normal file
19
devel/ruby-libgtop/files/patch-extconf.rb
Normal file
@ -0,0 +1,19 @@
|
||||
--- extconf.rb.orig Fri Apr 13 04:03:18 2001
|
||||
+++ extconf.rb Fri Apr 13 14:57:42 2001
|
||||
@@ -34,12 +34,10 @@
|
||||
######################################################################
|
||||
require "mkmf"
|
||||
|
||||
-dir_config("ruby_libgtop")
|
||||
-have_library("gtop", nil)
|
||||
-have_library("gtop_suid_common", nil)
|
||||
-have_library("gtop_common", nil)
|
||||
-have_library("gtop_names", nil)
|
||||
-have_library("gtop_sysdeps", nil)
|
||||
+libgtop_config = with_config("libgtop-config", "libgtop-config")
|
||||
+
|
||||
+$CFLAGS = `#{libgtop_config} --cflags`.chomp
|
||||
+$LDFLAGS = `#{libgtop_config} --libs`.chomp
|
||||
|
||||
create_makefile("ruby_libgtop")
|
||||
|
1
devel/ruby-libgtop/pkg-comment
Normal file
1
devel/ruby-libgtop/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A Ruby interface to libgtop
|
6
devel/ruby-libgtop/pkg-descr
Normal file
6
devel/ruby-libgtop/pkg-descr
Normal file
@ -0,0 +1,6 @@
|
||||
Ruby_libgtop -- a Ruby interface to the very useful libgtop, a
|
||||
portable library that fetches system related information such as CPU
|
||||
Load, Memory Usage and information about running processes.
|
||||
|
||||
Author: Colin Steele <colin@colinsteele.org>
|
||||
WWW: http://www.colinsteele.org/
|
6
devel/ruby-libgtop/pkg-plist
Normal file
6
devel/ruby-libgtop/pkg-plist
Normal file
@ -0,0 +1,6 @@
|
||||
%%RUBY_SITEARCHLIBDIR%%/ruby_libgtop.so
|
||||
%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/libgtop/test.rb
|
||||
%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/libgtop
|
||||
%%PORTDOCS%%%%RUBY_DOCDIR%%/libgtop/ChangeLog
|
||||
%%PORTDOCS%%%%RUBY_DOCDIR%%/libgtop/README
|
||||
%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/libgtop
|
Loading…
Reference in New Issue
Block a user