Files permissions are being changed by set_default_perms.sh script

in the post-install target, make the permission changes in the
do-install target.

Update the pkg-message.* to no longer refer to the libscrypt.* and
libdescrypt.* libraries.

changed pkg-plist to safely remove the share/doc/apache directory, so
that it doesn't get left behind.

Add to fp_install.sh the ability to setup the Frontpage Server
Administration service.

PR:		53030
Submitted by:	maintainer
Approved by:	edwin (mentor)
This commit is contained in:
Erwin Lansing 2003-06-08 09:53:42 +00:00
parent 8cee6fc334
commit 3d8e1fab4e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=82517
5 changed files with 158 additions and 33 deletions

View File

@ -10,7 +10,7 @@ PORTVERSION= 5.0.2.2623
PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ftp://ftp.microsoft.com/products/frontpage/ \
ftp://www.westbend.net/Mirrors/ftp.microsoft.com/Products/frontpage/
ftp://www.westbend.net/pub/microsoft/frontpage/
DISTFILES= ${FRONTPAGE}
MAINTAINER= hetzels@westbend.net
@ -22,8 +22,7 @@ USE_REINPLACE= yes
ONLY_FOR_ARCHS= i386 alpha
FP_VER= 5.0
#FP_VER= ${PORTVERSION:C/\..*//}
FP_VER= ${PORTVERSION:C|^([0-9]+)\.([0-9]+).*|\1.\2|}
.if ${ARCH} == i386
.ifdef WANT_BSDI_EXT
@ -125,9 +124,9 @@ do-install:
@${CP} ${PREFIX}/${README} ${MOD_FPDOCDIR}/index.html
@${INSTALL_SCRIPT} ${WRKDIR}/${FPINSTALL} ${PREFIX}/${FPINSTALL}
@${INSTALL_SCRIPT} ${WRKDIR}/${FPSETPERM} ${PREFIX}/${FPSETPERM}
@${PREFIX}/${FPSETPERM}
post-install:
@${CAT} ${PKGMESSAGE}
@${PREFIX}/${FPSETPERM}
.include <bsd.port.post.mk>

View File

@ -1,5 +1,5 @@
--- frontpage/version5.0/fp_install.sh.orig Mon Apr 16 07:39:25 2001
+++ frontpage/version5.0/fp_install.sh Tue Feb 12 17:37:58 2002
+++ frontpage/version5.0/fp_install.sh Sat Jun 7 21:00:21 2003
@@ -12,7 +12,7 @@
main() {
initialize
@ -9,7 +9,7 @@
$FPDIR/set_default_perms.sh # Run the external permissions script.
step3 # upgrade/install
@@ -52,7 +52,7 @@
@@ -52,12 +52,13 @@
echo
migrateoldconfig || error # Migrate old frontpage.cnf (if any)
@ -18,22 +18,26 @@
upgradeexistingservers || error # Check to see if servers need upgrading
upgrade="yes"
chownexistingservers || error # Now chown the webs
@@ -132,10 +132,12 @@
handlelanguage || error # configure some global settings
installrootweb || error # Install the root web
+ installadminweb || error # Install the FrontPage Server Administration Web
installnewsubwebs $PORT || error # Install new servers
installvirtualwebs || error # Install any virtual webs
}
@@ -132,9 +133,11 @@
{
VERSION="5.0"
PATH=".:/bin:/usr/bin:/sbin:/usr/sbin:/usr/ucb:/etc:/usr/bsd"
- INSTALLDIRDEFAULT="/usr/local/frontpage"
+ AP_TARGET=`PREFIX/sbin/apxs -q TARGET`
+ AP_CONFDIR=`PREFIX/sbin/apxs -q SYSCONFDIR`
+ INSTALLDIRDEFAULT="PREFIX/frontpage"
INSTALLDIRDEFAULT="/usr/local/frontpage"
NEWHTTPDNEW="/usr/local/frontpage/version${VERSION}/apache-fp/httpd"
DEFAULTHTTPD="/usr/local/apache/sbin/httpd"
- FPDIR="/usr/local/frontpage/version${VERSION}"
+ FPDIR="PREFIX/frontpage/version${VERSION}"
- DEFAULTHTTPD="/usr/local/apache/sbin/httpd"
+ DEFAULTHTTPD="PREFIX/sbin/httpd"
FPDIR="/usr/local/frontpage/version${VERSION}"
case "`echo 'x\c'`" in
'x\c') echo="echo -n" nnl= ;; #BSD
@@ -390,29 +392,9 @@
@@ -390,29 +393,9 @@
{
retval=0
@ -63,7 +67,7 @@
if chmod "$prot" "$installdir"
then
echo "Directory $installdir chmoded to $prot."
@@ -420,22 +402,6 @@
@@ -420,22 +403,6 @@
echo "ERROR: Unable to chmod $installdir to $prot."
retval=1
fi
@ -86,7 +90,7 @@
if [ "$installdir" != "/usr/local/frontpage" ]
then
@@ -805,16 +771,22 @@
@@ -805,16 +772,22 @@
accessconffile="${configfiledir}${file}"
;;
esac
@ -110,7 +114,7 @@
return 1
fi
@@ -1290,20 +1262,30 @@
@@ -1290,20 +1263,30 @@
echo " "
webname="/"
@ -143,7 +147,7 @@
done
getHttpRootDirective $configfile Port
@@ -1316,9 +1298,23 @@
@@ -1316,9 +1299,23 @@
done
weconfigfile="${installdir}/we${port}.cnf"
@ -167,7 +171,7 @@
webowner=""
until [ "$webowner" != "" ]
do
@@ -1333,6 +1329,12 @@
@@ -1333,6 +1330,12 @@
echo
getparam Group $configfile $port "Getting Group from "
defgroup=$param
@ -180,7 +184,127 @@
webgroup=""
until [ "$webgroup" != "" ]
do
@@ -1464,7 +1466,7 @@
@@ -1450,6 +1453,119 @@
return $retval
}
+# Install the FrontPage Server Administration Web
+installadminweb()
+{
+ retval=0
+
+ configfile=""
+ admin=""
+ port=""
+
+ echo
+ echo "Note: If you have not installed FrontPage Server Administration then you should do it now."
+ echo
+ myprompt 'yYnN' "Do you want to install FrontPage Server Administration (y/n)" "Y"
+ if [ $answer = n ] || [ $answer = N ]
+ then
+ echo "You have chosen not to install FrontPage Server Administration. If you wish"
+ echo "to install it later, you will need to use the following command:"
+ echo
+ echo "${FPDIR}/owsadm.exe -o setadminport -p 10865 \\"
+ echo " -s ${AP_CONFDIR}/${AP_TARGET}.conf -u <FP Admin user>"
+ echo
+ echo "The FrontPage Server Administration setup will require the following change"
+ echo "in ${AP_CONFDIR}/${AP_TARGET}.conf for <VirtualHost _default_:10865>:"
+ echo
+ echo " AllowOverride AuthConfig Limit Indexes Options"
+ echo
+ echo "otherwise, the FrontPage Server Administration web will not allow you to login."
+ echo
+ echo "This will then make FrontPage Server Administration available at:"
+ echo
+ echo " http://`hostname`:10865/fpadmcgi.exe"
+ echo
+ return $retval
+ fi
+
+ echo " "
+ echo "Installing FrontPage Server Administration..."
+ echo " "
+
+ defconfigfile="${AP_CONFDIR}/${AP_TARGET}.conf"
+
+ while ( [ "$configfile" = "" ] || [ ! -f $configfile ] )
+ do
+ $echo "Server config filename: [$defconfigfile] ${nnl}"
+ read configfile
+ if [ "$configfile" = "" ]
+ then
+ configfile=$defconfigfile
+ fi
+ done
+ httpdconfigfile=$configfile
+
+ defadmin="fpadmin"
+ until [ "$admin" != "" ]
+ do
+ $echo "FrontPage Server Administration user name: [$defadmin] ${nnl}"
+ read admin
+ if [ "$admin" = "" ]
+ then
+ admin=$defadmin
+ fi
+ done
+
+# Need to determine if the FrontPage Server Administration Web was previously
+# installed and to which port it was installed on.
+
+# getHttpRootDirective $configfile Port
+# port=$param
+
+ defport="10865"
+ until [ "$port" != "" ]
+ do
+ $echo "Enter the FrontPage Server Administration port number: [$defport] ${nnl}"
+ read port
+ if [ "$port" = "" ]
+ then
+ port=$defport
+ fi
+ done
+
+# getHttpRootDirective $configfile DocumentRoot
+# docroot=$param
+# if [ ! -d "$docroot" ]
+# then
+# echo "ERROR: $docroot does not exist!"
+# return 1
+# fi
+
+ echo "Installing FrontPage Server Administration on port $port..."
+ echo
+ ${FPDIR}/bin/owsadm.exe -o setadminport -p $port -s $configfile -u $admin ||
+ {
+ echo "ERROR: FrontPage Server Administration installation failed."
+ $echo "Hit enter to continue${nnl}"
+ read continue
+ return 1
+ }
+ echo
+ echo "FrontPage Server Administration is now available at:"
+ echo
+ echo " http://`hostname`:${port}/fpadmcgi.exe"
+ echo
+ echo "The FrontPage Server Administration setup requires the following change"
+ echo "in ${AP_CONFDIR}/${AP_TARGET}.conf for <VirtualHost _default_:${port}>:"
+ echo
+ echo " AllowOverride AuthConfig Limit Indexes Options"
+ echo
+ echo "otherwise, the FrontPage Server Administration web will not allow you to login."
+ echo
+
+ return $retval
+}
+
# Install a web on a multihosted server
installvirtualwebs()
{
@@ -1464,7 +1580,7 @@
return $retval
fi
@ -189,7 +313,7 @@
configfile=""
while ( [ "$configfile" = "" ] || [ ! -f $configfile ] )
do
@@ -1922,10 +1924,16 @@
@@ -1922,10 +2038,16 @@
resconffile="${configfiledir}${file}"
;;
esac
@ -206,7 +330,7 @@
resconffile=$configfile
fi
fi
@@ -1999,7 +2007,7 @@
@@ -1999,7 +2121,7 @@
param=`cat $configfile | $awk "
/^[^#]* *< *${virtualhost}/,/^[^#]* *< *\/${virtualhost}/ { next }
@ -215,7 +339,7 @@
return 0
}
@@ -2050,7 +2058,7 @@
@@ -2050,7 +2172,7 @@
print ARRAY[i]
}
}

View File

@ -1,7 +1,7 @@
The BSDI FrontPage Extensions require that libcrypt.* be linked to the
libdescrypt.* libraries. The fpsrvadm.exe program can only create DES
passwords, but the Apache server is unable to use them when libcrypt.*
are linked to the libscrypt.* libraries.
The BSDI FrontPage Extensions requires crypt_des is available in the
libcrypt.* libraries. The fpsrvadm.exe program can only create DES
passwords, but the Apache server is unable to use them when crypt_des
is not available in the libscrypt.* libraries.
For this port to be usefull you need to install an Apache-Frontpage
enabled web server. Only the following ports/packages qualifies:

View File

@ -1,7 +1,7 @@
The FreeBSD FrontPage Extensions require that libcrypt.* be linked to the
libdescrypt.* libraries. This is due to a problem with the fpsrvadm.exe
program will create invaild MD5 passwords when libcrypt.* are linked to
the libscrypt.* libraries.
The FreeBSD FrontPage Extensions requires crypt_des is included in
your libcrypt.* libraries. Otherwise the fpsrvadm.exe program will
create invaild MD5 passwords when libcrypt.* doesn't support DES
passwords. Fpsrvadm.exe can only create DES passwords.
For this port to be usefull you need to install an Apache-Frontpage
enabled web server. Only the following ports/packages qualifies:

View File

@ -257,6 +257,8 @@ share/doc/apache/manual/frontpage/index.html
@dirrm frontpage/version%%FP_VER%%/apache-fp
@dirrm frontpage/version%%FP_VER%%/admin/1033
@dirrm frontpage/version%%FP_VER%%/admin
@dirrm frontpage/version%%FP_VER%%
@dirrm frontpage
@unexec rmdir %D/frontpage/version%%FP_VER%% 2> /dev/null || true
@unexec rmdir %D/frontpage 2> /dev/null || true
@dirrm share/doc/apache/manual/frontpage
@unexec rmdir %D/share/doc/apache/manual 2> /dev/null || true
@unexec rmdir %D/share/doc/apache 2> /dev/null || true