- Update MASTER_SITES and WWW: line
- Support CC properly - Convert to USES - Stage support PR: 187042
This commit is contained in:
parent
0a665fd9a1
commit
3d2c911ad8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=346261
@ -5,62 +5,44 @@ PORTNAME= fmars
|
||||
PORTVERSION= 0.0.207
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://users.v-lo.krakow.pl/~michal/
|
||||
MASTER_SITES= http://corewar.co.uk/janeczek/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Fast Memory Array Redcode Simulator
|
||||
|
||||
DEPRECATED= No more public distfiles
|
||||
EXPIRATION_DATE= 2014-03-07
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
BUILD_DEPENDS= guile:${PORTSDIR}/lang/guile
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
|
||||
USES= gmake
|
||||
ALL_TARGET= x${PORTNAME}
|
||||
|
||||
OPTIONS_DEFINE= OPTIMIZED_CFLAGS DOCS
|
||||
OPTIONS_DEFINE= DOCS OPTIMIZED_CFLAGS
|
||||
OPTIONS_DEFAULT= OPTIMIZED_CFLAGS
|
||||
|
||||
NO_STAGE= yes
|
||||
.include <bsd.port.pre.mk>
|
||||
OPTIMIZED_CFLAGS_CFLAGS=-fomit-frame-pointer
|
||||
|
||||
post-patch:
|
||||
# Fix Makefile.
|
||||
@${REINPLACE_CMD} -e 's|\($$(OPT)\)|${CFLAGS} \1| ; \
|
||||
s|gcc|${CC}|g' \
|
||||
${WRKSRC}/${MAKEFILE}
|
||||
|
||||
# Enable/disable compilation optimizations.
|
||||
.if empty(PORT_OPTIONS:MOPTIMIZED_CFLAGS)
|
||||
@${REINPLACE_CMD} -e 's|$$(OPT)||' ${WRKSRC}/${MAKEFILE}
|
||||
.endif
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|^\(CC\) |#\1 | ; \
|
||||
s|^\(CFLAGS\) |#\1 | ; \
|
||||
s|^\(OPTS\) |#\1 | ; \
|
||||
s|gcc -E|$$(CC) -E|' ${WRKSRC}/Makefile
|
||||
|
||||
do-install:
|
||||
# Program.
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/x${PORTNAME} ${PREFIX}/bin/${PORTNAME}
|
||||
(cd ${WRKSRC} && ${INSTALL_PROGRAM} x${PORTNAME} \
|
||||
${STAGEDIR}${PREFIX}/bin/${PORTNAME})
|
||||
|
||||
# Data.
|
||||
${MKDIR} ${DATADIR}
|
||||
@${MKDIR} ${STAGEDIR}${DATADIR}
|
||||
.for d in rc rc-test
|
||||
${CP} -R ${WRKSRC}/${d} ${DATADIR}
|
||||
@(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${STAGEDIR}${DATADIR})
|
||||
.endfor
|
||||
|
||||
# Documentation (optional).
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
.endif
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
(cd ${WRKSRC} && ${INSTALL_DATA} README ${STAGEDIR}${DOCSDIR})
|
||||
|
||||
post-install:
|
||||
# Fix permissions.
|
||||
@${CHOWN} -R ${BINOWN}:${BINGRP} ${DATADIR}
|
||||
@${FIND} ${DATADIR} -type f -print0 | \
|
||||
${XARGS} -0 ${CHMOD} 644
|
||||
@${FIND} ${DATADIR} -type d -print0 | \
|
||||
${XARGS} -0 ${CHMOD} 755
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,18 +0,0 @@
|
||||
--- Makefile.orig Sun May 15 12:54:02 2005
|
||||
+++ Makefile Thu Jul 7 19:26:25 2005
|
||||
@@ -5,13 +5,12 @@
|
||||
#INDENT = indent
|
||||
|
||||
|
||||
-CC = gcc
|
||||
-CFLAGS = -O2 -fomit-frame-pointer -fpic -fno-strict-aliasing #-march=athlon-xp
|
||||
+CFLAGS = $(OPT)
|
||||
+OPT = -O2 -fomit-frame-pointer
|
||||
#DEBUG = -g -fno-omit-frame-pointer -O0
|
||||
|
||||
#options for fm_sim.c only:
|
||||
#no-crossjumping - gcc 3.3 breaks computed gotos, this seems to help a little
|
||||
-OPTS = -fno-cse-follow-jumps -fno-crossjumping
|
||||
#OPTS += -fno-strict-aliasing
|
||||
|
||||
#CFLAGS = $(CFLAGS_OPT) -fverbose-asm -W -Wimplicit -Wparentheses -Wpointer-arith \
|
@ -1,14 +1,15 @@
|
||||
fmars is Fast Memory Array Redcode Simulator
|
||||
|
||||
A specialized simulator for the game of Corewars. It's designed to be of
|
||||
particular use in automated redcode optimizers and evolvers. fmars borrows the
|
||||
idea from Martin Ankerl's qmars and pushes it to the extreme.
|
||||
A specialized simulator for the game of Corewars. It's designed to be
|
||||
of particular use in automated redcode optimizers and evolvers. fmars
|
||||
borrows the idea from Martin Ankerl's qmars and pushes it to the
|
||||
extreme.
|
||||
|
||||
It generates source code with special case for every possible opcode/addressing
|
||||
mode combination. This allows some optimizations that aren't possible in other
|
||||
simulators.
|
||||
It generates source code with special case for every possible
|
||||
opcode/addressing mode combination. This allows some optimizations
|
||||
that aren't possible in other simulators.
|
||||
|
||||
fmars is compatible with pMARS with an exception for p-space, which is not yet
|
||||
implemented.
|
||||
fmars is compatible with pMARS with an exception for p-space, which
|
||||
is not yet implemented.
|
||||
|
||||
WWW: http://www.v-lo.krakow.pl/~michal/fmars.html
|
||||
WWW: http://corewar.co.uk/janeczek/
|
||||
|
Loading…
Reference in New Issue
Block a user