Update to 1.23.

PR:		27671
Submitted by:	maintainer
This commit is contained in:
Maxim Sobolev 2001-05-27 07:31:02 +00:00
parent be06d57118
commit 3d0436f49d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=43109
3 changed files with 29 additions and 5 deletions

View File

@ -6,19 +6,22 @@
#
PORTNAME= wmfishtime
PORTVERSION= 1.21
PORTVERSION= 1.23
CATEGORIES= x11-clocks windowmaker
MASTER_SITES= http://www.ne.jp/asahi/linux/timecop/software/ \
http://www.freenix.no/~anders/
MAINTAINER= anders@fix.no
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
USE_GTK= yes
USE_X_PREFIX= yes
pre-build:
${PERL} -pi -e "s@gcc@${CC}@g; s@-O3@${CFLAGS}@g; \
s@gtk-config@${GTK_CONFIG}@g; s@-lgtk@-lgtk12@g" ${WRKSRC}/Makefile
GTK_LIBS?= `${GTK_CONFIG} --libs`
GTK_CFLAGS?= `${GTK_CONFIG} --cflags`
MAKE_ARGS+= CFLAGS="${CFLAGS} -Wall -I${LOCALBASE}/include ${GTK_CFLAGS}" \
GTK_LIBS="${GTK_LIBS}"
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmfishtime ${PREFIX}/bin

View File

@ -1 +1 @@
MD5 (wmfishtime-1.21.tar.gz) = a9f690aff8bf188f6e9bfab4f008623c
MD5 (wmfishtime-1.23.tar.gz) = ec10376dfb9b43eb7b519b20a1da71e6

View File

@ -0,0 +1,21 @@
--- Makefile.orig Sat May 26 22:49:41 2001
+++ Makefile Sun May 27 00:14:26 2001
@@ -6,17 +6,15 @@
# no user serviceable parts below this line
# optimization cflags
-CFLAGS = -O3 -Wall `gtk-config --cflags` ${EXTRA}
# profiling cflags
# CFLAGS=-ansi -pedantic -Wall -pg -O3 `gtk-config --cflags` ${EXTRA} -DPRO
# test coverage cflags
# CFLAGS=-fprofile-arcs -ftest-coverage -Wall -ansi -pedantic -g `gtk-config --cflags` ${EXTRA} -DPRO
-CC = gcc
SHELL = sh
OBJS = fishmon.o
-LIBS = `gtk-config --libs | sed "s/-lgtk//g"`
+LIBS = `echo $(GTK_LIBS) | sed "s/-lgtk12//g"` -lgnugetopt
INSTALL = -m 755
all: wmfishtime